summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-10-13 00:30:47 +0000
committerMike Frysinger <vapier@gentoo.org>2005-10-13 00:30:47 +0000
commit68c58eb78035bfde5573368a81c4ec2fdfd653fc (patch)
tree5a34bc85a949a74a61d4e1f31d0fcb76bb028c33 /games-misc/fortune-mod/fortune-mod-1.99.1-r2.ebuild
parent~ppc-macos keyword (diff)
downloadhistorical-68c58eb78035bfde5573368a81c4ec2fdfd653fc.tar.gz
historical-68c58eb78035bfde5573368a81c4ec2fdfd653fc.tar.bz2
historical-68c58eb78035bfde5573368a81c4ec2fdfd653fc.zip
Clean up misc crap.
Package-Manager: portage-2.0.53_rc5
Diffstat (limited to 'games-misc/fortune-mod/fortune-mod-1.99.1-r2.ebuild')
-rw-r--r--games-misc/fortune-mod/fortune-mod-1.99.1-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/games-misc/fortune-mod/fortune-mod-1.99.1-r2.ebuild b/games-misc/fortune-mod/fortune-mod-1.99.1-r2.ebuild
new file mode 100644
index 000000000000..3d81fdfc924f
--- /dev/null
+++ b/games-misc/fortune-mod/fortune-mod-1.99.1-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-misc/fortune-mod/fortune-mod-1.99.1-r2.ebuild,v 1.1 2005/10/13 00:30:47 vapier Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="The notorious fortune program"
+HOMEPAGE="http://www.redellipse.net/code/fortune"
+SRC_URI="http://www.redellipse.net/code/downloads/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc-macos ~ppc64 ~sparc ~x86"
+IUSE="offensive"
+
+DEPEND="app-text/recode"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+
+ sed -i \
+ -e 's:/games::' \
+ -e 's:/fortunes:/fortune:' \
+ -e '/^FORTDIR=/s:=.*:=$(prefix)/usr/bin:' \
+ -e '/^all:/s:$: fortune/fortune.man:' \
+ -e "/^OFFENSIVE=/s:=.*:=`use offensive && echo 1 || echo 0`:" \
+ Makefile || die "sed Makefile failed"
+}
+
+src_install() {
+ make prefix="${D}" install || die "make install failed"
+ dodoc ChangeLog INDEX Notes Offensive README TODO cookie-files
+}