summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2007-04-13 21:27:55 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2007-04-13 21:27:55 +0000
commit6564921653b8bbc4f7967e3365c6204413109538 (patch)
treed438c5ce8d0414cfd72c4ea13dbaefe4c737843c /games-fps/ut2004-da2/ut2004-da2-1.6_beta.ebuild
parentversion bump thanks to James Cloos <cloos@jhcloos.com> in bug 174268 (diff)
downloadhistorical-6564921653b8bbc4f7967e3365c6204413109538.tar.gz
historical-6564921653b8bbc4f7967e3365c6204413109538.tar.bz2
historical-6564921653b8bbc4f7967e3365c6204413109538.zip
Initial import. Ebuild by Paul Bredbury <brebs@sent.com>. Closing bug #118763.
Package-Manager: portage-2.1.2.3
Diffstat (limited to 'games-fps/ut2004-da2/ut2004-da2-1.6_beta.ebuild')
-rw-r--r--games-fps/ut2004-da2/ut2004-da2-1.6_beta.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/games-fps/ut2004-da2/ut2004-da2-1.6_beta.ebuild b/games-fps/ut2004-da2/ut2004-da2-1.6_beta.ebuild
new file mode 100644
index 000000000000..774d720d0b77
--- /dev/null
+++ b/games-fps/ut2004-da2/ut2004-da2-1.6_beta.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004-da2/ut2004-da2-1.6_beta.ebuild,v 1.1 2007/04/13 21:27:55 wolf31o2 Exp $
+
+MOD_NAME="Defence Alliance 2"
+MOD_DIR="DA2"
+MOD_DESC="assault mod with improved bot AI"
+MOD_BINS="da2"
+MOD_ICON="defencealliance2.xpm"
+
+inherit games games-mods
+
+MY_PV=${PV/_beta/beta}
+
+HOMEPAGE="http://www.planetunreal.com/da/2/"
+# The 1.6 zipfile is unreable.
+# http://forums.beyondunreal.com/showthread.php?t=178603&page=2
+SRC_URI="http://home.coc-ag.de/dressler-ro/liflg/files/native/defence.alliance2_${MY_PV}-english.run"
+
+# See Help/readme.txt
+LICENSE="free-noncomm"
+
+RDEPEND="${CATEGORY}/${GAME}"
+
+src_unpack() {
+ unpack_makeself
+ unpack ./da2.tar.gz
+
+ mv *.xpm "${MOD_DIR}" || die
+}