summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-03-12 08:01:05 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-03-12 08:01:05 +0000
commit727527a4ecc3b19323ebdc33d5da56d3733f37d4 (patch)
treef0ae1382573f8878752b93c76311b50239b94437 /games-fps/openarena/openarena-0.8.1-r1.ebuild
parentbackport FQDN patch from upstream (diff)
downloadhistorical-727527a4ecc3b19323ebdc33d5da56d3733f37d4.tar.gz
historical-727527a4ecc3b19323ebdc33d5da56d3733f37d4.tar.bz2
historical-727527a4ecc3b19323ebdc33d5da56d3733f37d4.zip
Fixing CFLAGS and LDFLAGS issues raised on bug #255453
Package-Manager: portage-2.1.7.17/cvs/Linux i686
Diffstat (limited to 'games-fps/openarena/openarena-0.8.1-r1.ebuild')
-rw-r--r--games-fps/openarena/openarena-0.8.1-r1.ebuild8
1 files changed, 2 insertions, 6 deletions
diff --git a/games-fps/openarena/openarena-0.8.1-r1.ebuild b/games-fps/openarena/openarena-0.8.1-r1.ebuild
index abe6b26aa457..5ab788f0cbe9 100644
--- a/games-fps/openarena/openarena-0.8.1-r1.ebuild
+++ b/games-fps/openarena/openarena-0.8.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/openarena/openarena-0.8.1-r1.ebuild,v 1.2 2010/03/10 09:54:08 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/openarena/openarena-0.8.1-r1.ebuild,v 1.3 2010/03/12 08:01:05 tupone Exp $
EAPI=2
inherit eutils flag-o-matic versionator games
@@ -39,11 +39,6 @@ src_prepare() {
cd "${WORKDIR}"
epatch "${FILESDIR}"/${P}-makefile.patch \
"${FILESDIR}"/${P}-unbundling.patch
- append-cflags -fno-strict-aliasing # bug #268851
- sed -i \
- -e "s:%CFLAGS%:${CFLAGS}:g" \
- "${MY_S}"/Makefile \
- || die "sed failed"
sed -i \
-e '/ALDRIVER_DEFAULT/s/libopenal.so.0/libopenal.so/' \
"${MY_S}"/code/client/snd_openal.c \
@@ -63,6 +58,7 @@ src_compile() {
cd "${MY_S}"
emake \
+ V=1 \
DEFAULT_BASEDIR="${DIR}" \
BR="${BUILD_DIR}" \
${myopts} \