summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-09 18:10:15 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-09 18:10:15 +0000
commitad69522f5e6b57d5350a46ebda16dbe091d0e4b6 (patch)
tree1580e46b57d69a004ab7bafb3f19590605890684 /games-fps/doomlegacy
parentNew version 'n cleanup (diff)
downloadhistorical-ad69522f5e6b57d5350a46ebda16dbe091d0e4b6.tar.gz
historical-ad69522f5e6b57d5350a46ebda16dbe091d0e4b6.tar.bz2
historical-ad69522f5e6b57d5350a46ebda16dbe091d0e4b6.zip
games-fps uNF uNF uNF
Diffstat (limited to 'games-fps/doomlegacy')
-rw-r--r--games-fps/doomlegacy/ChangeLog26
-rw-r--r--games-fps/doomlegacy/Manifest6
-rw-r--r--games-fps/doomlegacy/doomlegacy-1.40-r2.ebuild102
-rw-r--r--games-fps/doomlegacy/files/1.40-errno.patch55
-rw-r--r--games-fps/doomlegacy/files/CARD8.patch10
-rw-r--r--games-fps/doomlegacy/files/digest-doomlegacy-1.40-r23
-rw-r--r--games-fps/doomlegacy/files/makefile.patch122
7 files changed, 324 insertions, 0 deletions
diff --git a/games-fps/doomlegacy/ChangeLog b/games-fps/doomlegacy/ChangeLog
new file mode 100644
index 000000000000..6c028ed211a9
--- /dev/null
+++ b/games-fps/doomlegacy/ChangeLog
@@ -0,0 +1,26 @@
+# ChangeLog for app-games/doomlegacy
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/doomlegacy/ChangeLog,v 1.1 2003/09/09 18:10:14 vapier Exp $
+
+*doomlegacy-1.40-r2 (13 Aug 2003)
+
+ 13 Aug 2003; Mike Frysinger <vapier@gentoo.org> :
+ Remove x86 specific code (#26201). Add games.eclass support.
+
+*doomlegacy-1.40-r1 (06 Mar 2003)
+
+ 29 Jul 2003; Michael Sterrett <msterret@gentoo.org>
+ doomlegacy-1.40-r1.ebuild:
+ use sed -i
+
+ 06 Mar 2003; Mike Frysinger <vapier@gentoo.org> :
+ Added a patch to fix glibc errno (#16267) #16715.
+ Also tweaked makefile patch to allow custom CFLAGS.
+
+*doomlegacy-1.40 (28 Oct 2002)
+
+ 30 Oct 2002; Mike Frysinger <vapier@gentoo.org> :
+ Added a small patch for people who arent running with `opengl-update xfree`
+
+ 28 Oct 2002; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by Dries Harnie <Bulletz_1900@hotmail.com>.
diff --git a/games-fps/doomlegacy/Manifest b/games-fps/doomlegacy/Manifest
new file mode 100644
index 000000000000..256f4e6afb77
--- /dev/null
+++ b/games-fps/doomlegacy/Manifest
@@ -0,0 +1,6 @@
+MD5 3281a103dc695a80a8c228705d9cd423 ChangeLog 960
+MD5 c491b0d2493438aaebdbd7b2fe5539c0 doomlegacy-1.40-r2.ebuild 2645
+MD5 f745c34c32cb4f83e2ae7365d8453d69 files/1.40-errno.patch 1519
+MD5 478b45b54a9f909153c81f7785dde8cc files/CARD8.patch 246
+MD5 5c83faa6ece3a499e511e5438f38cf72 files/makefile.patch 4523
+MD5 cf078f54816f54fe5eccd2914132e177 files/digest-doomlegacy-1.40-r2 183
diff --git a/games-fps/doomlegacy/doomlegacy-1.40-r2.ebuild b/games-fps/doomlegacy/doomlegacy-1.40-r2.ebuild
new file mode 100644
index 000000000000..5d60626022d8
--- /dev/null
+++ b/games-fps/doomlegacy/doomlegacy-1.40-r2.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/doomlegacy/doomlegacy-1.40-r2.ebuild,v 1.1 2003/09/09 18:10:14 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="Doom legacy, THE doom port"
+HOMEPAGE="http://legacy.newdoom.com/"
+SRC_URI="mirror://sourceforge/doomlegacy/legacy_${PV/./}_src.tar.gz
+ mirror://sourceforge/doomlegacy/legacy.dat.gz
+ http://www.lbjhs.net/~jessh/lsdldoom/doom1.wad.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc"
+
+DEPEND="x86? ( >=dev-lang/nasm-0.98 )
+ >=sys-apps/sed-4
+ virtual/opengl
+ virtual/x11"
+
+S="${WORKDIR}/${PN}_src/"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PV}-errno.patch
+
+ # fix locations where objects/binaries get installed
+ mkdir {.,${S}}/{bin,objs}
+ cd ${S}
+ epatch ${FILESDIR}/makefile.patch
+
+ # if using the non-xfree version of GL header files, we need to patch ...
+ [ -z "`grep XFree86 /usr/X11R6/include/GL/glx.h`" ] && \
+ epatch ${FILESDIR}/CARD8.patch
+
+ # disable logfile writing
+ sed -i \
+ -e 's:#define LOGMESSAGES::' doomdef.h || \
+ die 'sed doomdef.h failed'
+
+ # make sure the games can find the wads/data files
+ sed -i \
+ -e "s:#define DEFAULTWADLOCATION1:#define DEFAULTWADLOCATION1 \"${GAMES_DATADIR}/${PN}\" //:" \
+ linux_x/i_system.c || \
+ die 'sed linux_x/i_system.c failed'
+
+ # move opengl lib file because it's not useful to anyone else
+ sed -i \
+ -e "s:\"r_opengl:\"${GAMES_LIBDIR}/${PN}/r_opengl:" \
+ linux_x/i_video_xshm.c
+
+ cd linux_x/musserv
+ make -f Makefile.linux clean
+}
+
+src_compile() {
+ # this is ugly but it's late (here) and it works
+ local useasm=
+ [ `use x86` ] && useasm="USEASM=1"
+ local redosnd=0
+ make \
+ EXTRAOPTS="${CFLAGS}" \
+ LINUX=1 \
+ X=1 \
+ ${useasm} \
+ || redosnd=1
+ if [ ${redosnd} -eq 1 ] ; then
+ cd linux_x/sndserv
+ make clean || die "clean snd srv failed"
+ make EXTRAOPTS="${CFLAGS}" || die "snd serv failed"
+ fi
+ cd ${S}
+ make \
+ EXTRAOPTS="${CFLAGS}" \
+ LINUX=1 \
+ X=1 \
+ ${useasm} \
+ || die "build failed"
+}
+
+src_install() {
+ dogamesbin linux_x/musserv/linux/musserver linux_x/sndserv/linux/llsndserv bin/llxdoom
+ exeinto ${GAMES_LIBDIR}/${PN}
+ doexe bin/r_opengl.so
+
+ insinto ${GAMES_DATADIR}/${PN}
+ doins ${WORKDIR}/{legacy.dat,doom1.wad}
+
+ dohtml _doc/*.html
+ rm _doc/*.html
+ dodoc _doc/*
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ ewarn "Software support is broken with latest XFree versions."
+ ewarn "If doomlegacy crashes with 'BadColor (invalid Colormap parameter)',"
+ ewarn "then please start the game with the '-opengl' parameter."
+ ewarn "See bug #19290 for more information."
+}
diff --git a/games-fps/doomlegacy/files/1.40-errno.patch b/games-fps/doomlegacy/files/1.40-errno.patch
new file mode 100644
index 000000000000..f784c7ebb5fd
--- /dev/null
+++ b/games-fps/doomlegacy/files/1.40-errno.patch
@@ -0,0 +1,55 @@
+--- ./doomlegacy_src/linux_x/sndserv/linux.c.orig 2003-03-06 08:03:22.000000000 -0500
++++ ./doomlegacy_src/linux_x/sndserv/linux.c 2003-03-06 08:04:09.000000000 -0500
+@@ -36,7 +36,7 @@
+ //
+ //-----------------------------------------------------------------------------
+
+-
++#include <errno.h>
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <fcntl.h>
+@@ -67,7 +67,6 @@
+ int* arg )
+ {
+ int rc;
+- extern int errno;
+
+ rc = ioctl(fd, command, arg);
+ if (rc < 0)
+--- ./doomlegacy_src/linux_x/i_sound.c.orig 2003-03-06 08:03:07.000000000 -0500
++++ ./doomlegacy_src/linux_x/i_sound.c 2003-03-06 08:03:49.000000000 -0500
+@@ -78,6 +78,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <stdarg.h>
++#include <errno.h>
+
+ #include <math.h>
+
+@@ -261,7 +262,6 @@
+ int* arg )
+ {
+ int rc;
+- extern int errno;
+
+ rc = ioctl(fd, command, arg);
+ if (rc < 0)
+--- ./doomlegacy_src/linux_x/i_video_xshm.c.orig 2003-03-06 08:03:12.000000000 -0500
++++ ./doomlegacy_src/linux_x/i_video_xshm.c 2003-03-06 08:04:01.000000000 -0500
+@@ -114,6 +114,7 @@
+ //
+ //-----------------------------------------------------------------------------
+
++#include <errno.h>
+ #include <stdlib.h>
+ #include <unistd.h>
+ #include <sys/ipc.h>
+@@ -1401,7 +1402,6 @@
+ id = shmget((key_t)key, size, IPC_CREAT|0777);
+ if (id==-1)
+ {
+- extern int errno;
+ fprintf(stderr, "errno=%d\n", errno);
+ I_Error("Could not get any shared memory");
+ }
diff --git a/games-fps/doomlegacy/files/CARD8.patch b/games-fps/doomlegacy/files/CARD8.patch
new file mode 100644
index 000000000000..990f20b4e362
--- /dev/null
+++ b/games-fps/doomlegacy/files/CARD8.patch
@@ -0,0 +1,10 @@
+--- hardware/hw_data.h.orig 2002-10-18 18:16:30.000000000 +0200
++++ hardware/hw_data.h 2002-10-18 18:20:52.000000000 +0200
+@@ -57,7 +57,6 @@
+
+ #ifndef __WIN32__
+ #ifndef DONTDEFINEBOOL
+-typedef int BOOL;
+ #define TRUE 1
+ #define FALSE 0
+ #endif
diff --git a/games-fps/doomlegacy/files/digest-doomlegacy-1.40-r2 b/games-fps/doomlegacy/files/digest-doomlegacy-1.40-r2
new file mode 100644
index 000000000000..13248252b265
--- /dev/null
+++ b/games-fps/doomlegacy/files/digest-doomlegacy-1.40-r2
@@ -0,0 +1,3 @@
+MD5 caad0e3ee637a00520b641c9953f079e legacy_140_src.tar.gz 1654331
+MD5 4a3e88115c20f42d18e88f5666f8d4d6 legacy.dat.gz 334964
+MD5 66851d7cecbc7845d612e7073c1355ad doom1.wad.gz 1765820
diff --git a/games-fps/doomlegacy/files/makefile.patch b/games-fps/doomlegacy/files/makefile.patch
new file mode 100644
index 000000000000..571c9fc5e58b
--- /dev/null
+++ b/games-fps/doomlegacy/files/makefile.patch
@@ -0,0 +1,122 @@
+--- makefile.orig 2003-08-12 23:21:29.000000000 -0400
++++ makefile 2003-08-12 23:22:30.000000000 -0400
+@@ -310,13 +310,13 @@
+ ifdef LINUX
+
+ # subdirectory for objects
+- O=../objs
+- BIN=../bin
++ O=objs
++ BIN=bin
+ MUSSERV=linux_x/musserv
+ SNDSERV=linux_x/sndserv
+
+ #use the x86 asm code
+- USEASM=1
++ #USEASM=1
+
+ OPTS=-DLINUX -DOLD_SOUND_DRIVER -DMUSSERV -DSNDSERV -DHWRENDER -DDIRECTFULLSCREEN
+ X=1
+@@ -360,7 +360,7 @@
+ SNDSERV=linux_x/sndserv
+
+ #use the x86 asm code
+- USEASM=1
++ #USEASM=1
+ ifndef FBSD_SDL
+ OPTS=-DLINUX -DFREEBSD -DOLD_SOUND_DRIVER -DSNDSERV -DHWRENDER -DDIRECTFULLSCREEN
+ ifndef FBSD_GGI
+@@ -444,7 +444,7 @@
+
+ #use the x86 asm code
+ NASM=nasm
+- USEASM=1
++ #USEASM=1
+ PROFILEMODE=1
+ # options
+ OPTS=-Zmt -D__OS2__ -I.. -I. -Ios2
+@@ -473,7 +473,7 @@
+ ifdef PGCC
+ CFLAGS = -g -pg -DPARANOIA -fwritable-strings $(OPTS)
+ else
+- CFLAGS = -g -pg -m486 -O3 -ffast-math -fwritable-strings $(OPTS)
++ CFLAGS = -g -pg $(EXTRAOPTS) $(OPTS)
+ endif
+ LDFLAGS = -g -pg -L/usr/X11R6/lib
+ else
+@@ -481,13 +481,13 @@
+
+ # build a normal optimised version
+ ifdef PGCC
+- CFLAGS = $(OPTS) -mpentium -O6 -ffast-math -fomit-frame-pointer -fwritable-strings
++ CFLAGS = $(OPTS) $(EXTRAOPTS)
+ # -fgcse -fcse-follow-jumps -fcse-skip-blocks -frerun-cse-after-loop -ffunction-cse \
+ # -fexpensive-optimizations -fforce-mem -fstrength-reduce -fthread-jumps \
+ # -fregmove -fschedule-insns -fschedule-insns2 -fmove-all-movables \
+ # -fcaller-saves -finline-functions -mieee-fp -mfp-ret-in-387 -m80387 -mhard-float -finline
+ else
+- CFLAGS = -m486 -O3 -ffast-math -fomit-frame-pointer -fwritable-strings $(OPTS)
++ CFLAGS = $(EXTRAOPTS) $(OPTS)
+ endif
+ endif
+
+@@ -644,7 +644,7 @@
+
+ #dll
+ dll : $(O)/r_opengl.o $(O)/ogl_x11.o
+- $(CC) -mpentium -O6 -o $(BIN)/r_opengl.so -shared -nostartfiles $(O)/r_opengl.o $(O)/ogl_x11.o -L/usr/X11R6/lib -L/usr/local/lib -lX11 -lXext -lGL -lGLU -lm
++ $(CC) $(CFLAGS) -o $(BIN)/r_opengl.so -shared -nostartfiles $(O)/r_opengl.o $(O)/ogl_x11.o -L/usr/X11R6/lib -L/usr/local/lib -lX11 -lXext -lGL -lGLU -lm
+
+ musserv:
+ @mkdir -p $(MUSSERV)/linux
+@@ -658,7 +658,7 @@
+
+ ifdef LINUX
+ $(O)/r_opengl.o: hardware/r_opengl/r_opengl.c hardware/r_opengl/r_opengl.h
+- $(CC) -mpentium -O6 -o $(O)/r_opengl.o -DHWRENDER -DVID_X11 -DLINUX $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/r_opengl.c
++ $(CC) $(CFLAGS) -o $(O)/r_opengl.o -DHWRENDER -DVID_X11 -DLINUX $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/r_opengl.c
+ endif
+
+ ifdef SDL
+@@ -672,16 +672,16 @@
+ $(CC) $(CFLAGS) $(LDFLAGS) $(WFLAGS) -I/usr/X11R6/include -c $< -o $@
+ else #FBSD_SDL
+ $(O)/r_opengl.o: hardware/r_opengl/r_opengl.c hardware/r_opengl/r_opengl.h
+- $(CC) -mpentium -O6 -o $(O)/r_opengl.o -DHWRENDER -DVID_X11 -DLINUX -DFREEBSD $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/r_opengl.c
++ $(CC) $(CFLAGS) -o $(O)/r_opengl.o -DHWRENDER -DVID_X11 -DLINUX -DFREEBSD $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/r_opengl.c
+ endif #FBSD_SDL
+ endif #FREEBSD
+
+ ifndef FREEBSD
+ $(O)/ogl_x11.o: hardware/r_opengl/ogl_x11.c hardware/r_opengl/r_opengl.h
+- $(CC) -mpentium -O6 -o $(O)/ogl_x11.o -DHWRENDER -DVID_X11 -DLINUX $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/ogl_x11.c
++ $(CC) $(CFLAGS) -o $(O)/ogl_x11.o -DHWRENDER -DVID_X11 -DLINUX $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/ogl_x11.c
+ else
+ $(O)/ogl_x11.o: hardware/r_opengl/ogl_x11.c hardware/r_opengl/r_opengl.h
+- $(CC) -mpentium -O6 -o $(O)/ogl_x11.o -DHWRENDER -DVID_X11 -DLINUX -DFREEBSD $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/ogl_x11.c
++ $(CC) $(CFLAGS) -o $(O)/ogl_x11.o -DHWRENDER -DVID_X11 -DLINUX -DFREEBSD $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/ogl_x11.c
+ endif
+
+
+--- linux_x/musserv/Makefile.linux.orig 2003-08-12 23:23:27.000000000 -0400
++++ linux_x/musserv/Makefile.linux 2003-08-12 23:23:43.000000000 -0400
+@@ -3,7 +3,7 @@
+ #
+
+ CC = gcc
+-CFLAGS = -I. -Wall -O2 -m486
++CFLAGS = -I. -Wall $(EXTRAOPTS)
+ LDFLAGS =
+ #LDFLAGS = -static
+
+--- linux_x/sndserv/Makefile.orig 2003-08-12 23:23:52.000000000 -0400
++++ linux_x/sndserv/Makefile 2003-08-12 23:24:05.000000000 -0400
+@@ -22,7 +22,7 @@
+ #
+
+ CC=gcc
+-CFLAGS=-O2 -m486 -Wall -DNORMALUNIX -DLINUX
++CFLAGS=-O2 -Wall -DNORMALUNIX -DLINUX
+ ifdef FREEBSD
+ CFLAGS:=${CFLAGS} -DFREEBSD
+ endif