summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-06-23 04:25:39 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-06-23 04:25:39 +0000
commit95e311a82be1dcce10abbd5eacd4942a0f7f5e73 (patch)
tree21371cd780aeca12477d52672824019b454493ca /games-fps/alephone/alephone-20100424.ebuild
parentConvert pkg_postinst() message about polkitd home directory to new user.eclas... (diff)
downloadhistorical-95e311a82be1dcce10abbd5eacd4942a0f7f5e73.tar.gz
historical-95e311a82be1dcce10abbd5eacd4942a0f7f5e73.tar.bz2
historical-95e311a82be1dcce10abbd5eacd4942a0f7f5e73.zip
Fix building with sys-devel/automake >= 1.12 wrt #422557
Package-Manager: portage-2.2.0_alpha110/cvs/Linux x86_64
Diffstat (limited to 'games-fps/alephone/alephone-20100424.ebuild')
-rw-r--r--games-fps/alephone/alephone-20100424.ebuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/games-fps/alephone/alephone-20100424.ebuild b/games-fps/alephone/alephone-20100424.ebuild
index c6b42715273b..d1c033509c72 100644
--- a/games-fps/alephone/alephone-20100424.ebuild
+++ b/games-fps/alephone/alephone-20100424.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/alephone/alephone-20100424.ebuild,v 1.5 2011/09/13 08:45:26 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/alephone/alephone-20100424.ebuild,v 1.6 2012/06/23 04:25:39 ssuominen Exp $
EAPI=2
inherit autotools eutils games
@@ -20,7 +20,7 @@ RDEPEND="media-libs/sdl-net
media-libs/libsdl[video]
dev-libs/expat
dev-libs/zziplib
- media-libs/libpng
+ media-libs/libpng:0
alsa? ( media-libs/alsa-lib )
mad? ( media-libs/libmad )
mpeg? ( media-libs/smpeg )
@@ -38,21 +38,25 @@ S=${WORKDIR}/${MY_P}
src_prepare() {
sed "s:GAMES_DATADIR:${GAMES_DATADIR}:g" \
"${FILESDIR}"/${PN}.sh > "${T}"/${PN}.sh \
- || die "sed failed"
+ || die
# try using the system expat - bug #251108
sed -i \
-e '/SUBDIRS/ s/Expat//' \
-e 's/Expat\/libexpat.a/-lexpat/' \
Source_Files/Makefile.am \
- || die "sed failed"
+ || die
sed -i \
-e '/Expat/d' \
configure.ac \
- || die "sed failed"
+ || die
rm -rf Source_Files/Expat
- epatch "${FILESDIR}"/${P}-boost_145.patch \
+ # for automake 1.12 compability - bug #422557
+ sed -i -e 's:AC_PROG_CC:&\nAC_PROG_OBJCXX:' configure.ac || die
+
+ epatch \
+ "${FILESDIR}"/${P}-boost_145.patch \
"${FILESDIR}"/${P}-png15.patch
eautoreconf