summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-01-23 03:04:40 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-01-23 03:04:40 +0000
commit4cc0b62862443b5aaf923270adbe9718ca4a5bef (patch)
treee1593a4ef410bc7c5d330437d192055f9fcfa6d4 /games-engines
parentheader fix (diff)
downloadhistorical-4cc0b62862443b5aaf923270adbe9718ca4a5bef.tar.gz
historical-4cc0b62862443b5aaf923270adbe9718ca4a5bef.tar.bz2
historical-4cc0b62862443b5aaf923270adbe9718ca4a5bef.zip
mpeg2 support needs vorbis (bug #79149) so turn it off if -oggvorbis; add flac support; use doicon
Package-Manager: portage-2.0.51-r14
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/scummvm/ChangeLog7
-rw-r--r--games-engines/scummvm/Manifest4
-rw-r--r--games-engines/scummvm/scummvm-0.7.0.ebuild11
3 files changed, 15 insertions, 7 deletions
diff --git a/games-engines/scummvm/ChangeLog b/games-engines/scummvm/ChangeLog
index d99b10aaab59..c62931b84430 100644
--- a/games-engines/scummvm/ChangeLog
+++ b/games-engines/scummvm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-engines/scummvm
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/ChangeLog,v 1.18 2005/01/20 06:57:34 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/ChangeLog,v 1.19 2005/01/23 03:04:40 mr_bones_ Exp $
+
+ 22 Jan 2005; Michael Sterrett <mr_bones_@gentoo.org> scummvm-0.7.0.ebuild:
+ mpeg2 support needs vorbis (bug #79149) so turn it off if -oggvorbis
+ add flac support
+ use doicon
20 Jan 2005; Michael Sterrett <mr_bones_@gentoo.org> scummvm-0.7.0.ebuild:
don't try to run the non-working test (bug #77507)
diff --git a/games-engines/scummvm/Manifest b/games-engines/scummvm/Manifest
index 92da3bbf9a7d..c264d8c35ae5 100644
--- a/games-engines/scummvm/Manifest
+++ b/games-engines/scummvm/Manifest
@@ -1,6 +1,6 @@
-MD5 1e0bebdba38f7e0dc7ad0140be2dfe1f ChangeLog 4474
+MD5 ac61f6a8a88b95683efa15734b4ad092 ChangeLog 4655
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 4000f2ba55277a166c085f4aa73fbab1 scummvm-0.6.1b.ebuild 1599
-MD5 62ccde30150abec208275de330c1470c scummvm-0.7.0.ebuild 1554
+MD5 cc00cd20925f3457fdc035165c871f1f scummvm-0.7.0.ebuild 1666
MD5 57586dda15d6cc8d56f0cb5f247d627b files/digest-scummvm-0.7.0 67
MD5 5d563fb08477f6c67b3254b545554b7c files/digest-scummvm-0.6.1b 68
diff --git a/games-engines/scummvm/scummvm-0.7.0.ebuild b/games-engines/scummvm/scummvm-0.7.0.ebuild
index c39456e5dbcf..db5a0d109f43 100644
--- a/games-engines/scummvm/scummvm-0.7.0.ebuild
+++ b/games-engines/scummvm/scummvm-0.7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/scummvm-0.7.0.ebuild,v 1.4 2005/01/20 06:57:34 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/scummvm-0.7.0.ebuild,v 1.5 2005/01/23 03:04:40 mr_bones_ Exp $
inherit eutils games
@@ -11,7 +11,7 @@ SRC_URI="mirror://sourceforge/scummvm/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc sparc x86"
-IUSE="alsa debug mad oggvorbis sdl zlib"
+IUSE="alsa debug flac mad oggvorbis sdl zlib"
RESTRICT="maketest" # it only looks like there's a test there #77507
RDEPEND="virtual/libc
@@ -24,6 +24,7 @@ RDEPEND="virtual/libc
)
alsa? ( >=media-libs/alsa-lib-0.9 )
mad? ( media-libs/libmad )
+ flac? ( media-libs/flac )
zlib? ( sys-libs/zlib )"
DEPEND="${RDEPEND}
x86? ( dev-lang/nasm )"
@@ -38,10 +39,13 @@ src_compile() {
|| myconf="${myconf} --disable-debug"
# not an autoconf script so dont call econf
+ # mpeg2 support needs vorbis (bug #79149) so turn it off if -oggvorbis
./configure \
$(use_enable alsa) \
$(use_enable mad) \
+ $(use_enable flac) \
$(use_enable oggvorbis vorbis) \
+ $(use_enable oggvorbis mpeg2) \
$(use_enable zlib) \
$(use_enable x86 nasm) \
${myconf} \
@@ -53,8 +57,7 @@ src_install() {
dogamesbin scummvm || die "dobin failed"
doman scummvm.6
dodoc NEWS README TODO
- insinto /usr/share/pixmaps
- doins scummvm.xpm || die "doins failed"
+ doicon scummvm.xpm
make_desktop_entry scummvm ScummVM
prepgamesdirs
}