summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-06-20 19:17:46 +0000
committerMike Frysinger <vapier@gentoo.org>2006-06-20 19:17:46 +0000
commitd89909b6bf3565b508a018ef4e4f2f21f7aefd79 (patch)
treea9046f2d1f261c1573d9b401b58c79406acfc7cc /games-emulation
parentReplace patch with a refreshed one in correct unix format. (diff)
downloadhistorical-d89909b6bf3565b508a018ef4e4f2f21f7aefd79.tar.gz
historical-d89909b6bf3565b508a018ef4e4f2f21f7aefd79.tar.bz2
historical-d89909b6bf3565b508a018ef4e4f2f21f7aefd79.zip
use cleaner method of supporting multilib
Package-Manager: portage-2.1.1_pre1-r1
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/nestra/nestra-0.66-r1.ebuild14
-rw-r--r--games-emulation/snes9x/snes9x-1.43-r1.ebuild9
-rw-r--r--games-emulation/zsnes/zsnes-1.42.ebuild12
3 files changed, 14 insertions, 21 deletions
diff --git a/games-emulation/nestra/nestra-0.66-r1.ebuild b/games-emulation/nestra/nestra-0.66-r1.ebuild
index 903d93c5ea60..89b679b5b989 100644
--- a/games-emulation/nestra/nestra-0.66-r1.ebuild
+++ b/games-emulation/nestra/nestra-0.66-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/nestra/nestra-0.66-r1.ebuild,v 1.13 2006/02/11 04:44:27 joshuabaergen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/nestra/nestra-0.66-r1.ebuild,v 1.14 2006/06/20 19:16:06 vapier Exp $
-inherit eutils toolchain-funcs flag-o-matic games
+inherit eutils toolchain-funcs flag-o-matic multilib games
PATCH="${P/-/_}-7.diff"
DESCRIPTION="NES emulation for Linux/x86"
@@ -21,11 +21,6 @@ DEPEND="${RDEPEND}"
S=${WORKDIR}/${PN}
-pkg_setup() {
- games_pkg_setup
- use amd64 && export ABI=x86
-}
-
src_unpack() {
unpack ${A}
cd "${S}"
@@ -40,6 +35,11 @@ src_unpack() {
|| die "sed failed"
}
+src_compile() {
+ use amd64 && multilib_toolchain_setup x86
+ games_src_compile
+}
+
src_install() {
dogamesbin nestra || die "dogamesbin failed"
dodoc BUGS CHANGES README
diff --git a/games-emulation/snes9x/snes9x-1.43-r1.ebuild b/games-emulation/snes9x/snes9x-1.43-r1.ebuild
index bfc59a026a17..3e44e18e4326 100644
--- a/games-emulation/snes9x/snes9x-1.43-r1.ebuild
+++ b/games-emulation/snes9x/snes9x-1.43-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/snes9x/snes9x-1.43-r1.ebuild,v 1.8 2006/04/13 20:33:52 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/snes9x/snes9x-1.43-r1.ebuild,v 1.9 2006/06/20 19:17:46 vapier Exp $
# 3dfx support (glide) is disabled because it requires
# glide-v2 while we only provide glide-v3 in portage
@@ -36,11 +36,6 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${P}-src
-pkg_setup() {
- games_pkg_setup
- use amd64 && [[ -z ${NATIVE_AMD64_BUILD_PLZ} ]] && has_multilib_profile && ABI=x86
-}
-
src_unpack() {
unpack ${A}
cd "${S}"/snes9x
@@ -64,6 +59,8 @@ src_unpack() {
}
src_compile() {
+ [[ -z ${NATIVE_AMD64_BUILD_PLZ} ]] && use amd64 && multilib_toolchain_setup x86
+
local vidconf=
local target=
local vid=
diff --git a/games-emulation/zsnes/zsnes-1.42.ebuild b/games-emulation/zsnes/zsnes-1.42.ebuild
index 2d7e014663d5..4e64e501b7b7 100644
--- a/games-emulation/zsnes/zsnes-1.42.ebuild
+++ b/games-emulation/zsnes/zsnes-1.42.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/zsnes/zsnes-1.42.ebuild,v 1.12 2006/04/13 20:36:47 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/zsnes/zsnes-1.42.ebuild,v 1.13 2006/06/20 19:17:03 vapier Exp $
-inherit eutils flag-o-matic games
+inherit eutils flag-o-matic multilib games
DESCRIPTION="SNES (Super Nintendo) emulator that uses x86 assembly"
HOMEPAGE="http://www.zsnes.com/ http://ipherswipsite.com/zsnes/"
@@ -23,12 +23,7 @@ DEPEND="${RDEPEND}
sys-devel/automake
>=sys-devel/autoconf-2.58"
-S="${WORKDIR}/${PN}_${PV//./_}"
-
-pkg_setup() {
- games_pkg_setup
- use amd64 && export ABI=x86
-}
+S=${WORKDIR}/${PN}_${PV//./_}
src_unpack() {
unpack ${A}
@@ -40,6 +35,7 @@ src_unpack() {
}
src_compile() {
+ use amd64 && multilib_toolchain_setup x86
cd src
egamesconf \
$(use_enable png libpng) \