summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-06-07 05:28:57 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-06-07 05:28:57 +0000
commitd1b076405ac49f1c26f9815915e163ecf388b07a (patch)
tree2481b2a5ba39e9c8efb041e005944800fe7a9646 /games-emulation
parentstable keywords (diff)
downloadhistorical-d1b076405ac49f1c26f9815915e163ecf388b07a.tar.gz
historical-d1b076405ac49f1c26f9815915e163ecf388b07a.tar.bz2
historical-d1b076405ac49f1c26f9815915e163ecf388b07a.zip
IUSE; tidy; error check sed
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/fake64/ChangeLog8
-rw-r--r--games-emulation/fake64/Manifest4
-rw-r--r--games-emulation/fake64/fake64-0.0.4_pre20021020.ebuild44
3 files changed, 33 insertions, 23 deletions
diff --git a/games-emulation/fake64/ChangeLog b/games-emulation/fake64/ChangeLog
index 52719ef4af33..39d7659b2c54 100644
--- a/games-emulation/fake64/ChangeLog
+++ b/games-emulation/fake64/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/fake64
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/fake64/ChangeLog,v 1.1 2003/09/19 05:06:16 vapier Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/fake64/ChangeLog,v 1.2 2004/06/07 05:28:57 mr_bones_ Exp $
+
+ 06 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ fake64-0.0.4_pre20021020.ebuild:
+ IUSE; tidy; error check sed
*fake64-0.0.4_pre20021020 (19 Sep 2003)
diff --git a/games-emulation/fake64/Manifest b/games-emulation/fake64/Manifest
index af846d12c280..f97be4d58b15 100644
--- a/games-emulation/fake64/Manifest
+++ b/games-emulation/fake64/Manifest
@@ -1,4 +1,4 @@
-MD5 9704c3f16f3026b7dcefa28f07c20730 fake64-0.0.4_pre20021020.ebuild 1440
-MD5 16e09e4bb23917c8c79cba1ff9469123 ChangeLog 362
+MD5 9c255677fd285502a9d877813781ed5f ChangeLog 485
+MD5 cb5902be6e21498648456ffbd3367095 fake64-0.0.4_pre20021020.ebuild 1660
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 e785cd21df88bb483a1532f74e2afe9b files/digest-fake64-0.0.4_pre20021020 70
diff --git a/games-emulation/fake64/fake64-0.0.4_pre20021020.ebuild b/games-emulation/fake64/fake64-0.0.4_pre20021020.ebuild
index e9996e4d76fe..af5735974326 100644
--- a/games-emulation/fake64/fake64-0.0.4_pre20021020.ebuild
+++ b/games-emulation/fake64/fake64-0.0.4_pre20021020.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/fake64/fake64-0.0.4_pre20021020.ebuild,v 1.2 2004/02/20 06:26:47 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/fake64/fake64-0.0.4_pre20021020.ebuild,v 1.3 2004/06/07 05:28:57 mr_bones_ Exp $
inherit games
@@ -11,13 +11,14 @@ SRC_URI="http://www.fakelabs.org/code/fake64/Fake64-20.10.2002.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86"
+IUSE=""
DEPEND="virtual/x11
virtual/opengl
virtual/glu
media-libs/libsdl"
-S=${WORKDIR}/${PN}
+S="${WORKDIR}/${PN}"
src_unpack() {
unpack ${A}
@@ -25,37 +26,42 @@ src_unpack() {
sed -i \
-e "s:@bindir@/fake64:${S}/blah:" \
-e 's:/etc/fake64rc:\$(DESTDIR)@sysconfdir@/fake64rc:' \
- Makefile.am
- sed -i "s:/etc/fake64rc:${GAMES_SYSCONFDIR}/fake64rc:" \
- romloader/configfile.c
+ Makefile.am \
+ || die "sed Makefile.am failed"
+ sed -i \
+ -e "s:/etc/fake64rc:${GAMES_SYSCONFDIR}/fake64rc:" \
+ romloader/configfile.c \
+ || die "sed romloader/configfile.c failed"
touch blah
./autogen.sh || die "autogen failed"
}
src_compile() {
econf \
- `use_enable x86` \
- `use_enable mmx` \
- `use_enable 3dnow` \
- `use_enable sse` \
+ $(use_enable x86) \
+ $(use_enable mmx) \
+ $(use_enable 3dnow) \
+ $(use_enable sse) \
|| die
- emake || die
+ emake || die "emake failed"
}
src_install() {
dodir /etc
- emake install DESTDIR=${D} || die
+ make DESTDIR="${D}" install || die "make install failed"
dodoc AUTHORS COMPATIBILITY ChangeLog NEWS README TODO
- cd ${D}/etc
- sed -i "s:/usr/local/fake64/plugins:${GAMES_LIBDIR}/${PN}:" fake64rc
- insinto ${GAMES_SYSCONFDIR}
+ cd "${D}/etc"
+ sed -i \
+ -e "s:/usr/local/fake64/plugins:${GAMES_LIBDIR}/${PN}:" fake64rc \
+ || die "sed fake64rc failed"
+ insinto "${GAMES_SYSCONFDIR}"
doins fake64rc && rm fake64rc
- cd ${D}/usr/fake64
- dogamesbin bin/*
- dosym romloader ${GAMES_BINDIR}/fake64
- dodir ${GAMES_LIBDIR}/${PN}
- mv plugins/* ${D}/${GAMES_LIBDIR}/${PN}/
+ cd "${D}/usr/fake64"
+ dogamesbin bin/* || die "dogamesbin failed"
+ dosym romloader "${GAMES_BINDIR}/fake64"
+ dodir "${GAMES_LIBDIR}/${PN}"
+ mv plugins/* "${D}/${GAMES_LIBDIR}/${PN}/"
cd .. && rm -rf fake64
prepgamesdirs