summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-11-17 23:23:24 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-11-17 23:23:24 +0000
commit8d79233184fdf51acc431ce8952076a999021073 (patch)
tree06dcbbcaaf3260dcc90d82b5880b4bd1facf9c22 /games-emulation
parentStable sparc. (diff)
downloadhistorical-8d79233184fdf51acc431ce8952076a999021073.tar.gz
historical-8d79233184fdf51acc431ce8952076a999021073.tar.bz2
historical-8d79233184fdf51acc431ce8952076a999021073.zip
still disable ggi (bug #71574)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/xmame/ChangeLog5
-rw-r--r--games-emulation/xmame/Manifest4
-rw-r--r--games-emulation/xmame/xmame-0.88.ebuild18
3 files changed, 16 insertions, 11 deletions
diff --git a/games-emulation/xmame/ChangeLog b/games-emulation/xmame/ChangeLog
index ce93a3783a0b..2c38f88a4920 100644
--- a/games-emulation/xmame/ChangeLog
+++ b/games-emulation/xmame/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-emulation/xmame
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/ChangeLog,v 1.28 2004/11/16 11:47:16 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/ChangeLog,v 1.29 2004/11/17 23:23:24 mr_bones_ Exp $
+
+ 17 Nov 2004; Michael Sterrett <mr_bones_@gentoo.org> xmame-0.88.ebuild:
+ still disable ggi (bug #71574)
*xmame-0.88 (16 Nov 2004)
diff --git a/games-emulation/xmame/Manifest b/games-emulation/xmame/Manifest
index ecb483adec3b..1d30a4542cff 100644
--- a/games-emulation/xmame/Manifest
+++ b/games-emulation/xmame/Manifest
@@ -1,8 +1,8 @@
-MD5 ebe3484485bb38ba10b27ff421908875 ChangeLog 7157
+MD5 5db36d0d05cc522635d67ac152c0a97e ChangeLog 7265
MD5 e44da7fe9271f2f2e299cc34df120830 metadata.xml 1537
MD5 30e8d4b0106df48fc70f99beb5608280 xmame-0.82.1.ebuild 6437
MD5 3bfc553fbd6d37187aba00e77fb80875 xmame-0.83.1.ebuild 6774
-MD5 4fb4b2db147acb6d28ea9abf4531fc21 xmame-0.88.ebuild 5417
+MD5 b78ba20e7aea46a10303eb6857f4538a xmame-0.88.ebuild 5530
MD5 8678f14a1893c1e9c8fa453ebd051382 xmame-0.86.ebuild 5877
MD5 9bbbd2de60f0c41f643674a694cd2c90 files/0.77.1-alsa-1.0.0.patch 438
MD5 13dc5b32bbff98dec74c41dd0c9b33a1 files/0.77.1-glx-fix.patch 597
diff --git a/games-emulation/xmame/xmame-0.88.ebuild b/games-emulation/xmame/xmame-0.88.ebuild
index a2360cc20a73..5ea904e91a73 100644
--- a/games-emulation/xmame/xmame-0.88.ebuild
+++ b/games-emulation/xmame/xmame-0.88.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/xmame-0.88.ebuild,v 1.1 2004/11/16 11:47:16 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/xmame-0.88.ebuild,v 1.2 2004/11/17 23:23:24 mr_bones_ Exp $
inherit flag-o-matic gcc eutils games
@@ -137,8 +137,9 @@ src_compile() {
disp=1
fi
if use ggi ; then
- emake DISPLAY_METHOD=ggi || die "emake failed (ggi)"
- disp=1
+ #emake DISPLAY_METHOD=ggi || die "emake failed (ggi)"
+ #disp=1
+ ewarn "GGI support is currently (${PV}) broken :("
fi
if [ ${disp} -eq 0 ] || use opengl || use X || use dga || use xv ; then
emake DISPLAY_METHOD=x11 || die "emake failed (x11)"
@@ -165,8 +166,9 @@ src_install() {
disp=1
fi
if use ggi ; then
- make DISPLAY_METHOD=ggi install || die "install failed (ggi)"
- disp=1
+ #make DISPLAY_METHOD=ggi install || die "install failed (ggi)"
+ #disp=1
+ ewarn "GGI support is currently (${PV}) broken :("
fi
if [ ${disp} -eq 0 ] || use opengl || use X || use dga || use xv ; then
make DISPLAY_METHOD=x11 install || die "install failed (x11)"
@@ -186,8 +188,8 @@ src_install() {
dosym "${TARGET}.SDL" "${GAMES_BINDIR}/${TARGET}"
elif use svga ; then
dosym ${TARGET}.svgalib "${GAMES_BINDIR}/${TARGET}"
- elif use ggi ; then
- dosym ${TARGET}.ggi "${GAMES_BINDIR}/${TARGET}"
+ #elif use ggi ; then
+ #dosym ${TARGET}.ggi "${GAMES_BINDIR}/${TARGET}"
fi
prepgamesdirs
}
@@ -199,6 +201,6 @@ pkg_postinst() {
einfo " ${TARGET}.x11"
fi
useq sdl && einfo " ${TARGET}.SDL"
- useq ggi && einfo " ${TARGET}.ggi"
+ #useq ggi && einfo " ${TARGET}.ggi"
useq svga && einfo " ${TARGET}.svgalib"
}