summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-06-28 23:10:10 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-06-28 23:10:10 +0000
commit48c4bc9d87d98f7278cfb50a1609c78dd8fb2824 (patch)
tree02b7311f9eeb557eedbd237c719e6075cb6d1ca0 /games-emulation
parentsync IUSE (-debug) (diff)
downloadhistorical-48c4bc9d87d98f7278cfb50a1609c78dd8fb2824.tar.gz
historical-48c4bc9d87d98f7278cfb50a1609c78dd8fb2824.tar.bz2
historical-48c4bc9d87d98f7278cfb50a1609c78dd8fb2824.zip
fix use flag invocation; tidy
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/stella/ChangeLog5
-rw-r--r--games-emulation/stella/Manifest6
-rw-r--r--games-emulation/stella/stella-1.3-r1.ebuild29
3 files changed, 23 insertions, 17 deletions
diff --git a/games-emulation/stella/ChangeLog b/games-emulation/stella/ChangeLog
index f758ff80084d..80cb5310eceb 100644
--- a/games-emulation/stella/ChangeLog
+++ b/games-emulation/stella/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-emulation/stella
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/ChangeLog,v 1.9 2004/06/24 22:36:30 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/ChangeLog,v 1.10 2004/06/28 23:10:10 mr_bones_ Exp $
+
+ 28 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org> stella-1.3-r1.ebuild:
+ fix use flag invocation; tidy
26 May 2004; Michael Sterrett <mr_bones_@gentoo.org> stella-1.3-r1.ebuild:
USE fixups
diff --git a/games-emulation/stella/Manifest b/games-emulation/stella/Manifest
index 36cc5960ce7f..1bda06002dd9 100644
--- a/games-emulation/stella/Manifest
+++ b/games-emulation/stella/Manifest
@@ -1,5 +1,5 @@
-MD5 f72af2d40011042f6d893c365f8b47c4 ChangeLog 1215
+MD5 7b88eb9114b6e1ddc3bb18a4e83069d3 ChangeLog 1327
+MD5 864cb7cce7e9c6b2f182f8b8d0b042e8 stella-1.3-r1.ebuild 1379
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
-MD5 9b106243bae85b630ba6c7729354e1c9 stella-1.3-r1.ebuild 1374
-MD5 72f37d51ae26ee356cc4ede6b1438195 files/stella-1.3-alsa-fix.patch 1040
MD5 5af9244b91231a9124ae00e7620ad00e files/digest-stella-1.3-r1 66
+MD5 72f37d51ae26ee356cc4ede6b1438195 files/stella-1.3-alsa-fix.patch 1040
diff --git a/games-emulation/stella/stella-1.3-r1.ebuild b/games-emulation/stella/stella-1.3-r1.ebuild
index a885e8f6feae..21a94a9eeb23 100644
--- a/games-emulation/stella/stella-1.3-r1.ebuild
+++ b/games-emulation/stella/stella-1.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/stella-1.3-r1.ebuild,v 1.6 2004/06/24 22:36:30 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/stella-1.3-r1.ebuild,v 1.7 2004/06/28 23:10:10 mr_bones_ Exp $
inherit eutils
@@ -22,10 +22,9 @@ DEPEND="|| (
media-libs/libpng"
src_unpack() {
- unpack ${A} || die
- cd ${S}
- epatch ${FILESDIR}/${P}-alsa-fix.patch || die \
- "Alsalib 1.0 fix failed"
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-alsa-fix.patch"
}
src_compile() {
@@ -35,24 +34,28 @@ src_compile() {
if use alsa ; then
MYOPTS="${MYOPTS} SOUND_ALSA=1"
fi
- if use X || [ -z "`use X``use sdl`" ] ; then
+ if use X || ! use sdl ; then
cd ${S}/src/build
- emake OPTIMIZATIONS="${CFLAGS}" $MYOPTS linux-x || die
+ emake OPTIMIZATIONS="${CFLAGS}" $MYOPTS linux-x \
+ || die "emake failed"
fi
if use sdl ; then
cd ${S}/src/build
- emake OPTIMIZATIONS="${CFLAGS}" $MYOPTS SOUND_SDL=1 linux-sdl || die
+ emake OPTIMIZATIONS="${CFLAGS}" $MYOPTS SOUND_SDL=1 linux-sdl \
+ || die "emake failed"
fi
}
src_install() {
- use X && dobin src/build/stella.x11
- use sdl && dobin src/build/stella.sdl
- [ -z "`use X``use sdl`" ] && dobin src/build/stella.x11
+ if use X || ! use sdl ; then
+ dobin src/build/stella.x11 || die "dobin failed"
+ fi
+ if use sdl ; then
+ dobin src/build/stella.sdl || die "dobin failed"
+ fi
insinto /etc
- doins src/stellarc
- doins src/emucore/stella.pro
+ doins src/stellarc src/emucore/stella.pro
dohtml -r docs/
dodoc *.txt