summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Goller <morfic@gentoo.org>2005-01-07 00:15:37 +0000
committerDaniel Goller <morfic@gentoo.org>2005-01-07 00:15:37 +0000
commit66f8d273b6f04319285125d534d218ced0151076 (patch)
tree2ac686a48fa971d303edce921a4b841c9c3f23ef /games-emulation/mupen64/files
parentversion 0.04 (diff)
downloadhistorical-66f8d273b6f04319285125d534d218ced0151076.tar.gz
historical-66f8d273b6f04319285125d534d218ced0151076.tar.bz2
historical-66f8d273b6f04319285125d534d218ced0151076.zip
fixed mupen64 with split out plugins in own packages
Diffstat (limited to 'games-emulation/mupen64/files')
-rw-r--r--games-emulation/mupen64/files/digest-mupen64-0.43
-rw-r--r--games-emulation/mupen64/files/mupen648
-rw-r--r--games-emulation/mupen64/files/mupen64-confdir.patch43
-rw-r--r--games-emulation/mupen64/files/mupen64-makefiles.patch28
-rw-r--r--games-emulation/mupen64/files/mupen64-noasm.patch11
5 files changed, 25 insertions, 68 deletions
diff --git a/games-emulation/mupen64/files/digest-mupen64-0.4 b/games-emulation/mupen64/files/digest-mupen64-0.4
index c5cdcf8bf1f9..235e4ebb6a71 100644
--- a/games-emulation/mupen64/files/digest-mupen64-0.4
+++ b/games-emulation/mupen64/files/digest-mupen64-0.4
@@ -2,6 +2,3 @@ MD5 322f2226f4f67e24868592c6b441e76a mupen64_src-0.4.tar.bz2 1871148
MD5 14fc6075a19bb567afebedd5ab2ea6c1 mupen64_input.tar.bz2 4438
MD5 88dfa0045794db7f1fc100b4c7b23125 mupen64_sound.tar.bz2 5932
MD5 9eb823e0f4a62c8ef0428dabf3f01370 hack_azi_rsp_hle.tar.bz2 38268
-MD5 f6f42d31cee3fce0ea92176f42ef73ba riceplugin.tar.bz2 287672
-MD5 31661c6fca2dc455d7cbe7e87d316021 blight_input-0.0.8-b.tar.gz 733624
-MD5 7bb104cf6ca94c0e761027eb9895fcbe jttl_sound-1.2.tar.bz2 10015
diff --git a/games-emulation/mupen64/files/mupen64 b/games-emulation/mupen64/files/mupen64
index 91f25bf47a02..09189fd8d05e 100644
--- a/games-emulation/mupen64/files/mupen64
+++ b/games-emulation/mupen64/files/mupen64
@@ -2,14 +2,20 @@
if [ ! -d ~/.mupen64/save ] ; then
mkdir -p ~/.mupen64/save
+ mkdir -p ~/.mupen64/plugins
cd ~/.mupen64
- ln -s GENTOO_DIR/plugins plugins
ln -s GENTOO_DIR/mupen64 mupen64
ln -s GENTOO_DIR/mupen64_nogui mupen64_nogui
cp GENTOO_DIR/mupen64.ini .
fi
cd ~/.mupen64
+
+cd plugins
+cleanlinks
+ln -s GENTOO_DIR/plugins/*.{so,ini} .
+cd ..
+
# We must execute ./blah not /foo/bar/blah because mupen64 tries to
# write to files in the directory from which the application is run.
# It segfaults if it can't write to the directory. Upstream has been
diff --git a/games-emulation/mupen64/files/mupen64-confdir.patch b/games-emulation/mupen64/files/mupen64-confdir.patch
index b71bf05e8516..d0705336faa8 100644
--- a/games-emulation/mupen64/files/mupen64-confdir.patch
+++ b/games-emulation/mupen64/files/mupen64-confdir.patch
@@ -1,46 +1,3 @@
---- blight_input-0.0.8-b/src/plugin.c.orig 2003-10-15 00:44:17.000000000 +0000
-+++ blight_input-0.0.8-b/src/plugin.c 2004-07-16 12:15:22.757428472 +0000
-@@ -33,6 +33,7 @@
- #include "SDL.h"
- #include <errno.h>
- #include <stdio.h>
-+#include <stdlib.h>
- #include <string.h>
-
- static unsigned short button_bits[] = {
-@@ -158,7 +159,8 @@
- FILE *f;
- int cont, plugged, mempak, mouse, i, b, dev;
- char line[200], device[200], key_a[200], key_b[200], button_a[200], button_b[200],
-- axis[200], button[200], hat[200], hat_pos_a[200], hat_pos_b[200], mbutton[200];
-+ axis[200], button[200], hat[200], hat_pos_a[200], hat_pos_b[200], mbutton[200],
-+ conffilename[200];
- const char *p;
- // const char *p1, *p2;
-
-@@ -188,8 +190,8 @@
- controller[i].axis[b].hat_pos_b = -1;
- }
- }
--
-- f = fopen( "blight_input.conf", "r" );
-+ snprintf (conffilename, 200, "%s/.mupen64/plugins/blight_input.conf", getenv("HOME"));
-+ f = fopen(conffilename, "r" );
- if( f == NULL )
- {
- fprintf( stderr, "["PLUGIN_NAME"]: Couldn't open blight_input.conf for reading: %s\n", strerror( errno ) );
-@@ -339,8 +341,10 @@
- char cButton_a[100], cButton_b[100], cAxis[100];
- char cHat[100];
- char cMouse[100];
-+ char conffilename[200];
-
-- f = fopen( "blight_input.conf", "w" );
-+ snprintf (conffilename, 200, "%s/.mupen64/plugins/blight_input.conf", getenv("HOME"));
-+ f = fopen(conffilename, "w" );
- if( f == NULL )
- {
- fprintf( stderr, "["PLUGIN_NAME"]: Couldn't open blight_input.conf for writing: %s\n", strerror( errno ) );
--- emu64/path.cfg.orig 2004-07-05 20:37:13.000000000 +0000
+++ emu64/path.cfg 2004-07-16 22:40:43.000000000 +0000
@@ -1 +1 @@
diff --git a/games-emulation/mupen64/files/mupen64-makefiles.patch b/games-emulation/mupen64/files/mupen64-makefiles.patch
index 86a7791507f9..a2a4e7f8f8f7 100644
--- a/games-emulation/mupen64/files/mupen64-makefiles.patch
+++ b/games-emulation/mupen64/files/mupen64-makefiles.patch
@@ -1,17 +1,3 @@
---- riceplugin/Makefile.orig 2004-07-15 21:38:45.195293640 +0000
-+++ riceplugin/Makefile 2004-07-15 21:40:31.719099560 +0000
-@@ -1,8 +1,8 @@
- CC = gcc
--#CFLAGS = -DUSE_GTK `sdl-config --cflags` `gtk-config --cflags` -g -mmmx -msse
--CFLAGS = -DUSE_GTK `sdl-config --cflags` `gtk-config --cflags` -O3 -mcpu=athlon -ffast-math -funroll-loops -fomit-frame-pointer -msse -mmmx
-+CFLAGS = -DUSE_GTK `sdl-config --cflags` `gtk-config --cflags` -g $(GCFLAGS)
-+#CFLAGS = -DUSE_GTK `sdl-config --cflags` `gtk-config --cflags` -O3 -mcpu=athlon -ffast-math -funroll-loops -fomit-frame-pointer -msse -mmmx
- CXX = g++
--CPPFLAGS = $(CFLAGS)
-+CPPFLAGS = -DUSE_GTK `sdl-config --cflags` `gtk-config --cflags` -g $(GCXXFLAGS)
- LD = g++
- LDFLAGS = -lGL -lGLU -L/usr/X11R6/lib -lSDL
-
--- emu64/Makefile.orig 2004-07-15 21:50:36.577147160 +0000
+++ emu64/Makefile 2004-07-15 21:53:11.189642488 +0000
@@ -3,14 +3,9 @@
@@ -26,9 +12,9 @@
-#CFLAGS =-DX86 -Wall -pipe -g
-
-CXXFLAGS =$(CFLAGS)
-+COMFLAGS =-DX86 -g
-+CFLAGS =$(COMFLAGS) $(GCFLAGS)
-+CXXFLAGS =$(COMFLAGS) $(GCXXFLAGS)
++COMFLAGS =-DX86
++CFLAGS =$(COMFLAGS)
++CXXFLAGS =$(COMFLAGS)
GL_PATH =-I/usr/X11R6/include
@@ -41,7 +27,7 @@
-#CC =gcc -O3 -I/usr/X11R6/include -fPIC -fomit-frame-pointer -funroll-loops -ffast-math -mcpu=pentium -pipe
-#CC =gcc -O3 -mpentium -Wall -g -pg
-CC =gcc -O3 -fomit-frame-pointer -funroll-loops -ffast-math -mcpu=athlon -Wall -DUSE_GTK `gtk-config --cflags` -I/usr/X11R6/include -pipe
-+CC =gcc -g $(GCFLAGS)
++CC =gcc
OBJ =main.o
@@ -52,10 +38,10 @@
-CFLAGS = -DUSE_GTK `gtk-config --cflags` -O3 -mcpu=athlon \
- -ffast-math -funroll-loops -fomit-frame-pointer
-#CFLAGS = -DUSE_GTK `gtk-config --cflags` -g -fPIC
-+CFLAGS = -DUSE_GTK `gtk-config --cflags` -g -fPIC $(GCFLAGS)
++CFLAGS = -DUSE_GTK `gtk-config --cflags` -fPIC
CXX = g++
-CXXFLAGS = $(CFLAGS)
-+CXXFLAGS = -DUSE_GTK `gtk-config --cflags` -g -fPIC $(GCXXFLAGS)
++CXXFLAGS = -DUSE_GTK `gtk-config --cflags` -fPIC
LD = g++
LDFLAGS =
@@ -64,7 +50,7 @@
@@ -1,5 +1,5 @@
CC = gcc
-CFLAGS = -O3 -fomit-frame-pointer -funroll-loops -ffast-math -mcpu=athlon `gtk-config --cflags` -DUSE_GTK -Wall
-+CFLAGS = `gtk-config --cflags` -DUSE_GTK $(GCFLAGS)
++CFLAGS = `gtk-config --cflags` -DUSE_GTK
LD = gcc
LDFLAGS = -shared -Wl,-Bsymbolic `gtk-config --libs` -lpthread
diff --git a/games-emulation/mupen64/files/mupen64-noasm.patch b/games-emulation/mupen64/files/mupen64-noasm.patch
new file mode 100644
index 000000000000..7b740acb85f6
--- /dev/null
+++ b/games-emulation/mupen64/files/mupen64-noasm.patch
@@ -0,0 +1,11 @@
+--- emu64/Makefile.old 2005-01-02 12:57:37.444075589 -0800
++++ emu64/Makefile 2005-01-02 12:57:44.673605061 -0800
+@@ -3,7 +3,7 @@
+ CC =gcc
+ CXX =g++
+
+-COMFLAGS =-DX86
++COMFLAGS =
+ CFLAGS =$(COMFLAGS)
+ CXXFLAGS =$(COMFLAGS)
+