summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-07-21 16:53:49 +0000
committerPacho Ramos <pacho@gentoo.org>2012-07-21 16:53:49 +0000
commit0a7110b818a9dffb184b7d00f2c8d54ad52f6123 (patch)
treef265ab64e16ef290900cc85fb44e75c2a0f73b13 /games-emulation/gxmame/gxmame-0.35_beta2.ebuild
parentVersion bump. (diff)
downloadhistorical-0a7110b818a9dffb184b7d00f2c8d54ad52f6123.tar.gz
historical-0a7110b818a9dffb184b7d00f2c8d54ad52f6123.tar.bz2
historical-0a7110b818a9dffb184b7d00f2c8d54ad52f6123.zip
Let it compile against glib-2.32
Package-Manager: portage-2.1.11.9/cvs/Linux x86_64
Diffstat (limited to 'games-emulation/gxmame/gxmame-0.35_beta2.ebuild')
-rw-r--r--games-emulation/gxmame/gxmame-0.35_beta2.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/games-emulation/gxmame/gxmame-0.35_beta2.ebuild b/games-emulation/gxmame/gxmame-0.35_beta2.ebuild
index c1a02f5292fc..9b75c876625f 100644
--- a/games-emulation/gxmame/gxmame-0.35_beta2.ebuild
+++ b/games-emulation/gxmame/gxmame-0.35_beta2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/gxmame/gxmame-0.35_beta2.ebuild,v 1.12 2012/05/04 04:38:38 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gxmame/gxmame-0.35_beta2.ebuild,v 1.13 2012/07/21 16:53:49 pacho Exp $
-EAPI=2
+EAPI=4
inherit eutils games
MY_P="${PN}-${PV/_beta/beta}"
@@ -27,6 +27,7 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}
src_prepare() {
+ epatch "${FILESDIR}"/${P}-glib-single-include.patch
epatch "${FILESDIR}"/${P}-ovflfix.patch
sed -i \
-e "s:-O2 -fomit-frame-pointer -ffast-math:${CFLAGS}:" \
@@ -60,7 +61,7 @@ src_configure() {
}
src_install() {
- emake DESTDIR="${D}" install || die
+ emake DESTDIR="${D}" install
dodoc AUTHORS BUGS ChangeLog NEWS README TODO
prepgamesdirs
}