summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-11-09 22:21:27 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-11-09 22:21:27 +0000
commit5d2f190ba1b81111d0a00d2102a9a289504c37b9 (patch)
tree45b314eab726771b7c05f944cfdb32c385087293 /games-emulation/dosbox/dosbox-9999.ebuild
parentenable user patching (diff)
downloadhistorical-5d2f190ba1b81111d0a00d2102a9a289504c37b9.tar.gz
historical-5d2f190ba1b81111d0a00d2102a9a289504c37b9.tar.bz2
historical-5d2f190ba1b81111d0a00d2102a9a289504c37b9.zip
add live svn ebuild to replace dosbox-cvs (bug #292468)
Package-Manager: portage-2.1.6.13/cvs/Linux i686
Diffstat (limited to 'games-emulation/dosbox/dosbox-9999.ebuild')
-rw-r--r--games-emulation/dosbox/dosbox-9999.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/games-emulation/dosbox/dosbox-9999.ebuild b/games-emulation/dosbox/dosbox-9999.ebuild
new file mode 100644
index 000000000000..30fb11d497d9
--- /dev/null
+++ b/games-emulation/dosbox/dosbox-9999.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dosbox/dosbox-9999.ebuild,v 1.1 2009/11/09 22:21:27 mr_bones_ Exp $
+
+EAPI=2
+ESVN_REPO_URI="https://dosbox.svn.sourceforge.net/svnroot/dosbox/dosbox/trunk"
+inherit autotools eutils subversion games
+
+DESCRIPTION="DOS emulator"
+HOMEPAGE="http://dosbox.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="alsa debug hardened opengl"
+
+DEPEND="alsa? ( media-libs/alsa-lib )
+ opengl? ( virtual/opengl )
+ debug? ( sys-libs/ncurses )
+ media-libs/libpng
+ media-libs/libsdl[joystick,video]
+ media-libs/sdl-net
+ media-libs/sdl-sound"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ subversion_src_unpack
+}
+
+src_prepare() {
+ subversion_src_prepare
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_enable alsa alsa-midi) \
+ $(use_enable !hardened dynamic-x86) \
+ $(use_enable debug) \
+ $(use_enable opengl)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS
+ make_desktop_entry dosbox DOSBox /usr/share/pixmaps/dosbox.ico
+ doicon src/dosbox.ico
+ prepgamesdirs
+}