summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-11-12 11:21:52 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-11-12 11:21:52 +0000
commitde360c0dc1b8ca7aac5e0f31e0020157e0b20308 (patch)
treedf9bff28586d053a5c2611d511794399fd0a5e3f /games-board/crafty
parentstable on alpha wrt bug #112226 (diff)
downloadhistorical-de360c0dc1b8ca7aac5e0f31e0020157e0b20308.tar.gz
historical-de360c0dc1b8ca7aac5e0f31e0020157e0b20308.tar.bz2
historical-de360c0dc1b8ca7aac5e0f31e0020157e0b20308.zip
version bump
Package-Manager: portage-2.0.51.22-r3
Diffstat (limited to 'games-board/crafty')
-rw-r--r--games-board/crafty/Manifest14
-rw-r--r--games-board/crafty/crafty-20.1.ebuild77
-rw-r--r--games-board/crafty/files/digest-crafty-20.11
3 files changed, 86 insertions, 6 deletions
diff --git a/games-board/crafty/Manifest b/games-board/crafty/Manifest
index c6f65bac287b..3cc1eae0f465 100644
--- a/games-board/crafty/Manifest
+++ b/games-board/crafty/Manifest
@@ -1,10 +1,12 @@
-MD5 93645f942a517a9fc8e5d45e697f4d77 crafty-19.8.ebuild 2115
-MD5 3cab1102bbc9003cdc5c8c934bef76a3 crafty-19.19.ebuild 2279
-MD5 db309e06fa0025cad92342bb96311154 ChangeLog 2485
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 6646e459c86a10c6539f2c91341d3e22 crafty-19.20.ebuild 2275
-MD5 4970593053a51ce5e26ea2d6bd89ffe9 files/19.8-ppc.patch 702
-MD5 17996dcbb38db4126094543f36cd43d1 files/digest-crafty-19.8 63
-MD5 1cfc5524de1fd69ae391d434d6e483d9 files/crafty-18.15-ppc.patch 634
+MD5 3cab1102bbc9003cdc5c8c934bef76a3 crafty-19.19.ebuild 2279
+MD5 d0a5ce169e3de402085e8fc69be3e1cf crafty-20.1.ebuild 2287
+MD5 db309e06fa0025cad92342bb96311154 ChangeLog 2485
+MD5 93645f942a517a9fc8e5d45e697f4d77 crafty-19.8.ebuild 2115
MD5 901b6df7332530910e854f501d4d49e1 files/digest-crafty-19.19 64
+MD5 4970593053a51ce5e26ea2d6bd89ffe9 files/19.8-ppc.patch 702
+MD5 65a97af46b1a4567e7df624c923cbc9a files/digest-crafty-20.1 60
MD5 1d2478ad97099a71745f628650cfa99b files/digest-crafty-19.20 64
+MD5 1cfc5524de1fd69ae391d434d6e483d9 files/crafty-18.15-ppc.patch 634
+MD5 17996dcbb38db4126094543f36cd43d1 files/digest-crafty-19.8 63
diff --git a/games-board/crafty/crafty-20.1.ebuild b/games-board/crafty/crafty-20.1.ebuild
new file mode 100644
index 000000000000..dadde88b7d92
--- /dev/null
+++ b/games-board/crafty/crafty-20.1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/crafty-20.1.ebuild,v 1.1 2005/11/12 11:21:52 mr_bones_ Exp $
+
+inherit flag-o-matic games
+
+DESCRIPTION="Bob Hyatt's strong chess engine"
+HOMEPAGE="ftp://ftp.cis.uab.edu/pub/hyatt/"
+SRC_URI="ftp://ftp.cis.uab.edu/pub/hyatt/src/${P}.zip"
+
+LICENSE="crafty"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86"
+IUSE="icc no-opts"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ icc? ( >=dev-lang/icc-5.0 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e '/-o crafty/s/CC/CXX/' Makefile \
+ || die "sed failed"
+ sed -i \
+ -e "s:\"crafty.hlp\":\"${GAMES_DATADIR}/${PN}/crafty.hlp\":" option.c \
+ || die "sed failed"
+}
+
+src_compile() {
+ local makeopts="target=LINUX"
+
+ if ! use no-opts ; then
+ if use icc ; then
+ makeopts="${makeopts} CC=icc CXX=gcc asm=X86.o"
+ append-flags -D_REENTRANT -tpp6 \
+ -DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS \
+ -DUSE_ASSEMBLY_A -DUSE_ASSEMBLY_B -DFAST \
+ -DSMP -DCPUS=4 -DCLONE -DDGT
+ append-flags -O2 -fno-alias -fforce-mem \
+ -fomit-frame-pointer -fno-gcse -mpreferred-stack-boundary=2
+ else
+ if [ "${CHOST}" == "i686-pc-linux-gnu" ] || [ "${CHOST}" == "i586-pc-linux-gnu" ] ; then
+ append-flags -DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS \
+ -DUSE_ASSEMBLY_A -DUSE_ASSEMBLY_B \
+ -DFAST -DSMP -DCPUS=4 -DCLONE -DDGT
+ append-flags -fforce-mem -fno-gcse \
+ -fomit-frame-pointer -mpreferred-stack-boundary=2
+ makeopts="${makeopts} CC=gcc CXX=g++ asm=X86.o"
+ else
+ : # everything else :)
+ fi
+ fi
+ fi
+ append-flags -DPOSIX
+ emake ${makeopts} crafty-make LDFLAGS="-lpthread" || die "build failed"
+}
+
+src_install() {
+ dogamesbin crafty || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins crafty.hlp || die "doins failed"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ einfo
+ einfo "Note: No books or tablebases have been installed. If you want them, just"
+ einfo " download them from ${HOMEPAGE}."
+ einfo " You will find documentation there too. In most cases you take now "
+ einfo " your xboard compatible application, (xboard, eboard, knights) and "
+ einfo " just play chess against computer opponent. Have fun."
+ einfo
+}
diff --git a/games-board/crafty/files/digest-crafty-20.1 b/games-board/crafty/files/digest-crafty-20.1
new file mode 100644
index 000000000000..6a541de68f82
--- /dev/null
+++ b/games-board/crafty/files/digest-crafty-20.1
@@ -0,0 +1 @@
+MD5 9ed3140ef26a22a8bdb5a0ba64cd91e5 crafty-20.1.zip 425288