summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-03-26 11:55:52 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-03-26 11:55:52 +0000
commitb4ce124565546a273fc221e22b959a178758dc56 (patch)
tree237b3d52e500e3d12b3d7729433ea681a0696bdc /games-arcade
parentfix SRC_URI; IUSE (diff)
downloadhistorical-b4ce124565546a273fc221e22b959a178758dc56.tar.gz
historical-b4ce124565546a273fc221e22b959a178758dc56.tar.bz2
historical-b4ce124565546a273fc221e22b959a178758dc56.zip
don't rdepend on sed; tidy
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/gunocide2ex/ChangeLog7
-rw-r--r--games-arcade/gunocide2ex/Manifest6
-rw-r--r--games-arcade/gunocide2ex/gunocide2ex-1.0.ebuild31
3 files changed, 25 insertions, 19 deletions
diff --git a/games-arcade/gunocide2ex/ChangeLog b/games-arcade/gunocide2ex/ChangeLog
index a5d5e2c1d5e1..e9c793b2918d 100644
--- a/games-arcade/gunocide2ex/ChangeLog
+++ b/games-arcade/gunocide2ex/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-arcade/gunocide2ex
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/gunocide2ex/ChangeLog,v 1.2 2003/11/28 20:19:12 mr_bones_ Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/gunocide2ex/ChangeLog,v 1.3 2004/03/26 11:55:52 mr_bones_ Exp $
+
+ 26 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org> gunocide2ex-1.0.ebuild:
+ don't rdepend on sed; tidy
28 Nov 2003; Michael Sterrett <mr_bones_@gentoo.org> gunocide2ex-1.0.ebuild:
actually compile; depend on sed-4; more error checking/messages; tidy
diff --git a/games-arcade/gunocide2ex/Manifest b/games-arcade/gunocide2ex/Manifest
index aa635c666afc..457ed73deebb 100644
--- a/games-arcade/gunocide2ex/Manifest
+++ b/games-arcade/gunocide2ex/Manifest
@@ -1,5 +1,5 @@
-MD5 c52ccd7dd8d332426662e5c4a1679334 ChangeLog 512
-MD5 659d3e37edde4b5e09e85879f9947354 gunocide2ex-1.0.ebuild 1985
-MD5 a30c9d4ce8f9629d6d7323eaab258343 metadata.xml 241
+MD5 21e7254f37412402d8ec5f85b19b19b2 ChangeLog 621
+MD5 66ca600aa7501b889f03de94c419cf00 gunocide2ex-1.0.ebuild 2010
+MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 1a6d5cdeab6dce56efb9db9e034d7461 files/1.0-gcc3.patch 251
MD5 a8df216f4323f42f869ca3148829177c files/digest-gunocide2ex-1.0 120
diff --git a/games-arcade/gunocide2ex/gunocide2ex-1.0.ebuild b/games-arcade/gunocide2ex/gunocide2ex-1.0.ebuild
index 765ffc414eac..148eea91fa56 100644
--- a/games-arcade/gunocide2ex/gunocide2ex-1.0.ebuild
+++ b/games-arcade/gunocide2ex/gunocide2ex-1.0.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/gunocide2ex/gunocide2ex-1.0.ebuild,v 1.3 2004/02/20 06:20:00 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/gunocide2ex/gunocide2ex-1.0.ebuild,v 1.4 2004/03/26 11:55:52 mr_bones_ Exp $
-inherit games eutils gcc
+inherit eutils gcc games
-S=${WORKDIR}
DESCRIPTION="fast-paced 2D shoot'em'up"
HOMEPAGE="http://www.polyfrag.com/content/product_gunocide.html"
SRC_URI="mirror://sourceforge/g2ex/g2ex-setup.run"
@@ -13,32 +12,36 @@ KEYWORDS="x86"
LICENSE="GPL-2"
SLOT="0"
-DEPEND="media-libs/libsdl
+RDEPEND="media-libs/libsdl
media-libs/sdl-ttf
- media-libs/sdl-mixer
+ media-libs/sdl-mixer"
+DEPEND="${RDEPEND}
>=sys-apps/sed-4"
+S="${WORKDIR}"
+
src_unpack() {
unpack_makeself
- sed -i "s:-g:${CFLAGS}:" makefile || \
- die "sed makefile failed"
+ sed -i "s:-g:${CFLAGS}:" makefile \
+ || die "sed makefile failed"
mkdir binary
epatch ${FILESDIR}/${PV}-gcc3.patch
edos2unix config.cfg
sed -i \
-e "s:/usr/local/games/gunocide2ex/config\.cfg:${GAMES_SYSCONFDIR}/${PN}.cfg:" \
-e "s:/usr/local/games/gunocide2ex/hscore\.dat:${GAMES_STATEDIR}/${PN}-hscore.dat:" \
- src/*.{h,cpp} || \
- die "sed failed"
+ src/*.{h,cpp} \
+ || die "sed failed"
sed -i \
-e "s:/usr/local/games:${GAMES_DATADIR}:" \
- src/*.{h,cpp} `find gfx -name '*.txt'` || \
- die "sed failed (2)"
+ src/*.{h,cpp} `find gfx -name '*.txt'` \
+ || die "sed failed (2)"
}
src_compile() {
- cd src
local cc=$(gcc-getCXX)
+
+ cd src
for f in *.cpp ; do
echo "${cc} ${CFLAGS} `sdl-config --cflags` ${f}"
${cc} ${cflags} `sdl-config --cflags` -c ${f} || \
@@ -52,8 +55,8 @@ src_install() {
dogamesbin src/${PN} || die "dogamesbin failed"
dosym ${PN} "${GAMES_BINDIR}/g2ex" || die "dosym failed"
dodir "${GAMES_DATADIR}/${PN}"
- cp -R gfx sfx lvl credits arial.ttf "${D}/${GAMES_DATADIR}/${PN}/" || \
- die "cp failed"
+ cp -R gfx sfx lvl credits arial.ttf "${D}/${GAMES_DATADIR}/${PN}/" \
+ || die "cp failed"
insinto "${GAMES_SYSCONFDIR}"
newins config.cfg ${PN}.cfg || die "newins failed (cfg)"
insinto "${GAMES_STATEDIR}"