summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 19:29:22 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 19:29:22 +0000
commit2d06451b949706e2e14d1e9cdbdedf30613ca779 (patch)
treee4defbc5a7848f65ff263eb968fe9f97f4e1a5f1 /games-arcade/xbill/xbill-2.1.ebuild
parentaction games ! (diff)
downloadhistorical-2d06451b949706e2e14d1e9cdbdedf30613ca779.tar.gz
historical-2d06451b949706e2e14d1e9cdbdedf30613ca779.tar.bz2
historical-2d06451b949706e2e14d1e9cdbdedf30613ca779.zip
arcade games !
Diffstat (limited to 'games-arcade/xbill/xbill-2.1.ebuild')
-rw-r--r--games-arcade/xbill/xbill-2.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/games-arcade/xbill/xbill-2.1.ebuild b/games-arcade/xbill/xbill-2.1.ebuild
new file mode 100644
index 000000000000..060db12864a4
--- /dev/null
+++ b/games-arcade/xbill/xbill-2.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/xbill/xbill-2.1.ebuild,v 1.1 2003/09/10 19:29:22 vapier Exp $
+
+DESCRIPTION="A game about evil hacker called Bill!"
+
+HOMEPAGE="http://www.xbill.org"
+KEYWORDS="x86 ppc"
+
+LICENSE="GPL-1"
+SLOT="0"
+
+DEPEND=">=gtk+-1.0"
+
+SRC_URI="http://www.xbill.org/download/${P}.tar.gz"
+
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${A}
+}
+
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --enable-gtk || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+}