summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-10-04 02:51:13 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-10-04 02:51:13 +0000
commit369a7cf4a82f4c23110de9f811bac1f34e6fbdb5 (patch)
tree6321b502bc119a9691f4d153d6d12e2f3174efe7 /games-arcade/spout/spout-1.3.ebuild
parentUpdate to install properly for xfree or xorg-x11, add virtual/x11 to RDEPEND. (diff)
downloadhistorical-369a7cf4a82f4c23110de9f811bac1f34e6fbdb5.tar.gz
historical-369a7cf4a82f4c23110de9f811bac1f34e6fbdb5.tar.bz2
historical-369a7cf4a82f4c23110de9f811bac1f34e6fbdb5.zip
version bump (bug #66264)
Diffstat (limited to 'games-arcade/spout/spout-1.3.ebuild')
-rw-r--r--games-arcade/spout/spout-1.3.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/games-arcade/spout/spout-1.3.ebuild b/games-arcade/spout/spout-1.3.ebuild
new file mode 100644
index 000000000000..2bd5ff4e58ce
--- /dev/null
+++ b/games-arcade/spout/spout-1.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/spout/spout-1.3.ebuild,v 1.1 2004/10/04 02:51:13 mr_bones_ Exp $
+
+inherit eutils games
+
+MY_P="spout-unix-${PV}"
+DESCRIPTION="Abstract Japanese caveflier / shooter"
+HOMEPAGE="http://code.mizzenblog.com/category/spout/"
+SRC_URI="http://code.mizzenblog.com/spout/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc"
+IUSE=""
+
+DEPEND="virtual/x11
+ >=media-libs/libsdl-1.2.6"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ dogamesbin spout || die "dogamesbin failed"
+ insinto /usr/share/pixmaps
+ doins spout.png
+ make_desktop_entry spout "Spout" spout.png
+ dodoc README
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ einfo "To play in fullscreen mode, do 'spout f'."
+ einfo "To play in a greater resolution, do 'spout x', where"
+ einfo "x is an integer; the larger x is, the higher the resolution."
+ echo
+ einfo "To play:"
+ einfo "Accelerate - spacebar, enter, z, x"
+ einfo "Pause - escape"
+ einfo "Exit - shift+escape"
+ einfo "Rotate - left or right"
+ echo
+}