summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <tristan@gentoo.org>2006-09-27 15:59:18 +0000
committerTristan Heaven <tristan@gentoo.org>2006-09-27 15:59:18 +0000
commit462a5ab7cce4d3b96428ce7d2551a72f1aee779a (patch)
tree33bd65b3eeb4fc26fab3ed01e3d94b507b665ff7 /games-arcade/solarwolf/solarwolf-1.5.ebuild
parentStable on alpha wrt bug #148228 (diff)
downloadhistorical-462a5ab7cce4d3b96428ce7d2551a72f1aee779a.tar.gz
historical-462a5ab7cce4d3b96428ce7d2551a72f1aee779a.tar.bz2
historical-462a5ab7cce4d3b96428ce7d2551a72f1aee779a.zip
Check sdl-mixer is built with USE=mikmod, bug #145139
Package-Manager: portage-2.1.2_pre1-r3
Diffstat (limited to 'games-arcade/solarwolf/solarwolf-1.5.ebuild')
-rw-r--r--games-arcade/solarwolf/solarwolf-1.5.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/games-arcade/solarwolf/solarwolf-1.5.ebuild b/games-arcade/solarwolf/solarwolf-1.5.ebuild
index 661b6a7b37cb..9b0d6fe36d84 100644
--- a/games-arcade/solarwolf/solarwolf-1.5.ebuild
+++ b/games-arcade/solarwolf/solarwolf-1.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/solarwolf/solarwolf-1.5.ebuild,v 1.12 2006/05/09 15:41:19 tcort Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/solarwolf/solarwolf-1.5.ebuild,v 1.13 2006/09/27 15:59:18 nyhm Exp $
inherit eutils games
@@ -17,6 +17,13 @@ DEPEND=">=dev-python/pygame-1.5.6
>=dev-lang/python-2.3
media-libs/libsdl"
+pkg_setup() {
+ games_pkg_setup
+ if ! built_with_use media-libs/sdl-mixer mikmod ; then
+ die "You need to build media-libs/sdl-mixer with USE=mikmod"
+ fi
+}
+
src_unpack() {
unpack ${A}
find "${S}" -name .xvpics -print0 | xargs -0 rm -fr