summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-07-03 06:13:17 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-07-03 06:13:17 +0000
commit408c46291ec289a4aba15db61548d8a9890fa94c (patch)
treef0568afb4762c69279f17cbdd944ce3557d1ee28 /games-arcade/sdlroids
parentStable amd64. (diff)
downloadhistorical-408c46291ec289a4aba15db61548d8a9890fa94c.tar.gz
historical-408c46291ec289a4aba15db61548d8a9890fa94c.tar.bz2
historical-408c46291ec289a4aba15db61548d8a9890fa94c.zip
Fix loading of the sound samples when using sdl-mixer (bug #55932)
Diffstat (limited to 'games-arcade/sdlroids')
-rw-r--r--games-arcade/sdlroids/ChangeLog6
-rw-r--r--games-arcade/sdlroids/Manifest5
-rw-r--r--games-arcade/sdlroids/files/1.3.4-sound.patch15
-rw-r--r--games-arcade/sdlroids/sdlroids-1.3.4-r3.ebuild11
4 files changed, 30 insertions, 7 deletions
diff --git a/games-arcade/sdlroids/ChangeLog b/games-arcade/sdlroids/ChangeLog
index 4ba28a3a834a..a20bf04ab645 100644
--- a/games-arcade/sdlroids/ChangeLog
+++ b/games-arcade/sdlroids/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/sdlroids
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/sdlroids/ChangeLog,v 1.5 2004/06/24 22:11:29 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/sdlroids/ChangeLog,v 1.6 2004/07/03 06:13:17 mr_bones_ Exp $
+
+ 02 Jul 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/1.3.4-sound.patch, sdlroids-1.3.4-r3.ebuild:
+ Fix loading of the sound samples when using sdl-mixer (bug #55932)
*sdlroids-1.3.4-r3 (24 Jan 2004)
diff --git a/games-arcade/sdlroids/Manifest b/games-arcade/sdlroids/Manifest
index 89e4c82dbf73..ce1964de7dc2 100644
--- a/games-arcade/sdlroids/Manifest
+++ b/games-arcade/sdlroids/Manifest
@@ -1,4 +1,5 @@
-MD5 4118924f46a38202332fd174433b8118 sdlroids-1.3.4-r3.ebuild 840
-MD5 1c607eaab087ea63b4bc55f47d180604 ChangeLog 1521
+MD5 1dc0f68caf9aa55e6c8cc88209ceb458 ChangeLog 1701
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 daac002601b4caa6480434a7d16ea8a6 sdlroids-1.3.4-r3.ebuild 916
MD5 933513560ad26be0b6fc1e21bb526a64 files/digest-sdlroids-1.3.4-r3 67
+MD5 441c876acdb07a550d72fa4645d5efee files/1.3.4-sound.patch 654
diff --git a/games-arcade/sdlroids/files/1.3.4-sound.patch b/games-arcade/sdlroids/files/1.3.4-sound.patch
new file mode 100644
index 000000000000..00da03f94252
--- /dev/null
+++ b/games-arcade/sdlroids/files/1.3.4-sound.patch
@@ -0,0 +1,15 @@
+--- sdlsound.c.orig 2004-07-02 23:03:03.000000000 -0700
++++ sdlsound.c 2004-07-02 23:05:37.000000000 -0700
+@@ -205,9 +205,9 @@
+ int load_sample(int num) {
+
+ if((samples[num] = Mix_LoadWAV(samplename[num])) ||
+- Mix_LoadWAV(datafilename(NULL, samplename[num])) ||
+- Mix_LoadWAV(datafilename(DATADIR, samplename[num])) ||
+- Mix_LoadWAV(datafilename(bindir, samplename[num])))
++ (samples[num] = Mix_LoadWAV(datafilename(NULL, samplename[num]))) ||
++ (samples[num] = Mix_LoadWAV(datafilename(DATADIR, samplename[num]))) ||
++ (samples[num] = Mix_LoadWAV(datafilename(bindir, samplename[num]))))
+ return 1;
+ return 0;
+ }
diff --git a/games-arcade/sdlroids/sdlroids-1.3.4-r3.ebuild b/games-arcade/sdlroids/sdlroids-1.3.4-r3.ebuild
index 6c3efb870e32..531304ae94ca 100644
--- a/games-arcade/sdlroids/sdlroids-1.3.4-r3.ebuild
+++ b/games-arcade/sdlroids/sdlroids-1.3.4-r3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/sdlroids/sdlroids-1.3.4-r3.ebuild,v 1.4 2004/06/24 22:11:29 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/sdlroids/sdlroids-1.3.4-r3.ebuild,v 1.5 2004/07/03 06:13:17 mr_bones_ Exp $
-inherit games
+inherit eutils games
DESCRIPTION="Asteroids Clone for X using SDL"
HOMEPAGE="http://david.hedbor.org/projects/sdlroids/"
@@ -13,17 +13,20 @@ SLOT="0"
KEYWORDS="x86 ppc ~amd64"
IUSE=""
-RDEPEND=">=media-libs/libsdl-1.1.8"
+RDEPEND=">=media-libs/libsdl-1.1.8
+ media-libs/sdl-mixer"
DEPEND="${RDEPEND}
>=sys-apps/sed-4"
src_unpack() {
unpack ${A}
+ cd "${S}"
sed -i \
-e 's/$(SOUNDSDIR)/$(DESTDIR)$(SOUNDSDIR)/' \
- -e 's/$(GFXDIR)/$(DESTDIR)$(GFXDIR)/' ${S}/Makefile.in \
+ -e 's/$(GFXDIR)/$(DESTDIR)$(GFXDIR)/' Makefile.in \
|| die "sed Makefile.in failed"
+ epatch "${FILESDIR}/${PV}-sound.patch"
}
src_install() {