summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <tristan@gentoo.org>2008-06-03 14:19:33 +0000
committerTristan Heaven <tristan@gentoo.org>2008-06-03 14:19:33 +0000
commit5db1e904f5e16665abfa75335bde8933f2d7429b (patch)
tree66f37cc87a965a45e277e71ab4dd9a312878b887 /games-action/openastromenace/openastromenace-1.2.0.ebuild
parentamd64 stable, bug 224305 (diff)
downloadhistorical-5db1e904f5e16665abfa75335bde8933f2d7429b.tar.gz
historical-5db1e904f5e16665abfa75335bde8933f2d7429b.tar.bz2
historical-5db1e904f5e16665abfa75335bde8933f2d7429b.zip
Fix build error with cmake-2.6
Package-Manager: portage-2.2_pre7-r1/cvs/Linux 2.6.25.4 Intel(R) Core(TM)2 Duo CPU E6750 @ 2.66GHz
Diffstat (limited to 'games-action/openastromenace/openastromenace-1.2.0.ebuild')
-rw-r--r--games-action/openastromenace/openastromenace-1.2.0.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/games-action/openastromenace/openastromenace-1.2.0.ebuild b/games-action/openastromenace/openastromenace-1.2.0.ebuild
index 4d7c9d97c673..fb8842f53792 100644
--- a/games-action/openastromenace/openastromenace-1.2.0.ebuild
+++ b/games-action/openastromenace/openastromenace-1.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/openastromenace/openastromenace-1.2.0.ebuild,v 1.1 2008/05/08 14:15:03 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/openastromenace/openastromenace-1.2.0.ebuild,v 1.2 2008/06/03 14:19:32 nyhm Exp $
inherit eutils games
@@ -31,6 +31,12 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/OpenAstroMenaceSVN
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-cmake.patch
+}
+
src_compile() {
cmake -DDATADIR="${GAMES_DATADIR}"/${PN} . || die "cmake failed"
emake || die "emake failed"