summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 19:29:16 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 19:29:16 +0000
commit6b2c6aa5f4161d5fcd009e3e5f2e9d84539b25f3 (patch)
tree5578c0bf4dcb7768e6bc8e22c99c359d60cb6c8e /games-action/glaxium/glaxium-0.5.ebuild
parentgames action and arcade (diff)
downloadhistorical-6b2c6aa5f4161d5fcd009e3e5f2e9d84539b25f3.tar.gz
historical-6b2c6aa5f4161d5fcd009e3e5f2e9d84539b25f3.tar.bz2
historical-6b2c6aa5f4161d5fcd009e3e5f2e9d84539b25f3.zip
action games !
Diffstat (limited to 'games-action/glaxium/glaxium-0.5.ebuild')
-rw-r--r--games-action/glaxium/glaxium-0.5.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/games-action/glaxium/glaxium-0.5.ebuild b/games-action/glaxium/glaxium-0.5.ebuild
new file mode 100644
index 000000000000..af1f08503931
--- /dev/null
+++ b/games-action/glaxium/glaxium-0.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/glaxium/glaxium-0.5.ebuild,v 1.1 2003/09/10 19:29:16 vapier Exp $
+
+inherit games flag-o-matic
+
+DESCRIPTION="OpenGL-based space-ship shoot-em-up style game"
+HOMEPAGE="http://xhosxe.free.fr/glaxium/"
+SRC_URI="http://xhosxe.free.fr/glaxium/glaxium_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND=">=libsdl-1.1.5
+ >=media-libs/sdl-mixer-1.2.4
+ virtual/x11
+ virtual/opengl
+ virtual/glu
+ virtual/glut
+ >=libpng-1.0.0"
+
+S=${WORKDIR}/${PN}_${PV}
+
+pkg_setup() {
+ ewarn "This currently only compiles with XFree OpenGL support"
+ ewarn "Use \`opengl-update xfree\` before emerging"
+}
+
+src_unpack() {
+ unpack ${A}
+ cp ${FILESDIR}/${PV}-20021024-Makefile.in ${S}/
+}
+
+src_compile() {
+ append-flags -DGL_GLEXT_LEGACY
+ egamesconf --datadir=${GAMES_DATADIR_BASE} || die
+ make || die
+}
+
+src_install() {
+ dodir ${GAMES_BINDIR}
+ egamesinstall \
+ exec_prefix=${D}/${GAMES_PREFIX} \
+ datadir=${D}/${GAMES_DATADIR_BASE} \
+ || die
+ dodoc README.txt CHANGES.txt
+ prepgamesdirs
+}