summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2006-04-03 02:03:04 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2006-04-03 02:03:04 +0000
commit1b68915fbbea54fc97ef4c5edf71d35e577667fc (patch)
treec2b1ce9e8ce623e2f91931a03d2fdd732bd4a181 /eclass/x-modular.eclass
parentVersion bump to 0.19. Ebuild submitted by Kai Huuhko <kai.huuhko@gmail.com> a... (diff)
downloadhistorical-1b68915fbbea54fc97ef4c5edf71d35e577667fc.tar.gz
historical-1b68915fbbea54fc97ef4c5edf71d35e577667fc.tar.bz2
historical-1b68915fbbea54fc97ef4c5edf71d35e577667fc.zip
Switch to eautoreconf instead of autoreconf, to get extra goodness. Tested by Flameeyes, based on his patch. Keeping the versioned deps on autotools because it's possible for someone to only have a too-low version installed based on autotools eclass deps.
Diffstat (limited to 'eclass/x-modular.eclass')
-rw-r--r--eclass/x-modular.eclass7
1 files changed, 3 insertions, 4 deletions
diff --git a/eclass/x-modular.eclass b/eclass/x-modular.eclass
index 026e0f72105c..358d240a71dd 100644
--- a/eclass/x-modular.eclass
+++ b/eclass/x-modular.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/x-modular.eclass,v 1.50 2006/04/02 00:07:55 kevquinn Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/x-modular.eclass,v 1.51 2006/04/03 02:03:04 spyderous Exp $
#
# Author: Donnie Berkholz <spyderous@gentoo.org>
#
@@ -27,7 +27,7 @@
EXPORT_FUNCTIONS src_unpack src_compile src_install pkg_preinst pkg_postinst pkg_postrm
-inherit eutils libtool toolchain-funcs flag-o-matic
+inherit eutils libtool toolchain-funcs flag-o-matic autotools
# Directory prefix to use for everything
XDIR="/usr"
@@ -221,8 +221,7 @@ x-modular_reconf_source() {
# If possible, generate configure if it doesn't exist
if [ -f "${S}/configure.ac" ]
then
- einfo "Running autoreconf..."
- autoreconf -v --force --install
+ eautoreconf
fi
fi