summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2011-02-10 21:36:38 +0000
committerUlrich Müller <ulm@gentoo.org>2011-02-10 21:36:38 +0000
commit3c24d5fe11f496991efe433eaca066807ffecbab (patch)
tree07cf67eef74bfc9f02f84b925c4f214ae049a5da /dev-vcs/svn2cl/svn2cl-0.9.ebuild
parentMove package from dev-util to dev-vcs, bug 56967. (diff)
downloadhistorical-3c24d5fe11f496991efe433eaca066807ffecbab.tar.gz
historical-3c24d5fe11f496991efe433eaca066807ffecbab.tar.bz2
historical-3c24d5fe11f496991efe433eaca066807ffecbab.zip
Move package from dev-util to dev-vcs, bug 56967.
Package-Manager: portage-2.1.9.39/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'dev-vcs/svn2cl/svn2cl-0.9.ebuild')
-rw-r--r--dev-vcs/svn2cl/svn2cl-0.9.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-vcs/svn2cl/svn2cl-0.9.ebuild b/dev-vcs/svn2cl/svn2cl-0.9.ebuild
new file mode 100644
index 000000000000..8b418f50f331
--- /dev/null
+++ b/dev-vcs/svn2cl/svn2cl-0.9.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/svn2cl/svn2cl-0.9.ebuild,v 1.1 2011/02/10 21:36:38 ulm Exp $
+
+inherit eutils
+
+DESCRIPTION="Create a GNU-style ChangeLog from subversion's svn log --xml output."
+HOMEPAGE="http://ch.tudelft.nl/~arthur/svn2cl/"
+SRC_URI="${HOMEPAGE}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~mips x86"
+IUSE=""
+
+RDEPEND="dev-libs/libxslt
+ dev-vcs/subversion"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # the wrapper script looks for the xsl files in the
+ # same directory as the script.
+ epatch "${FILESDIR}"/0.9-wrapper.patch
+}
+
+src_install() {
+ newbin svn2cl.sh svn2cl || die "failed to install wrapper script"
+ insinto /usr/share/svn2cl
+ doins svn2cl.xsl svn2html.xsl || die
+ dodoc README NEWS TODO ChangeLog authors.xml svn2html.css || die
+ doman svn2cl.1 || die
+}
+pkg_postinst() {
+ einfo "You can find samples of svn2html.css and authors.xml in"
+ einfo "/usr/share/doc/${PF}/"
+ einfo "Read man page for details."
+}