summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2011-12-26 12:04:37 +0000
committerChristian Faulhammer <fauli@gentoo.org>2011-12-26 12:04:37 +0000
commitdd1bb1116cc68f915c3662703f846ceb7107483b (patch)
tree61d42f2d86e66c45bb12024b513fa7aed585aaed /dev-vcs/bzr/files/bzr-2.4.2-no-pyrex-citon.patch
parentFixing deps for #388411 (diff)
downloadhistorical-dd1bb1116cc68f915c3662703f846ceb7107483b.tar.gz
historical-dd1bb1116cc68f915c3662703f846ceb7107483b.tar.bz2
historical-dd1bb1116cc68f915c3662703f846ceb7107483b.zip
version bump
Package-Manager: portage-2.1.10.41/cvs/Linux i686
Diffstat (limited to 'dev-vcs/bzr/files/bzr-2.4.2-no-pyrex-citon.patch')
-rw-r--r--dev-vcs/bzr/files/bzr-2.4.2-no-pyrex-citon.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-vcs/bzr/files/bzr-2.4.2-no-pyrex-citon.patch b/dev-vcs/bzr/files/bzr-2.4.2-no-pyrex-citon.patch
new file mode 100644
index 000000000000..a5128a03d628
--- /dev/null
+++ b/dev-vcs/bzr/files/bzr-2.4.2-no-pyrex-citon.patch
@@ -0,0 +1,33 @@
+--- setup.py.orig 2011-12-26 12:42:40.308882969 +0100
++++ setup.py 2011-12-26 12:43:38.861854988 +0100
+@@ -178,28 +178,8 @@
+ from distutils.errors import CCompilerError, DistutilsPlatformError
+ from distutils.extension import Extension
+ ext_modules = []
+-try:
+- try:
+- from Cython.Distutils import build_ext
+- from Cython.Compiler.Version import version as pyrex_version
+- except ImportError:
+- print("No Cython, trying Pyrex...")
+- from Pyrex.Distutils import build_ext
+- from Pyrex.Compiler.Version import version as pyrex_version
+-except ImportError:
+- have_pyrex = False
+- # try to build the extension from the prior generated source.
+- print("")
+- print("The python package 'Pyrex' is not available."
+- " If the .c files are available,")
+- print("they will be built,"
+- " but modifying the .pyx files will not rebuild them.")
+- print("")
+- from distutils.command.build_ext import build_ext
+-else:
+- have_pyrex = True
+- pyrex_version_info = tuple(map(int, pyrex_version.rstrip("+").split('.')))
+-
++have_pyrex = False
++from distutils.command.build_ext import build_ext
+
+ class build_ext_if_possible(build_ext):
+