summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando J. Pereda <ferdy@gentoo.org>2005-10-06 20:04:01 +0000
committerFernando J. Pereda <ferdy@gentoo.org>2005-10-06 20:04:01 +0000
commit321687508731d9ead64882cbb5caf75a28ddbfaf (patch)
tree864a6857d5cfa0e987a9476017d37e9923048d7a /dev-util
parentReenabled patch on Darwin (OSX) (diff)
downloadhistorical-321687508731d9ead64882cbb5caf75a28ddbfaf.tar.gz
historical-321687508731d9ead64882cbb5caf75a28ddbfaf.tar.bz2
historical-321687508731d9ead64882cbb5caf75a28ddbfaf.zip
version bump. Fix git-send-email installation. Added missing dependency on dev-perl/Email-Valid. Dropped ~mips keyword, see bug #108215 for more information.
Package-Manager: portage-2.0.51.22-r3
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/git/ChangeLog9
-rw-r--r--dev-util/git/Manifest10
-rw-r--r--dev-util/git/files/digest-git-0.99.8b1
-rw-r--r--dev-util/git/git-0.99.8b.ebuild106
4 files changed, 121 insertions, 5 deletions
diff --git a/dev-util/git/ChangeLog b/dev-util/git/ChangeLog
index 9a6e7b3444a3..d883f295e938 100644
--- a/dev-util/git/ChangeLog
+++ b/dev-util/git/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/git
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.29 2005/10/05 15:05:04 ferdy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.30 2005/10/06 20:04:01 ferdy Exp $
+
+*git-0.99.8b (06 Oct 2005)
+
+ 06 Oct 2005; Fernando J. Pereda <ferdy@gentoo.org> +git-0.99.8b.ebuild:
+ version bump. Fix git-send-email installation. Added missing dependency on
+ dev-perl/Email-Valid. Dropped ~mips keyword, see bug #108215 for more
+ information.
*git-0.99.8a (05 Oct 2005)
diff --git a/dev-util/git/Manifest b/dev-util/git/Manifest
index 668ef5863114..0bf94b377f85 100644
--- a/dev-util/git/Manifest
+++ b/dev-util/git/Manifest
@@ -3,16 +3,18 @@ Hash: SHA1
MD5 d35a0c0793dbfc65191588d2eca405d1 git-0.99.8a.ebuild 2835
MD5 edebd592261315b29a6b903b414573d2 git-0.7.ebuild 1312
-MD5 557248c23c81723a5ed8eda4ab5661c7 ChangeLog 4172
+MD5 37b46b1dfe818b2bf62ee6b8f576d682 git-0.99.8b.ebuild 2921
+MD5 de546a4b76b0ee6de0ec111c34485dd7 ChangeLog 4439
MD5 3526aab52e4319669bc1064d4d4ac83a metadata.xml 316
MD5 5c96e23fef078682e648254d9197f618 files/git-daemon.confd 376
MD5 ad6b9193f41375013fad4455bf1acda7 files/git-daemon.initd 526
MD5 62316f61a79143fdaf1e9f747d1ddf03 files/digest-git-0.99.8a 69
+MD5 fd5868fcfa11211c2a38977cb3a252c8 files/digest-git-0.99.8b 69
MD5 8ebc37d29c321b95a3c0ae51ebee4d4d files/digest-git-0.7 59
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFDQ+u/ViELBEf1JB0RAkiGAJ95lOGbC0msAkl5gIBZFtX1+LdwhACfbqwv
-cMsAIEZYIjVsFTcsaAaShBE=
-=edFF
+iD8DBQFDRYNoViELBEf1JB0RAltQAJ0U90njka4XAbpCqiXVN6/YGV626ACfV3Sz
+kMaPekJwPUs/wT6jD6MSj/I=
+=maso
-----END PGP SIGNATURE-----
diff --git a/dev-util/git/files/digest-git-0.99.8b b/dev-util/git/files/digest-git-0.99.8b
new file mode 100644
index 000000000000..b1ab81386784
--- /dev/null
+++ b/dev-util/git/files/digest-git-0.99.8b
@@ -0,0 +1 @@
+MD5 e3f151e028e04c8193fc0326a9a15038 git-core-0.99.8b.tar.bz2 366605
diff --git a/dev-util/git/git-0.99.8b.ebuild b/dev-util/git/git-0.99.8b.ebuild
new file mode 100644
index 000000000000..a85145be0884
--- /dev/null
+++ b/dev-util/git/git-0.99.8b.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-0.99.8b.ebuild,v 1.1 2005/10/06 20:04:01 ferdy Exp $
+
+inherit python
+
+DESCRIPTION="GIT - the stupid content tracker"
+HOMEPAGE="http://kernel.org/pub/software/scm/git/"
+SRC_URI="http://kernel.org/pub/software/scm/git/${PN}-core-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="mozsha1 ppcsha1 doc curl tcltk gitsendemail"
+S="${WORKDIR}/${PN}-core-${PV}"
+
+DEPEND="dev-libs/openssl
+ sys-libs/zlib
+ app-text/rcs
+ !app-misc/git
+ doc? ( >=app-text/asciidoc-7.0.1 app-text/xmlto )"
+RDEPEND="${DEPEND}
+ dev-lang/perl
+ >=dev-lang/python-2.3
+ tcltk? ( dev-lang/tk )
+ curl? ( net-misc/curl )
+ dev-perl/String-ShellQuote
+ gitsendemail? ( dev-perl/Mail-Sendmail dev-perl/Email-Valid )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i \
+ -e "s:-g -O2:${CFLAGS}:" \
+ Makefile
+}
+
+src_compile() {
+ # Use python_version to check for python 2.4.
+ # If the user don't have version 2.4 have then we set WITH_OWN_SUBPROCESS_PY
+ # that makes use of a suplied version of subprocess.py
+ python_version()
+ [[ $PYVER < 2.4 ]] && export WITH_OWN_SUBPROCESS_PY=yes
+
+ if use mozsha1 ; then
+ export MOZILLA_SHA1=yes
+ elif use ppcsha1 ; then
+ export PPC_SHA1=yes
+ fi
+
+ if ! use curl; then
+ export NO_CURL=yes
+ ewarn "git-http-pull will not be built because you are not"
+ ewarn " using the curl use flag"
+ fi
+
+ use gitsendemail && export WITH_SEND_EMAIL=yes
+
+ emake prefix=/usr || die "make failed"
+
+ if use doc ; then
+ sed -i \
+ -e "s:^\(WEBDOC_DEST = \).*$:\1${D}/usr/share/doc/${PF}/html/:g" \
+ ${S}/Documentation/Makefile || die "sed failed (Documentation)"
+ emake -C Documentation/ || die "make documentation failed"
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} prefix=/usr install || die "make install failed"
+
+ if use gitsendemail ; then
+ exeinto /usr/bin
+ newexe git-send-email.perl git-send-email
+ else
+ sed -i -e '/^send-email *$/d' ${D}/usr/bin/git
+ fi
+
+ use tcltk || rm ${D}/usr/bin/gitk
+
+ dodoc README COPYING
+ if use doc ; then
+ doman Documentation/*.1 Documentation/*.7
+ make install-webdoc -C Documentation/
+ fi
+
+ newinitd "${FILESDIR}/git-daemon.initd" git-daemon
+ newconfd "${FILESDIR}/git-daemon.confd" git-daemon
+}
+
+pkg_postinst() {
+ echo
+ ewarn "Some commands will be renamed before the final 1.0. Use the git"
+ ewarn "wrapper in your scripts to avoid compatibility problems. Check the"
+ ewarn "changes table at:"
+ echo
+ echo "http://dev.gentoo.org/~r3pek/git-new-command-list.txt"
+ echo
+ einfo
+ einfo "If you want to import arch repositories into git, consider using the"
+ einfo "git-archimport command. You should install dev-util/tla before."
+ einfo
+ einfo "If you want to import cvs repositories into git, consider using the"
+ einfo "git-cvsimport command. You should install >=dev-util/cvsps-2.1"
+ einfo
+}