summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-05-06 19:27:58 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-05-06 19:27:58 +0000
commit1565e3b1eb5a38201ad009a0fac2800aafba7e65 (patch)
treef7bf3d69faaf917fc19539d2e144a14b4c501a79 /dev-util/re2c/re2c-0.12.0.ebuild
parentStable for HPPA (bug #177324). (diff)
downloadhistorical-1565e3b1eb5a38201ad009a0fac2800aafba7e65.tar.gz
historical-1565e3b1eb5a38201ad009a0fac2800aafba7e65.tar.bz2
historical-1565e3b1eb5a38201ad009a0fac2800aafba7e65.zip
Version bump per bug #177302. See also upstream bug http://sourceforge.net/tracker/index.php?func=detail&aid=1708378&group_id=96864&atid=616200 about breakages in 0.11.3.
Package-Manager: portage-2.1.2.5
Diffstat (limited to 'dev-util/re2c/re2c-0.12.0.ebuild')
-rw-r--r--dev-util/re2c/re2c-0.12.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-util/re2c/re2c-0.12.0.ebuild b/dev-util/re2c/re2c-0.12.0.ebuild
new file mode 100644
index 000000000000..0bb2b404becd
--- /dev/null
+++ b/dev-util/re2c/re2c-0.12.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/re2c/re2c-0.12.0.ebuild,v 1.1 2007/05/06 19:27:58 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="tool for generating C-based recognizers from regular expressions"
+HOMEPAGE="http://re2c.sourceforge.net/"
+MY_PV="${PV/_/.}"
+MY_P="${PN}-${MY_PV}"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~hppa"
+IUSE=""
+
+RDEPEND="virtual/libc"
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A} || die
+ # Fix permissions
+ chmod -R u+rw ${S}
+ EPATCH_OPTS="-p1 -d ${S}" epatch "${FILESDIR}"/${PN}-0.9.11-gcc41.patch
+}
+
+src_compile() {
+ econf || die
+ emake -e || die
+}
+
+src_install() {
+ dobin re2c || die "dobin failed"
+ doman re2c.1 || die "doman failed"
+ dodoc README CHANGELOG doc/* && \
+ docinto examples && \
+ dodoc examples/*.c examples/*.re || die "docs failed"
+}