summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2007-03-07 11:02:29 +0000
committerChristian Heim <phreak@gentoo.org>2007-03-07 11:02:29 +0000
commit6db38b2f5bf0abe6a8192881204687131fd96b8d (patch)
tree990fa27ba13078089ccbcf8414ec72eaa63603b9 /dev-util/quilt/quilt-0.42-r1.ebuild
parentAdding preliminary mask for the new dev-util/quilt stuff .. (diff)
downloadhistorical-6db38b2f5bf0abe6a8192881204687131fd96b8d.tar.gz
historical-6db38b2f5bf0abe6a8192881204687131fd96b8d.tar.bz2
historical-6db38b2f5bf0abe6a8192881204687131fd96b8d.zip
Importing the ebuilds from my overlay, fixing some bugs (#152124, a stripping bug; noone reported yet); also introduction a new USE flag, that adds/removes the graphviz dependency.
Package-Manager: portage-2.1.2.1
Diffstat (limited to 'dev-util/quilt/quilt-0.42-r1.ebuild')
-rw-r--r--dev-util/quilt/quilt-0.42-r1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-util/quilt/quilt-0.42-r1.ebuild b/dev-util/quilt/quilt-0.42-r1.ebuild
new file mode 100644
index 000000000000..e5929c661be0
--- /dev/null
+++ b/dev-util/quilt/quilt-0.42-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/quilt/quilt-0.42-r1.ebuild,v 1.1 2007/03/07 11:02:29 phreak Exp $
+
+inherit bash-completion eutils
+
+DESCRIPTION="quilt patch manager"
+HOMEPAGE="http://savannah.nongnu.org/projects/quilt"
+SRC_URI="http://savannah.nongnu.org/download/quilt/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="graphviz"
+
+RDEPEND="sys-apps/ed
+ dev-util/diffstat
+ graphviz? ( media-gfx/graphviz )"
+
+# The tests are somewhat broken while being run from within portage, work fine
+# if you run them manually
+RESTRICT="test"
+
+pkg_setup() {
+ echo
+ elog "If you intend to use the folding functionality (graphical illustration of the patch stack)"
+ elog "then you'll need to remerge this package with USE=graphviz."
+ echo
+ epause
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # quilt-0.4.2 prestrips the libraries. Prevent it!
+ epatch "${FILESDIR}"/${P}-prevent-stripping.patch
+
+ # Add support for a "no-graphviz" version
+ use graphviz || epatch "${FILESDIR}"/${P}-no-graphviz.patch
+}
+
+src_install() {
+ make BUILD_ROOT="${D}" install || die "make install failed"
+
+ rm -rf "${D}"/usr/share/doc/${P}
+ dodoc AUTHORS TODO quilt.changes doc/README doc/README.MAIL \
+ doc/quilt.pdf doc/sample.quiltrc
+
+ rm -rf "${D}"/etc/bash_completion.d
+ dobashcompletion bash_completion
+}