summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2005-07-19 06:17:26 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2005-07-19 06:17:26 +0000
commit8183ddd7a8afcce93a74206e019bbd6270f2c2f2 (patch)
treebc5de91370df831ec8b97ffe66cd2f71678938ae /dev-util/monotone
parentBack into ~sparc with the patch that I made for upstream bug #1267. (diff)
downloadhistorical-8183ddd7a8afcce93a74206e019bbd6270f2c2f2.tar.gz
historical-8183ddd7a8afcce93a74206e019bbd6270f2c2f2.tar.bz2
historical-8183ddd7a8afcce93a74206e019bbd6270f2c2f2.zip
New version: 0.21
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'dev-util/monotone')
-rw-r--r--dev-util/monotone/ChangeLog7
-rw-r--r--dev-util/monotone/Manifest4
-rw-r--r--dev-util/monotone/files/digest-monotone-0.211
-rw-r--r--dev-util/monotone/monotone-0.21.ebuild66
4 files changed, 76 insertions, 2 deletions
diff --git a/dev-util/monotone/ChangeLog b/dev-util/monotone/ChangeLog
index d357c1316c92..f433987c1e4a 100644
--- a/dev-util/monotone/ChangeLog
+++ b/dev-util/monotone/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/monotone
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/monotone/ChangeLog,v 1.16 2005/07/07 00:50:16 leonardop Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/monotone/ChangeLog,v 1.17 2005/07/19 06:17:26 leonardop Exp $
+
+*monotone-0.21 (19 Jul 2005)
+
+ 19 Jul 2005; Leonardo Boshell <leonardop@gentoo.org> monotone-0.21.ebuild:
+ New release.
*monotone-0.20 (06 Jul 2005)
diff --git a/dev-util/monotone/Manifest b/dev-util/monotone/Manifest
index 5e2a47b22242..aa1badec428f 100644
--- a/dev-util/monotone/Manifest
+++ b/dev-util/monotone/Manifest
@@ -1,12 +1,14 @@
-MD5 cf5e57960c881b5e4cee9e19765188f7 ChangeLog 2976
+MD5 bb9a2198e744cd527cc071fc23e17017 ChangeLog 3099
MD5 1e6a86b292ad8ea52efad1e28f593e2f metadata.xml 964
MD5 dc5686ff5a40dfaf23bd7e7e2ae96073 monotone-0.16.ebuild 1236
MD5 790fb008dfdd0820a29a647565fe9284 monotone-0.17.ebuild 1692
MD5 aa7a28ac1380cf89fb5a1d0576a76707 monotone-0.18.ebuild 1687
MD5 af2251480135572c461c610665a18ab6 monotone-0.19.ebuild 1589
MD5 b37e056f9865f7279561e83f3fe5c874 monotone-0.20.ebuild 1868
+MD5 137b92d68c4340f34b2e8e7089910c1d monotone-0.21.ebuild 1766
MD5 f7dab86750bae0e4ff09e2139b790084 files/digest-monotone-0.16 66
MD5 c8834d71dc37833961a7eb7b4a455e84 files/digest-monotone-0.17 66
MD5 a4899373e67a34bbd0127cfb616e19ae files/digest-monotone-0.18 66
MD5 da4fd1c22f053091a99f33b3da3331d3 files/digest-monotone-0.19 66
MD5 2a075cd7118d0bbc2e3ce1e41c97f0ee files/digest-monotone-0.20 66
+MD5 b3a73360f9c121cd039cca80b516bb6a files/digest-monotone-0.21 66
diff --git a/dev-util/monotone/files/digest-monotone-0.21 b/dev-util/monotone/files/digest-monotone-0.21
new file mode 100644
index 000000000000..b7339b56497f
--- /dev/null
+++ b/dev-util/monotone/files/digest-monotone-0.21
@@ -0,0 +1 @@
+MD5 c30c96b97ae56268cac567bd8837b991 monotone-0.21.tar.gz 5005620
diff --git a/dev-util/monotone/monotone-0.21.ebuild b/dev-util/monotone/monotone-0.21.ebuild
new file mode 100644
index 000000000000..df1ff55abb15
--- /dev/null
+++ b/dev-util/monotone/monotone-0.21.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/monotone/monotone-0.21.ebuild,v 1.1 2005/07/19 06:17:26 leonardop Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Monotone Distributed Version Control System"
+HOMEPAGE="http://www.venge.net/monotone/"
+SRC_URI="http://www.venge.net/${PN}/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="doc ipv6 nls"
+
+RDEPEND=">=dev-libs/boost-1.32"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/gcc-3.2
+ nls? ( >=sys-devel/gettext-0.12.1 )
+ doc? ( sys-apps/texinfo )"
+
+src_compile() {
+ local myconf="$(use_enable nls) $(use_enable ipv6)"
+
+ # more aggressive optimizations cause trouble with the crypto library
+ strip-flags
+ append-flags -fno-stack-protector-all -fno-stack-protector \
+ -fno-strict-aliasing
+
+ econf ${myconf} || die "configure failed"
+ emake || die "emake failed"
+ use doc && make html
+}
+
+src_test() {
+ make check || die "self test failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ if use doc
+ then
+ dohtml -r html/*
+ dohtml -r figures
+ fi
+
+ dodoc ABOUT-NLS AUTHORS ChangeLog NEWS README* UPGRADE
+}
+
+pkg_postinst() {
+ einfo
+ einfo "If you are upgrading from:"
+ einfo " - 0.20 or earlier: you need to run 'db migrate' against each of"
+ einfo " your databases."
+ einfo " - 0.19 or earlier: there are some command line and server"
+ einfo " configuration changes; see /usr/share/doc/${PF}/NEWS.gz"
+ einfo " - 0.18 or earlier: if you have created a ~/.monotonerc, rename"
+ einfo " it to ~/.monotone/monotonerc, so monotone will still find it."
+ einfo
+ einfo "For instructions to upgrade from previous versions, please read"
+ einfo "/usr/share/doc/${PF}/UPGRADE.gz"
+ einfo
+}