summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2003-06-26 22:51:55 +0000
committerNick Hadaway <raker@gentoo.org>2003-06-26 22:51:55 +0000
commitebdd41889ca2b0360fcb09fc180c1163284136af (patch)
treea534dce38a81339e227c4d1f0e8af51eb2cb2404 /dev-util/gnustep-back/gnustep-back-0.8.5.ebuild
parentallow user to specify GROUP/USER much more easily (diff)
downloadhistorical-ebdd41889ca2b0360fcb09fc180c1163284136af.tar.gz
historical-ebdd41889ca2b0360fcb09fc180c1163284136af.tar.bz2
historical-ebdd41889ca2b0360fcb09fc180c1163284136af.zip
Version bump. Marked stable for x86.
Diffstat (limited to 'dev-util/gnustep-back/gnustep-back-0.8.5.ebuild')
-rw-r--r--dev-util/gnustep-back/gnustep-back-0.8.5.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/dev-util/gnustep-back/gnustep-back-0.8.5.ebuild b/dev-util/gnustep-back/gnustep-back-0.8.5.ebuild
new file mode 100644
index 000000000000..0a91065ce283
--- /dev/null
+++ b/dev-util/gnustep-back/gnustep-back-0.8.5.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gnustep-back/gnustep-back-0.8.5.ebuild,v 1.1 2003/06/26 22:51:55 raker Exp $
+
+DESCRIPTION="GNUstep GUI backend"
+HOMEPAGE="http://www.gnustep.org"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="x86 -ppc -sparc"
+DEPEND="=dev-util/gnustep-gui-${PV}*
+ >=media-libs/tiff-3.5.7
+ >=media-libs/jpeg-6b-r2
+ x11-base/xfree"
+S=${WORKDIR}/${P}
+
+src_compile() {
+
+ local myconf
+
+ # For a different graphics library... choose one
+ #
+ # myconf="--enable-graphics=xdps --with-name=xdps"
+ #
+ # -OR-
+ #
+ # make sure you have libart_lgpl installed and...
+ #
+ # myconf="--enable-graphics=art --with-name=art"
+
+
+ . /usr/GNUstep/System/Makefiles/GNUstep.sh
+
+ ./configure \
+ --prefix=/usr/GNUstep \
+ --with-jpeg-library=/usr/lib \
+ --with-jpeg-include=/usr/include \
+ --with-tiff-library=/usr/lib \
+ --with-tiff-include=/usr/include \
+ --with-x ${myconf} || die "configure failed"
+
+ # if we don't have Xft1, then we don't do Xft support at all
+ if [ ! -f "/usr/X11R6/include/X11/Xft1/Xft.h" ]; then
+ sed "s,^#define HAVE_XFT.*,#undef HAVE_XFT,g" config.h > config.h.new
+ sed "s,^#define HAVE_UTF8.*,#undef HAVE_UTF8,g" config.h.new > config.h
+ sed "s,^WITH_XFT=.*,WITH_XFT=no," config.make > config.make.new
+ sed "s,-lXft,," config.make.new > config.make
+ fi
+
+ make || die
+}
+
+src_install () {
+ . /usr/GNUstep/System/Makefiles/GNUstep.sh
+ make \
+ GNUSTEP_INSTALLATION_DIR=${D}/usr/GNUstep/System \
+ INSTALL_ROOT_DIR=${D} \
+ install || die "install failed"
+}