summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2007-06-28 19:54:00 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2007-06-28 19:54:00 +0000
commit5eb2b659852e25ea2a96c85a14e06baed8ebf581 (patch)
tree4596619c692c5bf418b14b3c73a37cb90bc9cd12 /dev-util/diasce/diasce-1.4.ebuild
parentFixing stupid cvs breakage thanks to Chris Mayo. Fixes bug #183566 (diff)
downloadhistorical-5eb2b659852e25ea2a96c85a14e06baed8ebf581.tar.gz
historical-5eb2b659852e25ea2a96c85a14e06baed8ebf581.tar.bz2
historical-5eb2b659852e25ea2a96c85a14e06baed8ebf581.zip
fixing diasce to not use linc anymore, clean depend
Package-Manager: portage-2.1.3_rc5
Diffstat (limited to 'dev-util/diasce/diasce-1.4.ebuild')
-rw-r--r--dev-util/diasce/diasce-1.4.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/dev-util/diasce/diasce-1.4.ebuild b/dev-util/diasce/diasce-1.4.ebuild
index 25aa4e2ae840..e3e8214e18a8 100644
--- a/dev-util/diasce/diasce-1.4.ebuild
+++ b/dev-util/diasce/diasce-1.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/diasce/diasce-1.4.ebuild,v 1.11 2006/11/22 17:11:13 masterdriverz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/diasce/diasce-1.4.ebuild,v 1.12 2007/06/28 19:54:00 eva Exp $
inherit eutils
@@ -28,23 +28,25 @@ RDEPEND=">=dev-libs/libxml2-2.4
>=gnome-base/libgnomecanvas-2"
DEPEND="${RDEPEND}
dev-util/pkgconfig
- net-libs/linc
+ >=gnome-base/orbit-2.8
nls? ( sys-devel/gettext )"
src_unpack() {
unpack ${A}
cd ${S}
- has_version '>=orbit/orbit-2.8.0' && epatch ${FILESDIR}/${P}-linc.patch
+ epatch ${FILESDIR}/${P}-linc.patch
}
src_compile() {
local myconf=""
- use nls || myconf="${myconf} --disable-nls"
+
+ myconf="${myconf} `use_enable nls`"
+
econf ${myconf} || die "./configure failed"
emake || die "emake failed"
}
src_install() {
- einstall || die
+ einstall || die "einstall failed"
dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
}