summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2002-12-04 21:17:25 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2002-12-04 21:17:25 +0000
commitee36f5508004cc4af4af7404e0597d5f890909b8 (patch)
treefce0b368327ab42d9edd5b0368d16071bcfca57e /dev-util/cvsup
parentfix dep on moz-1.2 to include 1.2.1 (diff)
downloadhistorical-ee36f5508004cc4af4af7404e0597d5f890909b8.tar.gz
historical-ee36f5508004cc4af4af7404e0597d5f890909b8.tar.bz2
historical-ee36f5508004cc4af4af7404e0597d5f890909b8.zip
New version that builds from source. Perhaps we can now convert from rsync to cvsup?
Diffstat (limited to 'dev-util/cvsup')
-rw-r--r--dev-util/cvsup/ChangeLog9
-rw-r--r--dev-util/cvsup/cvsup-16.1e-r1.ebuild110
-rw-r--r--dev-util/cvsup/files/digest-cvsup-16.1e4
-rw-r--r--dev-util/cvsup/files/digest-cvsup-16.1e-r13
4 files changed, 124 insertions, 2 deletions
diff --git a/dev-util/cvsup/ChangeLog b/dev-util/cvsup/ChangeLog
index 1f10b5b435b6..5e82fafa629f 100644
--- a/dev-util/cvsup/ChangeLog
+++ b/dev-util/cvsup/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/cvs
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cvsup/ChangeLog,v 1.2 2002/08/19 18:05:34 cybersystem Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cvsup/ChangeLog,v 1.3 2002/12/04 21:17:25 g2boojum Exp $
+
+*cvsup-16.1e-r1 (4 Dec. 2002)
+
+ 4 Dec. 2002; Grant Goodyear <g2boojum@gentoo.org> cvsup-16.1e-r1.ebuild :
+
+ Added new version that builds from source. Keywording as ~x86 and nothing else
+ until it gets tested.
*cvsup-16.1e (19 August 2002)
diff --git a/dev-util/cvsup/cvsup-16.1e-r1.ebuild b/dev-util/cvsup/cvsup-16.1e-r1.ebuild
new file mode 100644
index 000000000000..c0e83f7eb5fa
--- /dev/null
+++ b/dev-util/cvsup/cvsup-16.1e-r1.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cvsup/cvsup-16.1e-r1.ebuild,v 1.1 2002/12/04 21:17:25 g2boojum Exp $
+
+S=${WORKDIR}
+MY_P="${P/-/-snap-}"
+EZM3="ezm3-1.0"
+EZM3_TARGET="LINUXLIBC6"
+EZM3_INSTALL="${S}/${EZM3}-install" #// anywhere or having a trailing / makes the compile dies
+
+DESCRIPTION="a faster alternative to cvs"
+SRC_URI="http://people.freebsd.org/~jdp/s1g/${MY_P}.tar.gz
+ ftp://ftp.freebsd.org/pub/FreeBSD/development/CVSup/ezm3/${EZM3}-src.tar.bz2
+ ftp://ftp.freebsd.org/pub/FreeBSD/development/CVSup/ezm3/${EZM3}-${EZM3_TARGET}-boot.tar.bz2"
+HOMEPAGE="http://www.cvsup.org/"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~x86"
+DEPEND="virtual/glibc
+ dev-util/yacc"
+RDEPEND="virtual/glibc"
+
+seduse() {
+ [ -z "`use ${1}`" ] && echo "${2}" || echo ":"
+}
+
+src_compile() {
+ ########################
+ ### BEGIN EZM3 SETUP ###
+ ########################
+
+ # when you do make, ezm3 builds & installs at the same time so we control
+ # where it is going to install the compiler and stuff (to not violate sandbox)
+ cd ${S}/${EZM3}/m3config/src
+ cp ${EZM3_TARGET} ${EZM3_TARGET}.old
+ sed -e "s:/usr/local:${EZM3_INSTALL}:" \
+ ${EZM3_TARGET}.old > ${EZM3_TARGET}
+ echo "M3CC_MAKE = [\"make\", \"BISON=yacc\"]" >> ${EZM3_TARGET}
+
+ # now we disable X and OpenGL if the user doesnt have them in their USE var
+ cp COMMON COMMON.old
+ sed -e "s:/usr/local:${EZM3_INSTALL}:" \
+ -e "s:touch:ranlib:" \
+ -e "s:`seduse X 'import_X11():import_X11() is\nend\nproc dont_import_X11()'`:" \
+ -e "s:`seduse opengl 'import_OpenGL():import_OpenGL() is\nend\nproc dont_import_OpenGL()'`:" \
+ COMMON.old > COMMON
+
+ # finally we compile the m3 compiler
+ # we clear the CFLAGS because:
+ # (1) higher optimizations cause issues
+ # (2) it doesnt matter ... we arent installing the compiler ...
+ cd ${S}/${EZM3}
+ env CFLAGS="" make || die "ezm3 compile failed"
+
+ #########################
+ ### BEGIN CVSUP SETUP ###
+ #########################
+
+ # first we disable the gui (if no X) and enable static (if static is in USE)
+ cd ${S}/${MY_P}
+ local mym3flags; mym3flags=""
+ use static && mym3flags="${mym3flags} -DSTATIC"
+ use X || mym3flags="${mym3flags} -DNOGUI"
+ [ "${mym3flags:0:1}" == " " ] && mym3flags="${mym3flags:1}"
+ cp Makefile Makefile.old
+ sed -e "s:/usr/local:${D}/usr:" \
+ -e "s:^M3FLAGS=:M3FLAGS=${mym3flags}:" \
+ Makefile.old > Makefile
+
+ # then we fix the /usr/local/etc/cvsup paths in all the files
+ for f in `grep /usr/local/etc * -Rl` ; do
+ cp ${f} ${f}.old
+ sed -e "s:/usr/local/etc:/etc:" ${f}.old > ${f}
+ done
+
+ # then we compile cvsup
+ env PATH="${S}/${EZM3}-install/bin:${PATH}" make || die "cvsup compile failed"
+ # check to make sure all the binaries compiled ... the make doesnt return
+ # if an error was encountered ... it just keeeeeeeeeps going :/
+ [ `find ${S}/${MY_P} -perm +1 -type f | wc -l` == 9 ] || die "cvsup compile failed"
+
+ # now we do up the html pages ...
+ cd ${S}/${MY_P}/doc
+ make || die "html pages failed to compile !?"
+ for f in `ls *.html` ; do
+ cp ${f} ${f}.old
+ sed -e "s:images/::" ${f}.old > ${f}
+ done
+ mv ${S}/${MY_P}/doc/images/* ${S}/${MY_P}/doc/
+}
+
+src_install() {
+ S="${S}/${MY_P}"
+
+ for f in `find ${S} -perm +1 -type f | grep -v doc` ; do
+ dobin ${f}
+ done
+
+ doman ${S}/client/${EZM3_TARGET}/cvsup.1
+ doman ${S}/cvpasswd/${EZM3_TARGET}/cvpasswd.1
+ doman ${S}/server/${EZM3_TARGET}/cvsupd.8
+
+ dohtml ${S}/doc/*.{html,gif}
+
+ dodoc ${S}/{Acknowledgments,Announce,Blurb,ChangeLog,License,Install}
+
+ dodir ${S}/etc/cvsup
+ insinto ${S}/etc/cvsup
+}
diff --git a/dev-util/cvsup/files/digest-cvsup-16.1e b/dev-util/cvsup/files/digest-cvsup-16.1e
index 11c63c67d5bf..3ce08de952e9 100644
--- a/dev-util/cvsup/files/digest-cvsup-16.1e
+++ b/dev-util/cvsup/files/digest-cvsup-16.1e
@@ -1 +1,3 @@
-MD5 b6451a45b20656e6ab8b740785eeb38b cvsup-16.1e-LINUXLIBC6-gui.tar.gz 2104511
+MD5 1fc0ce8660b7fdc350893d4ea2458ceb cvsup-snap-16.1e.tar.gz 430594
+MD5 7f85f69e420b00a51481dad92f7eb749 ezm3-1.0-src.tar.bz2 6128550
+MD5 d2889caf3bb8fe2d50f40cfcc17908b9 ezm3-1.0-LINUXLIBC6-boot.tar.bz2 1345000
diff --git a/dev-util/cvsup/files/digest-cvsup-16.1e-r1 b/dev-util/cvsup/files/digest-cvsup-16.1e-r1
new file mode 100644
index 000000000000..3ce08de952e9
--- /dev/null
+++ b/dev-util/cvsup/files/digest-cvsup-16.1e-r1
@@ -0,0 +1,3 @@
+MD5 1fc0ce8660b7fdc350893d4ea2458ceb cvsup-snap-16.1e.tar.gz 430594
+MD5 7f85f69e420b00a51481dad92f7eb749 ezm3-1.0-src.tar.bz2 6128550
+MD5 d2889caf3bb8fe2d50f40cfcc17908b9 ezm3-1.0-LINUXLIBC6-boot.tar.bz2 1345000