summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-04-23 16:17:08 +0000
committerMike Frysinger <vapier@gentoo.org>2003-04-23 16:17:08 +0000
commit58b383f0e7349c1441ecd552c8950aa912d79c1d (patch)
treef3ba42ee95f4ce70a5690d94947c1e8400b8e1da /dev-util/cook
parentre-add patch (diff)
downloadhistorical-58b383f0e7349c1441ecd552c8950aa912d79c1d.tar.gz
historical-58b383f0e7349c1441ecd552c8950aa912d79c1d.tar.bz2
historical-58b383f0e7349c1441ecd552c8950aa912d79c1d.zip
touchups
Diffstat (limited to 'dev-util/cook')
-rw-r--r--dev-util/cook/cook-2.20.ebuild19
1 files changed, 6 insertions, 13 deletions
diff --git a/dev-util/cook/cook-2.20.ebuild b/dev-util/cook/cook-2.20.ebuild
index 9be6a6a19974..75c9c1c354e1 100644
--- a/dev-util/cook/cook-2.20.ebuild
+++ b/dev-util/cook/cook-2.20.ebuild
@@ -1,30 +1,23 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cook/cook-2.20.ebuild,v 1.7 2003/02/13 11:48:16 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cook/cook-2.20.ebuild,v 1.8 2003/04/23 16:11:57 vapier Exp $
-S=${WORKDIR}/${P}
-DESCRIPTION="Cook is a tool for constructing files. It is a replacement for make."
+DESCRIPTION="tool for constructing files; a drop in replacement for make"
SRC_URI="http://www.canb.auug.org.au/~millerp/cook/${P}.tar.gz"
HOMEPAGE="http://www.canb.auug.org.au/~millerp/cook/cook.html"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="x86 sparc "
+KEYWORDS="x86 sparc"
DEPEND="sys-devel/bison"
-src_compile()
-{
+src_compile() {
econf || die "./configure failed"
-
- # doesn't seem to like emake
- make || die
+ make || die # doesn't seem to like emake
}
-
-src_install ()
-{
-
+src_install() {
# we'll hijack the RPM_BUILD_ROOT variable which is intended for a
# similiar purpose anyway
make RPM_BUILD_ROOT=${D} install || die