summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Parpart <trapni@gentoo.org>2005-04-11 01:18:00 +0000
committerChristian Parpart <trapni@gentoo.org>2005-04-11 01:18:00 +0000
commit6dd7b8c471fe2127b4353c1c40dbe77146712c83 (patch)
treea3337a7604eee2f9e539613a12730c146adc17da /dev-util/ciabot-svn
parentStable on amd64. (diff)
downloadhistorical-6dd7b8c471fe2127b4353c1c40dbe77146712c83.tar.gz
historical-6dd7b8c471fe2127b4353c1c40dbe77146712c83.tar.bz2
historical-6dd7b8c471fe2127b4353c1c40dbe77146712c83.zip
initial import of ciabot-svn
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'dev-util/ciabot-svn')
-rw-r--r--dev-util/ciabot-svn/ChangeLog10
-rw-r--r--dev-util/ciabot-svn/Manifest5
-rw-r--r--dev-util/ciabot-svn/ciabot-svn-1.15.ebuild48
-rw-r--r--dev-util/ciabot-svn/files/config.py67
-rw-r--r--dev-util/ciabot-svn/files/digest-ciabot-svn-1.151
-rw-r--r--dev-util/ciabot-svn/metadata.xml8
6 files changed, 139 insertions, 0 deletions
diff --git a/dev-util/ciabot-svn/ChangeLog b/dev-util/ciabot-svn/ChangeLog
new file mode 100644
index 000000000000..a28d6a33da55
--- /dev/null
+++ b/dev-util/ciabot-svn/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-util/ciabot-svn
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ciabot-svn/ChangeLog,v 1.1 2005/04/11 01:18:00 trapni Exp $
+
+*ciabot-svn-1.15 (11 Apr 2005)
+
+ 11 Apr 2005; Christian Parpart <trapni@gentoo.org> +files/config.py,
+ +metadata.xml, +ciabot-svn-1.15.ebuild:
+ initial import
+
diff --git a/dev-util/ciabot-svn/Manifest b/dev-util/ciabot-svn/Manifest
new file mode 100644
index 000000000000..aedcf7b280dd
--- /dev/null
+++ b/dev-util/ciabot-svn/Manifest
@@ -0,0 +1,5 @@
+MD5 ed955515649ab029631ff68b8f7ce33d ChangeLog 374
+MD5 9f335de1f2a49fc6313408974a8da2ab ciabot-svn-1.15.ebuild 1380
+MD5 1bcf0125d9ba888a08c53f0822529612 metadata.xml 230
+MD5 2eaafc3252e73ad27881f0a468cf6924 files/digest-ciabot-svn-1.15 65
+MD5 282563a90ed45d870a07f83f35d67232 files/config.py 2978
diff --git a/dev-util/ciabot-svn/ciabot-svn-1.15.ebuild b/dev-util/ciabot-svn/ciabot-svn-1.15.ebuild
new file mode 100644
index 000000000000..70f39862f2fb
--- /dev/null
+++ b/dev-util/ciabot-svn/ciabot-svn-1.15.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ciabot-svn/ciabot-svn-1.15.ebuild,v 1.1 2005/04/11 01:18:00 trapni Exp $
+
+inherit eutils
+
+DESCRIPTION="CIA-bot script for Subversion repositories"
+HOMEPAGE="http://cia.navi.cx/doc/clients"
+SRC_URI="mirror://gentoo/${P}.py.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc ~ppc64"
+IUSE=""
+
+DEPEND="dev-lang/python"
+
+S="${WORKDIR}"
+
+src_install() {
+ dodir /etc/${PN}
+ insinto /etc/${PN}
+ doins ${FILESDIR}/config.py
+
+ newbin ${P}.py ${PN} || die
+}
+
+pkg_postinst() {
+ echo
+ einfo "This ciabot-svn script should be called from your repository's post-commit"
+ einfo "hook with the repository and revision as arguments. For example,"
+ einfo "you could copy this script into your repository's \"hooks\" directory"
+ einfo "and add something like the following to the \"post-commit\" script,"
+ einfo "also in the repository's \"hooks\" directory:"
+ einfo ""
+ einfo " REPOS=\"\$1\""
+ einfo " REV=\"\$2\""
+ einfo " /usr/bin/ciabot-svn \"\$REPOS\" \"\$REV\" &"
+ einfo ""
+ einfo "Or, if you have multiple project hosted, you can add each"
+ einfo "project's name to the commandline in that project's post-commit"
+ einfo "hook:"
+ einfo ""
+ einfo " /usr/bin/ciabot-svn \"\$REPOS\" \"\$REV\" \"ProjectName\" &"
+ echo
+ ebeep
+ epause
+}
diff --git a/dev-util/ciabot-svn/files/config.py b/dev-util/ciabot-svn/files/config.py
new file mode 100644
index 000000000000..6225e19a7160
--- /dev/null
+++ b/dev-util/ciabot-svn/files/config.py
@@ -0,0 +1,67 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ciabot-svn/files/config.py,v 1.1 2005/04/11 01:18:00 trapni Exp $
+
+# This file contains contents stripped out from upstream ciabot_svn.py
+# script in order to allow convient end-user config file management.
+#
+# Please adapt this file to your needs.
+
+class config:
+ # Replace this with your project's name, or always provide a project
+ # name on the commandline.
+ #
+ # NOTE: This shouldn't be a long description of your project. Ideally
+ # it is a short identifier with no spaces, punctuation, or
+ # unnecessary capitalization. This will be used in URLs related
+ # to your project, as an internal identifier, and in IRC messages.
+ # If you want a longer name shown for your project on the web
+ # interface, please use the "title" metadata key rather than
+ # putting that here.
+ #
+ project = "YOUR_PROJECT_NAME_HERE"
+
+ # Subversion's normal directory hierarchy is powerful enough that
+ # it doesn't have special methods of specifying modules, tags, or
+ # branches like CVS does. Most projects do use a naming
+ # convention though that works similarly to CVS's modules, tags,
+ # and branches.
+ #
+ # This is a list of regular expressions that are tested against
+ # paths in the order specified. If a regex matches, the 'branch'
+ # and 'module' groups are stored and the matching section of the
+ # path is removed.
+ #
+ # Several common directory structure styles are below as defaults.
+ # Uncomment the ones you're using, or add your own regexes.
+ # Whitespace in the each regex are ignored.
+
+ pathRegexes = [
+ # r"^ trunk/ (?P<module>[^/]+)/ ",
+ # r"^ (branches|tags)/ (?P<branch>[^/]+)/ ",
+ # r"^ (branches|tags)/ (?P<module>[^/]+)/ (?P<branch>[^/]+)/ ",
+ ]
+
+ # If your repository is accessable over the web, put its base URL here
+ # and 'uri' attributes will be given to all <file> elements. This means
+ # that in CIA's online message viewer, each file in the tree will link
+ # directly to the file in your repository
+ repositoryURI = None
+
+ # This can be the http:// URI of the CIA server to deliver commits over
+ # XML-RPC, or it can be an email address to deliver using SMTP. The
+ # default here should work for most people. If you need to use e-mail
+ # instead, you can replace this with "cia@cia.navi.cx"
+ server = "http://cia.navi.cx"
+
+ # The SMTP server to use, only used if the CIA server above is an
+ # email address
+ smtpServer = "localhost"
+
+ # The 'from' address to use. If you're delivering commits via email, set
+ # this to the address you would normally send email from on this host.
+ fromAddress = "cia-user@localhost"
+
+ # When nonzero, print the message to stdout instead of delivering it to CIA
+ debug = 0
+
diff --git a/dev-util/ciabot-svn/files/digest-ciabot-svn-1.15 b/dev-util/ciabot-svn/files/digest-ciabot-svn-1.15
new file mode 100644
index 000000000000..be60dcc1976c
--- /dev/null
+++ b/dev-util/ciabot-svn/files/digest-ciabot-svn-1.15
@@ -0,0 +1 @@
+MD5 04810a6017f3000b5ab286c660f4e409 ciabot-svn-1.15.py.bz2 3055
diff --git a/dev-util/ciabot-svn/metadata.xml b/dev-util/ciabot-svn/metadata.xml
new file mode 100644
index 000000000000..74009b7103b9
--- /dev/null
+++ b/dev-util/ciabot-svn/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>trapni@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>