summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-09-03 04:48:23 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-09-03 04:48:23 +0000
commitdb1b54caf107cb353ad8d2e0c031a7f66bd82990 (patch)
tree628309ef2f27b0719621cc5bd1f3890bdcbc5c4e /dev-tex/europecv/europecv-20060424-r1.ebuild
parentfix collision (diff)
downloadhistorical-db1b54caf107cb353ad8d2e0c031a7f66bd82990.tar.gz
historical-db1b54caf107cb353ad8d2e0c031a7f66bd82990.tar.bz2
historical-db1b54caf107cb353ad8d2e0c031a7f66bd82990.zip
rev bump to install in texmf-site and add examples useflag
Package-Manager: portage-2.2_rc8/cvs/Linux 2.6.26.3 x86_64
Diffstat (limited to 'dev-tex/europecv/europecv-20060424-r1.ebuild')
-rw-r--r--dev-tex/europecv/europecv-20060424-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-tex/europecv/europecv-20060424-r1.ebuild b/dev-tex/europecv/europecv-20060424-r1.ebuild
new file mode 100644
index 000000000000..3936926766dd
--- /dev/null
+++ b/dev-tex/europecv/europecv-20060424-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/europecv/europecv-20060424-r1.ebuild,v 1.1 2008/09/03 04:48:23 aballier Exp $
+
+inherit latex-package
+
+DESCRIPTION="LaTeX class for the standard model for curricula vitae as recommended by the European Commission."
+HOMEPAGE="http://www.ctan.org/tex-archive/help/Catalogue/entries/europecv.html"
+# Downloaded from:
+# ftp://cam.ctan.org/tex-archive/macros/latex/contrib/europecv.zip
+SRC_URI="mirror://gentoo/${P}.zip"
+
+LICENSE="LPPL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="examples"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+S="${WORKDIR}/${PN}"
+
+TEXMF=/usr/share/texmf-site
+
+src_compile() {
+ return
+}
+
+src_install() {
+ insinto ${TEXMF}/tex/latex/europecv
+ doins ecv* europecv.cls EuropeFlag* europasslogo*
+
+ insinto /usr/share/doc/${PF}
+ doins -r europecv.pdf europecv.tex
+ dosym /usr/share/doc/${PF}/europecv.pdf ${TEXMF}/doc/latex/${PN}/europecv.pdf
+ use examples && doins -r examples templates
+}