summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-07 03:33:41 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-07 03:33:41 +0000
commit54e7966a6682654a453466ef2f6478a9d7c84113 (patch)
tree01ead3a9ed92a878aa61cfb067d22f7a02791f16 /dev-tex/cpp2latex
parentfix license/repoman (diff)
downloadhistorical-54e7966a6682654a453466ef2f6478a9d7c84113.tar.gz
historical-54e7966a6682654a453466ef2f6478a9d7c84113.tar.bz2
historical-54e7966a6682654a453466ef2f6478a9d7c84113.zip
fix license/repoman
Diffstat (limited to 'dev-tex/cpp2latex')
-rw-r--r--dev-tex/cpp2latex/cpp2latex-2.2.ebuild29
1 files changed, 15 insertions, 14 deletions
diff --git a/dev-tex/cpp2latex/cpp2latex-2.2.ebuild b/dev-tex/cpp2latex/cpp2latex-2.2.ebuild
index c1c0dc450a5f..a91be496cc41 100644
--- a/dev-tex/cpp2latex/cpp2latex-2.2.ebuild
+++ b/dev-tex/cpp2latex/cpp2latex-2.2.ebuild
@@ -1,30 +1,31 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/cpp2latex/cpp2latex-2.2.ebuild,v 1.1 2003/06/09 07:32:39 satai Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/cpp2latex/cpp2latex-2.2.ebuild,v 1.2 2003/08/07 03:32:58 vapier Exp $
+
+inherit eutils
-S=${WORKDIR}/${P}
DESCRIPTION="A program to convert C++ code to LaTeX source"
-SRC_URI="http://www.arnoldarts.de/${P}.tar.gz"
HOMEPAGE="http://www.arnoldarts.de/cpp2latex.html"
+SRC_URI="http://www.arnoldarts.de/${P}.tar.gz"
-DEPEND="virtual/glibc
- app-text/tetex"
-
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 ppc"
+DEPEND="virtual/glibc
+ app-text/tetex"
+
src_unpack () {
unpack ${A}
cd ${S}
- patch -p 0 < ${FILESDIR}/main.cpp.patch
+ epatch ${FILESDIR}/main.cpp.patch
}
-src_compile () {
- econf
- emake
+src_compile() {
+ econf || die
+ emake || die
}
-src_install () {
- make install DESTDIR=${D} || die make install failed
+src_install() {
+ make install DESTDIR=${D} || die make install failed
}