summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHerbie Hopkins <herbs@gentoo.org>2005-11-16 11:27:05 +0000
committerHerbie Hopkins <herbs@gentoo.org>2005-11-16 11:27:05 +0000
commit780ddbca0b3e1249380da1c61c064c3afc0b2c10 (patch)
treeeace5daa2a7c59a6fa88d5b63c2942d5289c309d /dev-tcltk/thread
parentCosmetic. (diff)
downloadhistorical-780ddbca0b3e1249380da1c61c064c3afc0b2c10.tar.gz
historical-780ddbca0b3e1249380da1c61c064c3afc0b2c10.tar.bz2
historical-780ddbca0b3e1249380da1c61c064c3afc0b2c10.zip
Multilib fix.
Package-Manager: portage-2.0.53_rc7
Diffstat (limited to 'dev-tcltk/thread')
-rw-r--r--dev-tcltk/thread/ChangeLog5
-rw-r--r--dev-tcltk/thread/Manifest16
-rw-r--r--dev-tcltk/thread/thread-2.6.1.ebuild18
3 files changed, 32 insertions, 7 deletions
diff --git a/dev-tcltk/thread/ChangeLog b/dev-tcltk/thread/ChangeLog
index 2c39db0b0d7b..98cea70c8c5d 100644
--- a/dev-tcltk/thread/ChangeLog
+++ b/dev-tcltk/thread/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-tcltk/thread
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/thread/ChangeLog,v 1.2 2005/07/03 01:20:12 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/thread/ChangeLog,v 1.3 2005/11/16 11:27:05 herbs Exp $
+
+ 16 Nov 2005; Herbie Hopkins <herbs@gentoo.org> thread-2.6.1.ebuild:
+ Multilib fix.
03 Jul 2005; MATSUU Takuto <matsuu@gentoo.org> thread-2.6.1.ebuild:
Fixed with gdbm cofigure issue. Bug 97738.
diff --git a/dev-tcltk/thread/Manifest b/dev-tcltk/thread/Manifest
index da866ec053e0..10687bed38ac 100644
--- a/dev-tcltk/thread/Manifest
+++ b/dev-tcltk/thread/Manifest
@@ -1,4 +1,14 @@
-MD5 2ecd1ec578a13592b623d8ab6b58c5a0 thread-2.6.1.ebuild 1076
-MD5 b68310e6e2e92adc40b42a5b6d1d7955 ChangeLog 500
-MD5 43e377139ff5f3b7415b94a8c8d5260d metadata.xml 158
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 fd0b6946646b51f640fea3b6d1a6cb2b ChangeLog 586
MD5 9b4c86b16329dae30cdefd49b1e31f68 files/digest-thread-2.6.1 63
+MD5 43e377139ff5f3b7415b94a8c8d5260d metadata.xml 158
+MD5 0485e2ab2787a91f581d98d07cd85cf5 thread-2.6.1.ebuild 1362
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFDexeY2G5bA0cA/ScRAjuUAJ9tj/WQLi9zcVtacozi4+8EjR9PlwCfU+ue
+HHEaM4o2cKrIaliiU1L0zJo=
+=COIn
+-----END PGP SIGNATURE-----
diff --git a/dev-tcltk/thread/thread-2.6.1.ebuild b/dev-tcltk/thread/thread-2.6.1.ebuild
index 0436f27ee3d2..c3b2e9c24c82 100644
--- a/dev-tcltk/thread/thread-2.6.1.ebuild
+++ b/dev-tcltk/thread/thread-2.6.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/thread/thread-2.6.1.ebuild,v 1.2 2005/07/03 01:20:12 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/thread/thread-2.6.1.ebuild,v 1.3 2005/11/16 11:27:05 herbs Exp $
-inherit eutils
+inherit eutils multilib
DESCRIPTION="the Tcl Thread extension"
HOMEPAGE="http://www.tcl.tk/"
@@ -18,6 +18,16 @@ DEPEND="gdbm? ( sys-libs/gdbm )
S=${WORKDIR}/${PN}${PV}
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # Search for libs in libdir not just exec_prefix/lib
+ sed -i -e 's:${exec_prefix}/lib:${libdir}:' \
+ aclocal.m4 || die "sed failed"
+ aclocal || die "aclocal failed"
+ autoconf || die "autoconf failed"
+}
+
pkg_setup() {
if ! built_with_use dev-lang/tcl threads ; then
eerror "dev-lang/tcl was not merged with threading enabled."
@@ -27,11 +37,13 @@ pkg_setup() {
}
src_compile() {
- local myconf="--with-threads --with-tclinclude=/usr/include"
+ local myconf="--with-threads --with-tclinclude=/usr/include \
+ --with-tcl=/usr/$(get_libdir)"
if use gdbm ; then
myconf="${myconf} --with-gdbm"
fi
+
econf ${myconf} || die "econf failed"
emake || die "emake failed"
}