summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2003-02-03 01:19:27 +0000
committerArcady Genkin <agenkin@gentoo.org>2003-02-03 01:19:27 +0000
commit7a6457f64f0906903462ed8bb431d12c93064385 (patch)
tree01c8969cc15bac413de2bb1a075d8b18015599b4 /dev-tcltk/tclxml/tclxml-2.4.ebuild
parentRemoved extraneous files (diff)
downloadhistorical-7a6457f64f0906903462ed8bb431d12c93064385.tar.gz
historical-7a6457f64f0906903462ed8bb431d12c93064385.tar.bz2
historical-7a6457f64f0906903462ed8bb431d12c93064385.zip
Looks like tclxml-expat does not compile in 2.5, but does for 2.4,
hence I'm bringing 2.4 in. Also, needed to hack TclxmlConfig.sh to include the correct "-L" path to the library.
Diffstat (limited to 'dev-tcltk/tclxml/tclxml-2.4.ebuild')
-rw-r--r--dev-tcltk/tclxml/tclxml-2.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-tcltk/tclxml/tclxml-2.4.ebuild b/dev-tcltk/tclxml/tclxml-2.4.ebuild
new file mode 100644
index 000000000000..1a4aa9c2207d
--- /dev/null
+++ b/dev-tcltk/tclxml/tclxml-2.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2003 Arcady Genkin <agenkin@gentoo.org>.
+# Distributed under the terms of the GNU General Public License v2.
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclxml/tclxml-2.4.ebuild,v 1.1 2003/02/03 01:19:27 agenkin Exp $
+
+DESCRIPTION="Pure Tcl implementation of an XML parser."
+HOMEPAGE="http://tclxml.sourceforge.net/"
+
+DEPEND=">=dev-lang/tcl-8.3.3"
+
+LICENSE="BSD"
+KEYWORDS="~x86"
+
+SLOT="0"
+SRC_URI="mirror://sourceforge/tclxml/${P}.tar.gz"
+S=${WORKDIR}/${P}
+
+src_compile() {
+
+ econf || die
+ make || die
+
+ # Need to hack the config script.
+ sed 's:NONE:/usr:' < TclxmlConfig.sh > TclxmlConfig.sh.hacked
+ mv TclxmlConfig.sh.hacked TclxmlConfig.sh
+
+}
+
+src_install() {
+
+ einstall || die
+ dodoc ChangeLog LICENSE README RELNOTES
+
+}