summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-10-29 04:45:39 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-10-29 04:45:39 +0000
commitb0502258455b473a3fe6f6d1934a99f7a6624666 (patch)
treec5bd2014426c6d44165d9f6ba0e5ab13958aa7ee /dev-tcltk/iwidgets/iwidgets-4.0.1.ebuild
parentadd new ebuild as it's a PDEPEND for the new itcl (diff)
downloadhistorical-b0502258455b473a3fe6f6d1934a99f7a6624666.tar.gz
historical-b0502258455b473a3fe6f6d1934a99f7a6624666.tar.bz2
historical-b0502258455b473a3fe6f6d1934a99f7a6624666.zip
add new ebuild as it's a PDEPEND for the new itcl
Diffstat (limited to 'dev-tcltk/iwidgets/iwidgets-4.0.1.ebuild')
-rw-r--r--dev-tcltk/iwidgets/iwidgets-4.0.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-tcltk/iwidgets/iwidgets-4.0.1.ebuild b/dev-tcltk/iwidgets/iwidgets-4.0.1.ebuild
new file mode 100644
index 000000000000..84882b1e10f0
--- /dev/null
+++ b/dev-tcltk/iwidgets/iwidgets-4.0.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+
+MY_P=${PN}${PV}
+S=${WORKDIR}/${MY_P}
+
+ITCL_MY_PN="itcl"
+ITCL_MY_PV="3.2.1"
+ITCL_MY_P="${ITCL_MY_PN}${ITCL_MY_PV}"
+
+DESCRIPTION="Widget collection for incrTcl/incrTk"
+SRC_URI="mirror://sourceforge/incrtcl/${MY_P}.tar.gz
+ mirror://sourceforge/incrtcl/${ITCL_MY_P}_src.tgz"
+HOMEPAGE="http://www.tcltk.com/${PN}/"
+
+SLOT="0"
+LICENSE="as-is BSD"
+KEYWORDS="~x86 ~ppc ~sparc"
+DEPEND=">=dev-tcltk/itcl-3.2.1"
+PDEPEND="dev-tcltk/iwidgets"
+
+src_compile() {
+ local myconf
+ myconf="${myconf} --with-itcl=${WORKDIR}/${ITCL_MY_P}"
+ econf ${myconf} || die "configure failed"
+ # we don't need to compile anything
+}
+
+src_install() {
+ einstall || "einstall failed"
+ dodoc CHANGES ChangeLog README license.terms
+ doman doc/*.n
+}