summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Legler <a3li@gentoo.org>2009-11-28 09:34:07 +0000
committerAlex Legler <a3li@gentoo.org>2009-11-28 09:34:07 +0000
commit1462b42941c72e0a0f944e1eaf72f49e66752cbd (patch)
treea486f9942a3794a1b2712b9977cd8b2c87ba7f7c /dev-ruby
parentDrop --impl-headers since the call was dropped from new eselect, and should b... (diff)
downloadhistorical-1462b42941c72e0a0f944e1eaf72f49e66752cbd.tar.gz
historical-1462b42941c72e0a0f944e1eaf72f49e66752cbd.tar.bz2
historical-1462b42941c72e0a0f944e1eaf72f49e66752cbd.zip
Version bump, security bug 294797
Package-Manager: portage-2.2_rc52/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/actionmailer/ChangeLog7
-rw-r--r--dev-ruby/actionmailer/actionmailer-2.3.5.ebuild18
-rw-r--r--dev-ruby/actionpack/ChangeLog7
-rw-r--r--dev-ruby/actionpack/actionpack-2.3.5.ebuild19
-rw-r--r--dev-ruby/activerecord/ChangeLog7
-rw-r--r--dev-ruby/activerecord/activerecord-2.3.5.ebuild22
-rw-r--r--dev-ruby/activeresource/ChangeLog7
-rw-r--r--dev-ruby/activeresource/activeresource-2.3.5.ebuild18
-rw-r--r--dev-ruby/activesupport/ChangeLog7
-rw-r--r--dev-ruby/activesupport/activesupport-2.3.5.ebuild17
-rw-r--r--dev-ruby/rails/ChangeLog7
-rw-r--r--dev-ruby/rails/rails-2.3.5.ebuild47
12 files changed, 177 insertions, 6 deletions
diff --git a/dev-ruby/actionmailer/ChangeLog b/dev-ruby/actionmailer/ChangeLog
index 4ad198dec04f..188e856291b4 100644
--- a/dev-ruby/actionmailer/ChangeLog
+++ b/dev-ruby/actionmailer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionmailer
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.122 2009/10/22 08:13:17 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.123 2009/11/28 09:26:34 a3li Exp $
+
+*actionmailer-2.3.5 (28 Nov 2009)
+
+ 28 Nov 2009; Alex Legler <a3li@gentoo.org> +actionmailer-2.3.5.ebuild:
+ Version bump, security bug 294797
22 Oct 2009; Alex Legler <a3li@gentoo.org> -actionmailer-1.3.6.ebuild,
-actionmailer-2.0.5.ebuild, -actionmailer-2.1.2.ebuild:
diff --git a/dev-ruby/actionmailer/actionmailer-2.3.5.ebuild b/dev-ruby/actionmailer/actionmailer-2.3.5.ebuild
new file mode 100644
index 000000000000..edeabe129e9e
--- /dev/null
+++ b/dev-ruby/actionmailer/actionmailer-2.3.5.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-2.3.5.ebuild,v 1.1 2009/11/28 09:26:34 a3li Exp $
+
+inherit ruby gems
+USE_RUBY="ruby18 ruby19"
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="http://rubyforge.org/projects/actionmailer/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="~dev-ruby/actionpack-${PV}
+ >=dev-lang/ruby-1.8.6"
+RDEPEND="${DEPEND}"
diff --git a/dev-ruby/actionpack/ChangeLog b/dev-ruby/actionpack/ChangeLog
index 423a383917e2..5ea3e57484d7 100644
--- a/dev-ruby/actionpack/ChangeLog
+++ b/dev-ruby/actionpack/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionpack
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.128 2009/10/22 15:14:31 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.129 2009/11/28 09:19:32 a3li Exp $
+
+*actionpack-2.3.5 (28 Nov 2009)
+
+ 28 Nov 2009; Alex Legler <a3li@gentoo.org> +actionpack-2.3.5.ebuild:
+ Version bump, security bug 294797
22 Oct 2009; Alex Legler <a3li@gentoo.org> -actionpack-1.13.6.ebuild,
-actionpack-2.0.5.ebuild, -actionpack-2.1.2-r1.ebuild:
diff --git a/dev-ruby/actionpack/actionpack-2.3.5.ebuild b/dev-ruby/actionpack/actionpack-2.3.5.ebuild
new file mode 100644
index 000000000000..fceab08dce5c
--- /dev/null
+++ b/dev-ruby/actionpack/actionpack-2.3.5.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/actionpack-2.3.5.ebuild,v 1.1 2009/11/28 09:19:32 a3li Exp $
+
+inherit ruby gems
+USE_RUBY="ruby18 ruby19"
+
+DESCRIPTION="Eases web-request routing, handling, and response."
+HOMEPAGE="http://rubyforge.org/projects/actionpack/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=dev-lang/ruby-1.8.6
+ ~dev-ruby/activesupport-${PV}
+ =dev-ruby/rack-1.0*"
+RDEPEND="${DEPEND}"
diff --git a/dev-ruby/activerecord/ChangeLog b/dev-ruby/activerecord/ChangeLog
index 28a6566b4906..91ff9655376b 100644
--- a/dev-ruby/activerecord/ChangeLog
+++ b/dev-ruby/activerecord/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activerecord
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.119 2009/10/22 08:08:07 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.120 2009/11/28 09:29:54 a3li Exp $
+
+*activerecord-2.3.5 (28 Nov 2009)
+
+ 28 Nov 2009; Alex Legler <a3li@gentoo.org> +activerecord-2.3.5.ebuild:
+ Version bump, security bug 294797
22 Oct 2009; Alex Legler <a3li@gentoo.org> -activerecord-1.15.6.ebuild,
-activerecord-2.0.5.ebuild, -activerecord-2.1.2.ebuild:
diff --git a/dev-ruby/activerecord/activerecord-2.3.5.ebuild b/dev-ruby/activerecord/activerecord-2.3.5.ebuild
new file mode 100644
index 000000000000..1847ffc212d2
--- /dev/null
+++ b/dev-ruby/activerecord/activerecord-2.3.5.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-2.3.5.ebuild,v 1.1 2009/11/28 09:29:55 a3li Exp $
+
+inherit ruby gems
+USE_RUBY="ruby18 ruby19"
+
+DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
+HOMEPAGE="http://rubyforge.org/projects/activerecord/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="mysql postgres sqlite sqlite3"
+
+DEPEND=">=dev-lang/ruby-1.8.6
+ ~dev-ruby/activesupport-${PV}"
+RDEPEND="${DEPEND}
+ sqlite? ( >=dev-ruby/sqlite-ruby-2.2.2 )
+ sqlite3? ( dev-ruby/sqlite3-ruby )
+ mysql? ( >=dev-ruby/mysql-ruby-2.7 )
+ postgres? ( >=dev-ruby/ruby-postgres-0.7.1 )"
diff --git a/dev-ruby/activeresource/ChangeLog b/dev-ruby/activeresource/ChangeLog
index 4928167a7c9e..1a860612cb7f 100644
--- a/dev-ruby/activeresource/ChangeLog
+++ b/dev-ruby/activeresource/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activeresource
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.50 2009/10/22 08:29:08 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.51 2009/11/28 09:22:37 a3li Exp $
+
+*activeresource-2.3.5 (28 Nov 2009)
+
+ 28 Nov 2009; Alex Legler <a3li@gentoo.org> +activeresource-2.3.5.ebuild:
+ Version bump, security bug 294797
22 Oct 2009; Alex Legler <a3li@gentoo.org> -activeresource-2.0.5.ebuild,
-activeresource-2.1.2.ebuild:
diff --git a/dev-ruby/activeresource/activeresource-2.3.5.ebuild b/dev-ruby/activeresource/activeresource-2.3.5.ebuild
new file mode 100644
index 000000000000..32edfc2bd488
--- /dev/null
+++ b/dev-ruby/activeresource/activeresource-2.3.5.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/activeresource-2.3.5.ebuild,v 1.1 2009/11/28 09:22:37 a3li Exp $
+
+inherit ruby gems
+USE_RUBY="ruby18 ruby19"
+
+DESCRIPTION="Think Active Record for web resources.."
+HOMEPAGE="http://rubyforge.org/projects/activeresource/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=dev-lang/ruby-1.8.6
+ ~dev-ruby/activesupport-${PV}"
+RDEPEND="${DEPEND}"
diff --git a/dev-ruby/activesupport/ChangeLog b/dev-ruby/activesupport/ChangeLog
index 86ebd77216ab..22c53d58c540 100644
--- a/dev-ruby/activesupport/ChangeLog
+++ b/dev-ruby/activesupport/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activesupport
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.104 2009/10/22 08:29:58 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.105 2009/11/28 09:16:37 a3li Exp $
+
+*activesupport-2.3.5 (28 Nov 2009)
+
+ 28 Nov 2009; Alex Legler <a3li@gentoo.org> +activesupport-2.3.5.ebuild:
+ Version bump, security bug 294797
22 Oct 2009; Alex Legler <a3li@gentoo.org> -activesupport-1.4.4.ebuild,
-activesupport-2.0.5.ebuild, -activesupport-2.1.2.ebuild:
diff --git a/dev-ruby/activesupport/activesupport-2.3.5.ebuild b/dev-ruby/activesupport/activesupport-2.3.5.ebuild
new file mode 100644
index 000000000000..ebcf194aaacc
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-2.3.5.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-2.3.5.ebuild,v 1.1 2009/11/28 09:16:37 a3li Exp $
+
+inherit ruby gems
+USE_RUBY="ruby18 ruby19"
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="http://rubyforge.org/projects/activesupport/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=dev-lang/ruby-1.8.6"
+RDEPEND="${DEPEND}"
diff --git a/dev-ruby/rails/ChangeLog b/dev-ruby/rails/ChangeLog
index 3a15b39aa1fb..a2b3c9e1c903 100644
--- a/dev-ruby/rails/ChangeLog
+++ b/dev-ruby/rails/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rails
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.157 2009/10/22 08:05:19 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.158 2009/11/28 09:34:07 a3li Exp $
+
+*rails-2.3.5 (28 Nov 2009)
+
+ 28 Nov 2009; Alex Legler <a3li@gentoo.org> +rails-2.3.5.ebuild:
+ Version bump, security bug 294797
22 Oct 2009; Alex Legler <a3li@gentoo.org> -rails-1.2.6-r1.ebuild,
-rails-2.0.5-r1.ebuild, -rails-2.1.2-r1.ebuild:
diff --git a/dev-ruby/rails/rails-2.3.5.ebuild b/dev-ruby/rails/rails-2.3.5.ebuild
new file mode 100644
index 000000000000..fe1c06b3a6fc
--- /dev/null
+++ b/dev-ruby/rails/rails-2.3.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/rails-2.3.5.ebuild,v 1.1 2009/11/28 09:34:07 a3li Exp $
+
+inherit ruby gems
+USE_RUBY="ruby18 ruby19"
+
+DESCRIPTION="ruby on rails is a web-application and persistance framework"
+HOMEPAGE="http://www.rubyonrails.org"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="fastcgi"
+DEPEND=">=dev-lang/ruby-1.8.6
+ >=app-admin/eselect-rails-0.15
+ >=dev-ruby/rake-0.8.3
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/activeresource-${PV}
+ ~dev-ruby/activesupport-${PV}
+ ~dev-ruby/actionmailer-${PV}
+ ~dev-ruby/actionpack-${PV}"
+
+RDEPEND="${DEPEND}
+ fastcgi? ( >=dev-ruby/ruby-fcgi-0.8.6 )
+ >=dev-ruby/rubygems-1.3.2"
+
+src_install() {
+ gems_src_install
+ # Rename slotted files that may clash so that eselect can handle
+ # them
+ mv "${D}/usr/bin/rails" "${D}/usr/bin/rails-${PV}"
+ sed -i -e "s/>= 0/${PV}/" "${D}/usr/bin/rails-${PV}"
+ mv "${D}/${GEMSDIR}/bin/rails" "${D}/${GEMSDIR}/bin/rails-${PV}"
+}
+
+pkg_postinst() {
+ einfo "To select between slots of rails, use:"
+ einfo "\teselect rails"
+
+ eselect rails update
+}
+
+pkg_postrm() {
+ eselect rails update
+}