summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Legler <a3li@gentoo.org>2009-03-17 10:52:50 +0000
committerAlex Legler <a3li@gentoo.org>2009-03-17 10:52:50 +0000
commit139c0d9dedadcafa81f07d6f33d91c11654fdd18 (patch)
treeab9cb20a23673f92202ab991dd0e3d4eea20c9c5 /dev-ruby
parentm68k stable wrt #255244, thanks to kolla for testing (diff)
downloadhistorical-139c0d9dedadcafa81f07d6f33d91c11654fdd18.tar.gz
historical-139c0d9dedadcafa81f07d6f33d91c11654fdd18.tar.bz2
historical-139c0d9dedadcafa81f07d6f33d91c11654fdd18.zip
Version bump
Package-Manager: portage-2.2_rc25/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/activerecord/ChangeLog7
-rw-r--r--dev-ruby/activerecord/activerecord-2.3.2.ebuild22
-rw-r--r--dev-ruby/rails/ChangeLog7
-rw-r--r--dev-ruby/rails/rails-2.3.2.ebuild47
4 files changed, 81 insertions, 2 deletions
diff --git a/dev-ruby/activerecord/ChangeLog b/dev-ruby/activerecord/ChangeLog
index b817abef1ca7..1ecaf41d222e 100644
--- a/dev-ruby/activerecord/ChangeLog
+++ b/dev-ruby/activerecord/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activerecord
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.96 2009/01/10 16:31:50 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.97 2009/03/17 10:49:38 a3li Exp $
+
+*activerecord-2.3.2 (17 Mar 2009)
+
+ 17 Mar 2009; Alex Legler <a3li@gentoo.org> +activerecord-2.3.2.ebuild:
+ Version bump
10 Jan 2009; Raúl Porcel <armin76@gentoo.org> activerecord-2.2.2.ebuild:
ia64 stable wrt #253425
diff --git a/dev-ruby/activerecord/activerecord-2.3.2.ebuild b/dev-ruby/activerecord/activerecord-2.3.2.ebuild
new file mode 100644
index 000000000000..167c5da5a25e
--- /dev/null
+++ b/dev-ruby/activerecord/activerecord-2.3.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-2.3.2.ebuild,v 1.1 2009/03/17 10:49:38 a3li Exp $
+
+inherit ruby gems
+USE_RUBY="ruby18 ruby19"
+
+DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
+HOMEPAGE="http://rubyforge.org/projects/activerecord/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="mysql postgres sqlite sqlite3"
+RESTRICT="test"
+
+DEPEND=">=dev-lang/ruby-1.8.6
+ ~dev-ruby/activesupport-2.3.2
+ sqlite? ( >=dev-ruby/sqlite-ruby-2.2.2 )
+ sqlite3? ( dev-ruby/sqlite3-ruby )
+ mysql? ( >=dev-ruby/mysql-ruby-2.7 )
+ postgres? ( >=dev-ruby/ruby-postgres-0.7.1 )"
diff --git a/dev-ruby/rails/ChangeLog b/dev-ruby/rails/ChangeLog
index ace26dd0f1e1..1b7a577ce2c0 100644
--- a/dev-ruby/rails/ChangeLog
+++ b/dev-ruby/rails/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rails
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.131 2009/01/10 16:36:32 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.132 2009/03/17 10:52:50 a3li Exp $
+
+*rails-2.3.2 (17 Mar 2009)
+
+ 17 Mar 2009; Alex Legler <a3li@gentoo.org> +rails-2.3.2.ebuild:
+ Version bump
10 Jan 2009; Raúl Porcel <armin76@gentoo.org> rails-1.2.6-r1.ebuild,
rails-2.1.2-r1.ebuild, rails-2.2.2-r1.ebuild:
diff --git a/dev-ruby/rails/rails-2.3.2.ebuild b/dev-ruby/rails/rails-2.3.2.ebuild
new file mode 100644
index 000000000000..ad02a4c36a8f
--- /dev/null
+++ b/dev-ruby/rails/rails-2.3.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/rails-2.3.2.ebuild,v 1.1 2009/03/17 10:52:50 a3li Exp $
+
+inherit ruby gems
+USE_RUBY="ruby18 ruby19"
+
+DESCRIPTION="ruby on rails is a web-application and persistance framework"
+HOMEPAGE="http://www.rubyonrails.org"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="fastcgi"
+DEPEND=">=dev-lang/ruby-1.8.6
+ >=app-admin/eselect-rails-0.15
+ >=dev-ruby/rake-0.8.3
+ ~dev-ruby/activerecord-2.3.2
+ ~dev-ruby/activeresource-2.3.2
+ ~dev-ruby/activesupport-2.3.2
+ ~dev-ruby/actionmailer-2.3.2
+ ~dev-ruby/actionpack-2.3.2"
+
+RDEPEND="${DEPEND}
+ fastcgi? ( >=dev-ruby/ruby-fcgi-0.8.6 )
+ >=dev-ruby/rubygems-1.3.1"
+
+src_install() {
+ gems_src_install
+ # Rename slotted files that may clash so that eselect can handle
+ # them
+ mv "${D}/usr/bin/rails" "${D}/usr/bin/rails-${PV}"
+ sed -i -e "s/>= 0/${PV}/" "${D}/usr/bin/rails-${PV}"
+ mv "${D}/${GEMSDIR}/bin/rails" "${D}/${GEMSDIR}/bin/rails-${PV}"
+}
+
+pkg_postinst() {
+ einfo "To select between slots of rails, use:"
+ einfo "\teselect rails"
+
+ eselect rails update
+}
+
+pkg_postrm() {
+ eselect rails update
+}