summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-12-31 14:25:34 +0000
committerHans de Graaff <graaff@gentoo.org>2011-12-31 14:25:34 +0000
commitb140c6389e72067bd15cbab3366a5e6c58ec77c3 (patch)
tree7d76e0afbeb1b3055cb2fc4837819114c64b8a28 /dev-ruby/treetop/treetop-1.4.10-r1.ebuild
parentDrop ia64 support #345433 (diff)
downloadhistorical-b140c6389e72067bd15cbab3366a5e6c58ec77c3.tar.gz
historical-b140c6389e72067bd15cbab3366a5e6c58ec77c3.tar.bz2
historical-b140c6389e72067bd15cbab3366a5e6c58ec77c3.zip
Create revision bump and add ruby19 only there. Drop keywords due to lack of activesupport with ruby19, bug 396043.
Package-Manager: portage-2.1.10.41/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/treetop/treetop-1.4.10-r1.ebuild')
-rw-r--r--dev-ruby/treetop/treetop-1.4.10-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/treetop/treetop-1.4.10-r1.ebuild b/dev-ruby/treetop/treetop-1.4.10-r1.ebuild
new file mode 100644
index 000000000000..9b4bee5eda2c
--- /dev/null
+++ b/dev-ruby/treetop/treetop-1.4.10-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/treetop/treetop-1.4.10-r1.ebuild,v 1.1 2011/12/31 14:25:34 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ree18 ruby19"
+# jruby fails tests, not investigated yet.
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST="none"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Treetop is a language for describing languages."
+HOMEPAGE="http://treetop.rubyforge.org/"
+LICENSE="Ruby"
+
+KEYWORDS="~amd64 ~x86 ~sparc-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "test? ( >=dev-ruby/rr-0.10.2 dev-ruby/rspec:2 dev-ruby/activesupport )"
+ruby_add_rdepend ">=dev-ruby/polyglot-0.3.1"
+
+each_ruby_test() {
+ ${RUBY} -S rspec spec || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/*
+}