summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-12-28 08:24:41 +0000
committerHans de Graaff <graaff@gentoo.org>2011-12-28 08:24:41 +0000
commit92ea24f3b061aa99917a25d144921900b641016d (patch)
treefb161f34bd18890f4bd8057c97cf92d43e2e3d8f /dev-ruby/rspec
parentDrop ruby19 from stable version. (diff)
downloadhistorical-92ea24f3b061aa99917a25d144921900b641016d.tar.gz
historical-92ea24f3b061aa99917a25d144921900b641016d.tar.bz2
historical-92ea24f3b061aa99917a25d144921900b641016d.zip
Revision bump to drop ruby19 from stable version.
Package-Manager: portage-2.1.10.41/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/rspec')
-rw-r--r--dev-ruby/rspec/ChangeLog8
-rw-r--r--dev-ruby/rspec/rspec-2.6.0-r1.ebuild28
-rw-r--r--dev-ruby/rspec/rspec-2.6.0.ebuild4
3 files changed, 37 insertions, 3 deletions
diff --git a/dev-ruby/rspec/ChangeLog b/dev-ruby/rspec/ChangeLog
index e7bedee83343..b5c7c36a3eec 100644
--- a/dev-ruby/rspec/ChangeLog
+++ b/dev-ruby/rspec/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/rspec
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec/ChangeLog,v 1.110 2011/12/26 11:12:11 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec/ChangeLog,v 1.111 2011/12/28 08:24:41 graaff Exp $
+
+*rspec-2.6.0-r1 (28 Dec 2011)
+
+ 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> rspec-2.6.0.ebuild,
+ +rspec-2.6.0-r1.ebuild:
+ Revision bump to drop ruby19 from stable version.
26 Dec 2011; Hans de Graaff <graaff@gentoo.org> rspec-1.3.2.ebuild:
Fix tests for ruby19. Should also fix bug 340781.
diff --git a/dev-ruby/rspec/rspec-2.6.0-r1.ebuild b/dev-ruby/rspec/rspec-2.6.0-r1.ebuild
new file mode 100644
index 000000000000..6a3310b8223b
--- /dev/null
+++ b/dev-ruby/rspec/rspec-2.6.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec/rspec-2.6.0-r1.ebuild,v 1.1 2011/12/28 08:24:41 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="http://rspec.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+SUBVERSION="$(get_version_component_range 1-2)"
+
+ruby_add_rdepend "
+ =dev-ruby/rspec-core-${SUBVERSION}*
+ =dev-ruby/rspec-expectations-${SUBVERSION}*
+ =dev-ruby/rspec-mocks-${SUBVERSION}*"
diff --git a/dev-ruby/rspec/rspec-2.6.0.ebuild b/dev-ruby/rspec/rspec-2.6.0.ebuild
index 07aed9ed7a00..7b7a560d349a 100644
--- a/dev-ruby/rspec/rspec-2.6.0.ebuild
+++ b/dev-ruby/rspec/rspec-2.6.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec/rspec-2.6.0.ebuild,v 1.10 2011/10/02 17:07:15 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec/rspec-2.6.0.ebuild,v 1.11 2011/12/28 08:24:41 graaff Exp $
EAPI=2
-USE_RUBY="ruby18 ruby19 ree18 jruby"
+USE_RUBY="ruby18 ree18 jruby"
RUBY_FAKEGEM_TASK_TEST=""