summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-10-04 19:56:57 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-10-04 19:56:57 +0000
commitdfaec888ba36bbf6d54244e2f2ef4b7034616718 (patch)
tree59e87e61c94a782daf4639723ce1e9d832699666 /dev-ruby/prawn-table/prawn-table-0.2.0.ebuild
parentAdd upstream metadata tag. (diff)
downloadhistorical-dfaec888ba36bbf6d54244e2f2ef4b7034616718.tar.gz
historical-dfaec888ba36bbf6d54244e2f2ef4b7034616718.tar.bz2
historical-dfaec888ba36bbf6d54244e2f2ef4b7034616718.zip
Version bump.
Package-Manager: portage-2.2.14_rc1/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/prawn-table/prawn-table-0.2.0.ebuild')
-rw-r--r--dev-ruby/prawn-table/prawn-table-0.2.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/prawn-table/prawn-table-0.2.0.ebuild b/dev-ruby/prawn-table/prawn-table-0.2.0.ebuild
new file mode 100644
index 000000000000..73661b05074c
--- /dev/null
+++ b/dev-ruby/prawn-table/prawn-table-0.2.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/prawn-table/prawn-table-0.2.0.ebuild,v 1.1 2014/10/04 19:56:53 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides support for tables in Prawn"
+HOMEPAGE="http://prawn.majesticseacreature.com/"
+LICENSE="|| ( GPL-2+ Ruby )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/mocha
+ >=dev-ruby/pdf-inspector-1.1.0
+ >=dev-ruby/pdf-reader-1.2
+ >=dev-ruby/prawn-1.3.0
+ )"
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/s/^/#/" spec/spec_helper.rb || die
+ # Remove failing test
+ # See https://github.com/prawnpdf/prawn-table/issues/10
+ sed -i -e "/Prints table on one page when using subtable with colspan > 1/,+24 s/^/#/" spec/table_spec.rb || die
+}