summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-12-28 08:06:26 +0000
committerHans de Graaff <graaff@gentoo.org>2010-12-28 08:06:26 +0000
commit36d6c233438175987b63b0d9dba30732cae1b105 (patch)
tree54d2396059f2a00c48e1181d16e33010d59aa246 /dev-ruby/osmlib-base/osmlib-base-0.1.4-r1.ebuild
parentFix include path for script, thanks for James le Cuirot for the patch. (diff)
downloadhistorical-36d6c233438175987b63b0d9dba30732cae1b105.tar.gz
historical-36d6c233438175987b63b0d9dba30732cae1b105.tar.bz2
historical-36d6c233438175987b63b0d9dba30732cae1b105.zip
Provide missing file for tests. Restrict tests due to additional failure,
bug 339903. Package-Manager: portage-2.1.9.25/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/osmlib-base/osmlib-base-0.1.4-r1.ebuild')
-rw-r--r--dev-ruby/osmlib-base/osmlib-base-0.1.4-r1.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-ruby/osmlib-base/osmlib-base-0.1.4-r1.ebuild b/dev-ruby/osmlib-base/osmlib-base-0.1.4-r1.ebuild
index 8d2041428907..5acce11ec041 100644
--- a/dev-ruby/osmlib-base/osmlib-base-0.1.4-r1.ebuild
+++ b/dev-ruby/osmlib-base/osmlib-base-0.1.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/osmlib-base/osmlib-base-0.1.4-r1.ebuild,v 1.2 2010/08/15 22:16:21 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/osmlib-base/osmlib-base-0.1.4-r1.ebuild,v 1.3 2010/12/28 08:06:26 graaff Exp $
EAPI=2
@@ -23,11 +23,18 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
+RESTRICT="test"
+
ruby_add_rdepend ">=dev-ruby/libxml-0.5.4
dev-ruby/GeoRuby"
ruby_add_bdepend "test? ( dev-ruby/builder )"
+all_ruby_prepare() {
+ # Add test file missing from gem distribution
+ cp "${FILESDIR}"/test.osm test/ || die "Unable to copy test.osm"
+}
+
all_ruby_install() {
all_fakegem_install