summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-08-28 05:26:15 +0000
committerHans de Graaff <graaff@gentoo.org>2012-08-28 05:26:15 +0000
commit25944f173517affdf3bc6ce3c1f3ebd04d72531d (patch)
treea1bcb33f8308f2892278d91a5b1f75401221b344 /dev-ruby/multi_json
parentCleanup. (diff)
downloadhistorical-25944f173517affdf3bc6ce3c1f3ebd04d72531d.tar.gz
historical-25944f173517affdf3bc6ce3c1f3ebd04d72531d.tar.bz2
historical-25944f173517affdf3bc6ce3c1f3ebd04d72531d.zip
Cleanup.
Package-Manager: portage-2.1.11.9/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/multi_json')
-rw-r--r--dev-ruby/multi_json/ChangeLog6
-rw-r--r--dev-ruby/multi_json/multi_json-1.0.4.ebuild47
-rw-r--r--dev-ruby/multi_json/multi_json-1.2.0.ebuild53
-rw-r--r--dev-ruby/multi_json/multi_json-1.3.4.ebuild53
-rw-r--r--dev-ruby/multi_json/multi_json-1.3.5.ebuild53
5 files changed, 5 insertions, 207 deletions
diff --git a/dev-ruby/multi_json/ChangeLog b/dev-ruby/multi_json/ChangeLog
index 8b1af68789e0..b566e1881461 100644
--- a/dev-ruby/multi_json/ChangeLog
+++ b/dev-ruby/multi_json/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/multi_json
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_json/ChangeLog,v 1.21 2012/07/05 23:03:34 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_json/ChangeLog,v 1.22 2012/08/28 05:23:13 graaff Exp $
+
+ 28 Aug 2012; Hans de Graaff <graaff@gentoo.org> -multi_json-1.0.4.ebuild,
+ -multi_json-1.2.0.ebuild, -multi_json-1.3.4.ebuild, -multi_json-1.3.5.ebuild:
+ Cleanup.
*multi_json-1.3.6 (05 Jul 2012)
diff --git a/dev-ruby/multi_json/multi_json-1.0.4.ebuild b/dev-ruby/multi_json/multi_json-1.0.4.ebuild
deleted file mode 100644
index 3d90557aeca5..000000000000
--- a/dev-ruby/multi_json/multi_json-1.0.4.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_json/multi_json-1.0.4.ebuild,v 1.8 2012/03/11 13:07:26 ranger Exp $
-
-EAPI=2
-
-USE_RUBY="ruby18 ruby19 ree18 jruby"
-
-RUBY_FAKEGEM_TASK_TEST="spec"
-RUBY_FAKEGEM_TASK_DOC="doc:rdoc"
-
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-RUBY_FAKEGEM_GEMSPEC="multi_json.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A gem to provide swappable JSON backends"
-HOMEPAGE="http://github.com/intridea/multi_json"
-LICENSE="MIT"
-
-KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-SLOT="0"
-IUSE=""
-
-ruby_add_rdepend "|| ( >=dev-ruby/json-1.4 >=dev-ruby/yajl-ruby-0.7 =dev-ruby/activesupport-3* )"
-
-ruby_add_bdepend "doc? ( dev-ruby/rspec:2 )"
-
-ruby_add_bdepend "test? ( dev-ruby/rspec:2 dev-ruby/json )"
-
-USE_RUBY=ruby18 ruby_add_bdepend "test? ( dev-ruby/yajl-ruby )"
-USE_RUBY=ruby19 ruby_add_bdepend "test? ( dev-ruby/yajl-ruby )"
-USE_RUBY=ree18 ruby_add_bdepend "test? ( dev-ruby/yajl-ruby )"
-
-all_ruby_prepare() {
- sed -i -e '/[Bb]undler/d' Rakefile spec/helper.rb || die "Unable to remove bundler."
- rm Gemfile || die "Unable to remove bundler Gemfile."
-
- # Remove simplecov support since we only care about the test results
- # and this avoids another dependency.
- sed -i -e '/[Ss]imple[Cc]ov/d' spec/helper.rb || die
-
- # Provide version otherwise provided by bundler.
- sed -i -e "s/#{MultiJson::VERSION}/${PV}/" Rakefile || die
-}
diff --git a/dev-ruby/multi_json/multi_json-1.2.0.ebuild b/dev-ruby/multi_json/multi_json-1.2.0.ebuild
deleted file mode 100644
index fff5a1041af8..000000000000
--- a/dev-ruby/multi_json/multi_json-1.2.0.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_json/multi_json-1.2.0.ebuild,v 1.1 2012/04/09 12:44:10 graaff Exp $
-
-EAPI=2
-
-USE_RUBY="ruby18 ruby19 ree18 jruby"
-
-RUBY_FAKEGEM_TASK_TEST="spec"
-RUBY_FAKEGEM_TASK_DOC="doc:rdoc"
-
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-RUBY_FAKEGEM_GEMSPEC="multi_json.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A gem to provide swappable JSON backends"
-HOMEPAGE="http://github.com/intridea/multi_json"
-LICENSE="MIT"
-
-KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-SLOT="0"
-IUSE=""
-
-ruby_add_rdepend "|| ( >=dev-ruby/json-1.4 >=dev-ruby/yajl-ruby-0.7 =dev-ruby/activesupport-3* )"
-
-ruby_add_bdepend "doc? ( dev-ruby/rspec:2 )"
-
-ruby_add_bdepend "test? ( dev-ruby/rspec:2 dev-ruby/json )"
-
-USE_RUBY=ruby18 ruby_add_bdepend "test? ( dev-ruby/yajl-ruby )"
-USE_RUBY=ruby19 ruby_add_bdepend "test? ( dev-ruby/yajl-ruby )"
-USE_RUBY=ree18 ruby_add_bdepend "test? ( dev-ruby/yajl-ruby )"
-
-all_ruby_prepare() {
- sed -i -e '/[Bb]undler/d' Rakefile spec/helper.rb || die "Unable to remove bundler."
- rm Gemfile || die "Unable to remove bundler Gemfile."
-
- # Remove simplecov support since we only care about the test results
- # and this avoids another dependency.
- sed -i -e '/[Ss]imple[Cc]ov/d' spec/helper.rb || die
-
- # Provide version otherwise provided by bundler.
- sed -i -e "s/#{MultiJson::VERSION}/${PV}/" Rakefile || die
-
- # Remove unimportant rspec options not supported by rspec 2.6.
- rm .rspec || die
-
- # Remove best default spec since we don't package oj yet.
- sed -i -e '/defaults to the best available gem/,/^ end/ s:^:#:' spec/multi_json_spec.rb || die
-}
diff --git a/dev-ruby/multi_json/multi_json-1.3.4.ebuild b/dev-ruby/multi_json/multi_json-1.3.4.ebuild
deleted file mode 100644
index ab24ce2d05d7..000000000000
--- a/dev-ruby/multi_json/multi_json-1.3.4.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_json/multi_json-1.3.4.ebuild,v 1.1 2012/05/07 11:41:29 graaff Exp $
-
-EAPI=2
-
-USE_RUBY="ruby18 ruby19 ree18 jruby"
-
-RUBY_FAKEGEM_TASK_TEST="spec"
-RUBY_FAKEGEM_TASK_DOC="doc:rdoc"
-
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-RUBY_FAKEGEM_GEMSPEC="multi_json.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A gem to provide swappable JSON backends"
-HOMEPAGE="http://github.com/intridea/multi_json"
-LICENSE="MIT"
-
-KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-SLOT="0"
-IUSE=""
-
-ruby_add_rdepend "|| ( >=dev-ruby/json-1.4 >=dev-ruby/yajl-ruby-0.7 =dev-ruby/activesupport-3* )"
-
-ruby_add_bdepend "doc? ( dev-ruby/rspec:2 )"
-
-ruby_add_bdepend "test? ( dev-ruby/rspec:2 dev-ruby/json )"
-
-USE_RUBY=ruby18 ruby_add_bdepend "test? ( dev-ruby/yajl-ruby )"
-USE_RUBY=ruby19 ruby_add_bdepend "test? ( dev-ruby/yajl-ruby )"
-USE_RUBY=ree18 ruby_add_bdepend "test? ( dev-ruby/yajl-ruby )"
-
-all_ruby_prepare() {
- sed -i -e '/[Bb]undler/d' Rakefile spec/helper.rb || die "Unable to remove bundler."
- rm Gemfile || die "Unable to remove bundler Gemfile."
-
- # Provide version otherwise provided by bundler.
- sed -i -e "s/#{MultiJson::VERSION}/${PV}/" Rakefile || die
-
- # Remove unimportant rspec options not supported by rspec 2.6.
- rm .rspec || die
-
- # Remove best default spec since we don't package oj yet.
- sed -i -e '/defaults to the best available gem/,/^ end/ s:^:#:' spec/multi_json_spec.rb || die
-}
-
-each_ruby_test() {
- CI=true ${RUBY} -S rspec spec || die
-}
diff --git a/dev-ruby/multi_json/multi_json-1.3.5.ebuild b/dev-ruby/multi_json/multi_json-1.3.5.ebuild
deleted file mode 100644
index 96a73a852c70..000000000000
--- a/dev-ruby/multi_json/multi_json-1.3.5.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_json/multi_json-1.3.5.ebuild,v 1.1 2012/05/17 11:45:37 graaff Exp $
-
-EAPI=4
-
-USE_RUBY="ruby18 ruby19 ree18 jruby"
-
-RUBY_FAKEGEM_TASK_TEST="spec"
-RUBY_FAKEGEM_TASK_DOC="doc:rdoc"
-
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-RUBY_FAKEGEM_GEMSPEC="multi_json.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A gem to provide swappable JSON backends"
-HOMEPAGE="http://github.com/intridea/multi_json"
-LICENSE="MIT"
-
-KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-SLOT="0"
-IUSE=""
-
-ruby_add_rdepend "|| ( >=dev-ruby/json-1.4 >=dev-ruby/yajl-ruby-0.7 =dev-ruby/activesupport-3* )"
-
-ruby_add_bdepend "doc? ( dev-ruby/rspec:2 )"
-
-ruby_add_bdepend "test? ( dev-ruby/rspec:2 dev-ruby/json )"
-
-USE_RUBY=ruby18 ruby_add_bdepend "test? ( dev-ruby/yajl-ruby )"
-USE_RUBY=ruby19 ruby_add_bdepend "test? ( dev-ruby/yajl-ruby )"
-USE_RUBY=ree18 ruby_add_bdepend "test? ( dev-ruby/yajl-ruby )"
-
-all_ruby_prepare() {
- sed -i -e '/[Bb]undler/d' Rakefile spec/helper.rb || die "Unable to remove bundler."
- rm Gemfile || die "Unable to remove bundler Gemfile."
-
- # Provide version otherwise provided by bundler.
- sed -i -e "s/#{MultiJson::VERSION}/${PV}/" Rakefile || die
-
- # Remove unimportant rspec options not supported by rspec 2.6.
- rm .rspec || die
-
- # Remove best default spec since we don't package oj yet.
- sed -i -e '/defaults to the best available gem/,/^ end/ s:^:#:' spec/multi_json_spec.rb || die
-}
-
-each_ruby_test() {
- CI=true ${RUBY} -S rspec spec || die
-}