summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-08-10 04:59:14 +0000
committerHans de Graaff <graaff@gentoo.org>2011-08-10 04:59:14 +0000
commitd20355fac14605c440c1203fec03fa663f67d216 (patch)
treea2b8c1ce89af8658bf6ff184ff2b4f3b68677773 /dev-ruby/libxml
parentVersion bump (diff)
downloadhistorical-d20355fac14605c440c1203fec03fa663f67d216.tar.gz
historical-d20355fac14605c440c1203fec03fa663f67d216.tar.bz2
historical-d20355fac14605c440c1203fec03fa663f67d216.zip
Version bump.
Package-Manager: portage-2.1.10.3/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/libxml')
-rw-r--r--dev-ruby/libxml/ChangeLog7
-rw-r--r--dev-ruby/libxml/libxml-2.2.0.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/dev-ruby/libxml/ChangeLog b/dev-ruby/libxml/ChangeLog
index de525f129544..bdcefeb02a31 100644
--- a/dev-ruby/libxml/ChangeLog
+++ b/dev-ruby/libxml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/libxml
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/libxml/ChangeLog,v 1.47 2011/08/04 06:03:25 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/libxml/ChangeLog,v 1.48 2011/08/10 04:59:14 graaff Exp $
+
+*libxml-2.2.0 (10 Aug 2011)
+
+ 10 Aug 2011; Hans de Graaff <graaff@gentoo.org> +libxml-2.2.0.ebuild:
+ Version bump.
*libxml-2.1.2 (04 Aug 2011)
diff --git a/dev-ruby/libxml/libxml-2.2.0.ebuild b/dev-ruby/libxml/libxml-2.2.0.ebuild
new file mode 100644
index 000000000000..cf99b8074711
--- /dev/null
+++ b/dev-ruby/libxml/libxml-2.2.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/libxml/libxml-2.2.0.ebuild,v 1.1 2011/08/10 04:59:14 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18 ruby19"
+
+RUBY_FAKEGEM_NAME="libxml-ruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc HISTORY"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby libxml with a user friendly API, akin to REXML, but feature complete and significantly faster."
+HOMEPAGE="http://libxml.rubyforge.org"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="${RDEPEND} dev-libs/libxml2"
+DEPEND="${DEPEND} dev-libs/libxml2"
+
+all_ruby_prepare() {
+ # Remove grancher tasks only needed for publishing the website
+ sed -i -e '/grancher/d' -e '/Grancher/,$d' Rakefile || die
+
+ # We don't have the hanna template available.
+ sed -i -e 's/hanna/rake/' Rakefile || die
+
+ # Remove rake-compiler bits since we don't use it
+ sed -i -e '/extensiontask/d' -e '/ExtensionTask/,/end/d' -e '/GemPackageTask/,/end/d' Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -C ext/libxml extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -C ext/libxml
+ cp ext/libxml/libxml_ruby.so lib/ || die
+}
+
+each_ruby_test() {
+ # The test suite needs to load its files in alphabetical order but
+ # this is not guaranteed. See bug 370501.
+ ${RUBY} -Ilib -r test/test_helper.rb test/test_suite.rb || die
+}