summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-05-24 08:52:19 +0000
committerHans de Graaff <graaff@gentoo.org>2011-05-24 08:52:19 +0000
commiteef6cf3282f055ef55c1a2f017121134d7cd7d1c (patch)
tree5f41048fad5bb5addbdb8a9bcc554c95cc9e6fdf /dev-ruby/hashie/hashie-1.0.0.ebuild
parentVersion bump. (diff)
downloadhistorical-eef6cf3282f055ef55c1a2f017121134d7cd7d1c.tar.gz
historical-eef6cf3282f055ef55c1a2f017121134d7cd7d1c.tar.bz2
historical-eef6cf3282f055ef55c1a2f017121134d7cd7d1c.zip
Version bump.
Package-Manager: portage-2.1.9.42/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/hashie/hashie-1.0.0.ebuild')
-rw-r--r--dev-ruby/hashie/hashie-1.0.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/hashie/hashie-1.0.0.ebuild b/dev-ruby/hashie/hashie-1.0.0.ebuild
new file mode 100644
index 000000000000..d378dab899d8
--- /dev/null
+++ b/dev-ruby/hashie/hashie-1.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hashie/hashie-1.0.0.ebuild,v 1.1 2011/05/24 08:52:19 graaff Exp $
+
+EAPI="2"
+USE_RUBY="ruby18 ruby19 jruby ree18"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Hashie is a small collection of tools that make hashes more powerful."
+HOMEPAGE="http://intridea.com/posts/hashie-the-hash-toolkit"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/rspec:2 dev-ruby/json )"
+
+each_ruby_prepare() {
+ # Remove bundler
+ rm Gemfile Gemfile.lock || die
+}