summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Verwilst <verwilst@gentoo.org>2002-09-17 17:24:11 +0000
committerBart Verwilst <verwilst@gentoo.org>2002-09-17 17:24:11 +0000
commitcd2fa28b0c3648ad3d10e689046cb67b49e0be53 (patch)
tree1b05529e2b4e57c2efab12b2b48fb1f0e7f8e94e /dev-python
parentYet another utility that works on PPC. (diff)
downloadhistorical-cd2fa28b0c3648ad3d10e689046cb67b49e0be53.tar.gz
historical-cd2fa28b0c3648ad3d10e689046cb67b49e0be53.tar.bz2
historical-cd2fa28b0c3648ad3d10e689046cb67b49e0be53.zip
new version, masked
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/PyQt/ChangeLog4
-rw-r--r--dev-python/PyQt/PyQt-3.4.ebuild45
-rw-r--r--dev-python/PyQt/files/digest-PyQt-3.41
3 files changed, 49 insertions, 1 deletions
diff --git a/dev-python/PyQt/ChangeLog b/dev-python/PyQt/ChangeLog
index 1e2702e40817..ffb5fcccbeed 100644
--- a/dev-python/PyQt/ChangeLog
+++ b/dev-python/PyQt/ChangeLog
@@ -1,6 +1,8 @@
# ChangeLog for dev-python/PyQt
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/ChangeLog,v 1.4 2002/08/13 02:41:27 verwilst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/ChangeLog,v 1.5 2002/09/17 17:24:11 verwilst Exp $
+
+*PyQt-3.4 (17 Sept 2002) Bart Verwilst <verwilst@gentoo.org>
*PyQt-3.3.2 (25 July 2002) Bart Verwilst <verwilst@gentoo.org>
diff --git a/dev-python/PyQt/PyQt-3.4.ebuild b/dev-python/PyQt/PyQt-3.4.ebuild
new file mode 100644
index 000000000000..ecd9a73a6abf
--- /dev/null
+++ b/dev-python/PyQt/PyQt-3.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.4.ebuild,v 1.1 2002/09/17 17:24:11 verwilst Exp $
+
+S="${WORKDIR}/PyQt-x11-gpl-${PV}"
+DESCRIPTION="PyQt is a set of Python bindings for the QT 3.x Toolkit"
+SRC_URI="http://www.river-bank.demon.co.uk/download/PyQt/PyQt-x11-gpl-${PV}.tar.gz"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/pyqt/"
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="x86 sparc sparc64"
+DEPEND="virtual/glibc
+ sys-devel/libtool
+ >=x11-libs/qt-3.0.4.1
+ >=dev-lang/python-2.2.1
+ =dev-python/sip-3.4"
+
+src_compile() {
+
+ cd ${S}
+ mkdir -p ${D}/usr/lib/python2.2/site-packages
+ mkdir -p ${D}/usr/include/python2.2
+ python build.py \
+ -d ${D}/usr/lib/python2.2/site-packages \
+ -e /usr/include/python2.2 \
+ -b ${D}/usr/bin \
+ -l qt-mt -c
+ make
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+ make DESTDIR=${D} install-eric || die
+ dodoc README.Linux NEWS LICENSE README ChangeLog THANKS
+ echo "#!/bin/sh" > ${D}/usr/bin/eric
+ echo " " >> ${D}/usr/bin/eric
+ echo "exec python /usr/lib/python2.2/site-packages/eric/eric.py $*" >> ${D}/usr/bin/eric
+ chmod +x ${D}/usr/bin/eric
+ mkdir -p ${D}/usr/share/doc/${P}/
+ mv ${D}/usr/share/doc/* ${D}/usr/share/doc/${P}/
+
+}
+
+
diff --git a/dev-python/PyQt/files/digest-PyQt-3.4 b/dev-python/PyQt/files/digest-PyQt-3.4
new file mode 100644
index 000000000000..cc7e76cb280a
--- /dev/null
+++ b/dev-python/PyQt/files/digest-PyQt-3.4
@@ -0,0 +1 @@
+MD5 1a61c55ad716f20f52883740c578c352 PyQt-x11-gpl-3.4.tar.gz 711859