summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-18 17:51:02 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-18 17:51:02 +0000
commit62dae1adad56ff5b98446738d7230c002395b28a (patch)
tree93255f8cee34fe26d7273de3e73c88c077a469e9 /dev-python
parentUse PYTHON_DEPEND instead of NEED_PYTHON. (diff)
downloadhistorical-62dae1adad56ff5b98446738d7230c002395b28a.tar.gz
historical-62dae1adad56ff5b98446738d7230c002395b28a.tar.bz2
historical-62dae1adad56ff5b98446738d7230c002395b28a.zip
Delete older ebuilds.
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pycairo/pycairo-1.4.12.ebuild48
-rw-r--r--dev-python/pycairo/pycairo-1.8.2.ebuild48
-rw-r--r--dev-python/pycairo/pycairo-1.8.4.ebuild48
-rw-r--r--dev-python/pycairo/pycairo-1.8.6.ebuild73
4 files changed, 0 insertions, 217 deletions
diff --git a/dev-python/pycairo/pycairo-1.4.12.ebuild b/dev-python/pycairo/pycairo-1.4.12.ebuild
deleted file mode 100644
index 0054353727f4..000000000000
--- a/dev-python/pycairo/pycairo-1.4.12.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/pycairo-1.4.12.ebuild,v 1.8 2008/11/10 11:33:19 armin76 Exp $
-
-NEED_PYTHON=2.4
-
-inherit distutils
-
-DESCRIPTION="Python wrapper for cairo vector graphics library"
-HOMEPAGE="http://cairographics.org/pycairo/"
-SRC_URI="http://cairographics.org/releases/${P}.tar.gz"
-
-LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd"
-IUSE="examples"
-
-RDEPEND=">=x11-libs/cairo-1.4.12"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-PYTHON_MODNAME="cairo"
-DOCS="AUTHORS doc/*"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # don't run py-compile
- sed -i \
- -e '/if test -n "$$dlist"; then/,/else :; fi/d' \
- cairo/Makefile.in || die "sed in cairo/Makefile.in failed"
-}
-
-src_install() {
- distutils_src_install
-
- if use examples ; then
- insinto /usr/share/doc/${PF}/examples
- doins -r examples/*
- rm "${D}"/usr/share/doc/${PF}/examples/Makefile*
- fi
-}
-
-src_test() {
- cd test
- PYTHONPATH="$(ls -d ${S}/build/lib.*)" "${python}" test.py || die "tests failed"
-}
diff --git a/dev-python/pycairo/pycairo-1.8.2.ebuild b/dev-python/pycairo/pycairo-1.8.2.ebuild
deleted file mode 100644
index 142bbfdacbbc..000000000000
--- a/dev-python/pycairo/pycairo-1.8.2.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/pycairo-1.8.2.ebuild,v 1.7 2009/05/01 16:44:06 armin76 Exp $
-
-NEED_PYTHON=2.5
-
-inherit distutils
-
-DESCRIPTION="Python wrapper for cairo vector graphics library"
-HOMEPAGE="http://cairographics.org/pycairo/"
-SRC_URI="http://cairographics.org/releases/${P}.tar.gz"
-
-LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd"
-IUSE="examples"
-
-RDEPEND=">=x11-libs/cairo-1.8.2"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-PYTHON_MODNAME="cairo"
-DOCS="AUTHORS doc/*"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # don't run py-compile
- sed -i \
- -e '/if test -n "$$dlist"; then/,/else :; fi/d' \
- cairo/Makefile.in || die "sed in cairo/Makefile.in failed"
-}
-
-src_install() {
- distutils_src_install
-
- if use examples ; then
- insinto /usr/share/doc/${PF}/examples
- doins -r examples/*
- rm "${D}"/usr/share/doc/${PF}/examples/Makefile*
- fi
-}
-
-src_test() {
- cd test
- PYTHONPATH="$(ls -d ${S}/build/lib.*)" "${python}" test.py || die "tests failed"
-}
diff --git a/dev-python/pycairo/pycairo-1.8.4.ebuild b/dev-python/pycairo/pycairo-1.8.4.ebuild
deleted file mode 100644
index 1da561867def..000000000000
--- a/dev-python/pycairo/pycairo-1.8.4.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/pycairo-1.8.4.ebuild,v 1.1 2009/04/25 16:25:19 arfrever Exp $
-
-NEED_PYTHON=2.6
-
-inherit distutils
-
-DESCRIPTION="Python wrapper for cairo vector graphics library"
-HOMEPAGE="http://cairographics.org/pycairo/"
-SRC_URI="http://cairographics.org/releases/${P}.tar.gz"
-
-LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="examples"
-
-RDEPEND=">=x11-libs/cairo-1.8.4"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-PYTHON_MODNAME="cairo"
-DOCS="AUTHORS NEWS doc/*"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # don't run py-compile
- sed -i \
- -e '/if test -n "$$dlist"; then/,/else :; fi/d' \
- cairo/Makefile.in || die "sed in cairo/Makefile.in failed"
-}
-
-src_install() {
- distutils_src_install
-
- if use examples ; then
- insinto /usr/share/doc/${PF}/examples
- doins -r examples/*
- rm "${D}"/usr/share/doc/${PF}/examples/Makefile*
- fi
-}
-
-src_test() {
- cd test
- PYTHONPATH="$(ls -d ${S}/build/lib.*)" "${python}" test.py || die "tests failed"
-}
diff --git a/dev-python/pycairo/pycairo-1.8.6.ebuild b/dev-python/pycairo/pycairo-1.8.6.ebuild
deleted file mode 100644
index c188e7b35fd7..000000000000
--- a/dev-python/pycairo/pycairo-1.8.6.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/pycairo-1.8.6.ebuild,v 1.3 2009/08/08 20:36:20 arfrever Exp $
-
-EAPI="2"
-
-NEED_PYTHON="2.6"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils
-
-DESCRIPTION="Python wrapper for cairo vector graphics library"
-HOMEPAGE="http://cairographics.org/pycairo/"
-SRC_URI="http://cairographics.org/releases/${P}.tar.gz"
-
-LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="doc examples"
-
-RDEPEND=">=x11-libs/cairo-1.8.6"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- doc? ( dev-python/sphinx )"
-
-RESTRICT_PYTHON_ABIS="2.4 2.5 3*"
-
-PYTHON_MODNAME="cairo"
-DOCS="AUTHORS NEWS README"
-
-src_prepare() {
- # Don't run py-compile.
- sed -i \
- -e '/if test -n "$$dlist"; then/,/else :; fi/d' \
- cairo/Makefile.in || die "sed in cairo/Makefile.in failed"
-}
-
-src_configure() {
- if use doc; then
- econf
- fi
-}
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- emake html || die "emake html failed"
- fi
-}
-
-src_test() {
- testing() {
- pushd test > /dev/null
- PYTHONPATH="$(ls -d ../build-${PYTHON_ABI}/lib.*)" "$(PYTHON)" test.py || return 1
- popd > /dev/null
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -r doc/.build/html/ || die "dohtml -r doc/.build/html/ failed"
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r examples/*
- rm "${D}"/usr/share/doc/${PF}/examples/Makefile*
- fi
-}