summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2010-09-30 07:46:01 +0000
committerFabian Groffen <grobian@gentoo.org>2010-09-30 07:46:01 +0000
commit5d949475bafb2957ac8b77fed2ec26fe7c0df017 (patch)
tree20fca9a25db91157816cbf06e9ce1c46a5194987 /dev-python
parentMarked ~x86-solaris (diff)
downloadhistorical-5d949475bafb2957ac8b77fed2ec26fe7c0df017.tar.gz
historical-5d949475bafb2957ac8b77fed2ec26fe7c0df017.tar.bz2
historical-5d949475bafb2957ac8b77fed2ec26fe7c0df017.zip
Fixed pycxx detection in Prefix, thanks Martin Zibricky in bug #338895, marked ~x86-solaris
Package-Manager: portage-2.2.01.16711-prefix/cvs/SunOS i386
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pysvn/ChangeLog5
-rw-r--r--dev-python/pysvn/pysvn-1.7.2.ebuild10
2 files changed, 11 insertions, 4 deletions
diff --git a/dev-python/pysvn/ChangeLog b/dev-python/pysvn/ChangeLog
index a00913663dd2..1cdc075a8472 100644
--- a/dev-python/pysvn/ChangeLog
+++ b/dev-python/pysvn/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/pysvn
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pysvn/ChangeLog,v 1.9 2010/06/22 18:38:00 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysvn/ChangeLog,v 1.10 2010/09/30 07:46:01 grobian Exp $
+
+ 30 Sep 2010; Fabian Groffen <grobian@gentoo.org> pysvn-1.7.2.ebuild:
+ Fixed pycxx detection in Prefix, marked ~x86-solaris
22 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
pysvn-1.7.2.ebuild:
diff --git a/dev-python/pysvn/pysvn-1.7.2.ebuild b/dev-python/pysvn/pysvn-1.7.2.ebuild
index 1fbdf7ace869..24867292b458 100644
--- a/dev-python/pysvn/pysvn-1.7.2.ebuild
+++ b/dev-python/pysvn/pysvn-1.7.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pysvn/pysvn-1.7.2.ebuild,v 1.4 2010/06/22 18:38:00 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysvn/pysvn-1.7.2.ebuild,v 1.5 2010/09/30 07:46:01 grobian Exp $
EAPI="3"
SUPPORT_PYTHON_ABIS="1"
@@ -13,7 +13,7 @@ SRC_URI="http://pysvn.barrys-emacs.org/source_kits/${P}.tar.gz"
LICENSE="Apache-1.1"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~x86-freebsd ~ppc-macos"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-freebsd ~ppc-macos ~x86-solaris"
IUSE="doc examples"
DEPEND="dev-lang/python
@@ -42,7 +42,11 @@ src_prepare() {
src_configure() {
configuration() {
cd Source
- "$(PYTHON)" setup.py configure --apr-inc-dir="${EPREFIX}/usr/include/apr-1" --svn-root-dir="${EPREFIX}/usr" || die "Configuration failed with Python {PYTHON_ABI}"
+ "$(PYTHON)" setup.py configure \
+ --pycxx-src-dir="${EPREFIX}/usr/share/python${PYTHON_ABI}/CXX" \
+ --apr-inc-dir="${EPREFIX}/usr/include/apr-1" \
+ --svn-root-dir="${EPREFIX}/usr" \
+ || die "Configuration failed with Python {PYTHON_ABI}"
sed -e 's:^\(CCFLAGS=\)\(.*\):\1$(CFLAGS) \2:g' \
-e 's:^\(CCCFLAGS=\)\(.*\):\1$(CXXFLAGS) \2:g' \